Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

0
votes
1answer
32 views

wygwam error after move of server

I am new to ExpressEngine. One of my clients has a website built in EE by another developer. We have just moved the site to a new server, and now we are getting the following errors, if anyone can ...
0
votes
0answers
10 views

non unicode characters re breaking gwcode_categories plugin

does anyone have a plugin or advice to fix non unicode characters in entries? I have a french site and when an entry uses a character like â it totally breaks my code. In particular it breaks ...
0
votes
1answer
27 views

Wygwam character limit for Cyrillic text

I'm finding that Cyrillic text entered into a Wygwam field is truncated. Is this because there is a limit for character rendered in unicode?
0
votes
1answer
53 views

Have WYGWAM image insert be able to select from multiple directories

I am currently using WYGWAM 3.3.3 with EE 2.11.1. I have WYGWAM using EE's file manager. Currently with file manager there are 6 different folders they can upload images and pdf's to. When they ...
0
votes
2answers
110 views

Adding CKEditor Plugins to Wygwam 4.0.9 in EE3

I'm attempting to add a CKEditor plugin to Wygwam 4.0.9 in EE3, but the documentation I found in pixelandtonic and wygwam docs showing wrong upload folders. There is no such folders as themes/...
1
vote
1answer
115 views

Transcribe + Wygwam + Structure links not working

When adding Structure Links to a wygwam field on a Transcribe entry that's not the default language, they are being rendered like this: <a href="{page_168}"> More info: I have a Transcribe ...
0
votes
1answer
53 views

EE3 structure remove index.php

When adding link "using structure page link type" via backend (wygwam) all links include index.php automatically, is this a bug?
1
vote
2answers
297 views

Need a regex ninja's help with replacing a YouTube string

I'm looking for some help with replacing YouTube embed codes with something that can be used with AMP pages https://www.ampproject.org/ Example, we would like replace this: <iframe ...
0
votes
2answers
171 views

Changing the <img> tag with CE Image?

So if you may or may not know, Google rolled out Amp'd pages and displaying these websites that are 'Amp ready' higher on the search results. Without getting into the details of Amp, we need to change ...
0
votes
1answer
47 views

Suggestion for fields to use for this type of content

I'm using EE 2.11.2, and am having trouble coming up with a good, user-friendly way to set up my fields to represent some dynamic content on a site I'm building. Can you offer a suggestion of a ...
0
votes
1answer
47 views

Question on Wygwam from Pixel & Tonic

We use Wygwam for client to enter their content to EE. Client would like to enter order list type with A,B,C,D instead of 1,2,3,4. Can someone give me a hint how can I add option to client to choose ...
0
votes
1answer
28 views

Wygwam - Applying style to Unordered List

How can I apply a style in Wygwam editor so that the following code <ul> <li>Here's bullet point number one</li> </ul> Changes to this <ul data-bullet="ti-arrow-...
1
vote
0answers
31 views

Links out of Structure Listing in Wygwam is missing trailing slash

When adding a link in Wygwam through Structure Listing, the link is missing a trailing slash. Due to our SEO policy we would like to have a trailing slash in the url's. How to realize?
0
votes
1answer
58 views

Updated to latest Wygwam, Icons are all messed up

I'm using EE 2.8.1 and I just updated Wygwam from 3.3.1 to 3.3.3 by copying over system/expressionengine/third_party/wygwam and theme/third_party/wygwam folder contents over, then running "run module ...
0
votes
1answer
23 views

How to prevent Assets uploads within Wygwam for specific user group(s)?

I have created a restricted user group for external bloggers; I want to be able to prevent them from uploading images via Assets, but I'm not sure how. I've restricted access to the Assets module for ...
0
votes
0answers
29 views

Converts tags into the ellipsis character

For some reason, my Expression Engine install is converting img and span tag endings in the HTML entity 'ellipsis' character. (& #8230;). What happens is the span and img tags don't close and ...
0
votes
1answer
24 views

Wygwam shows only PDF files but no images

I just downloaded the newest Wygwam 4.0.1 and installed it into a working EE 3.1.2 installation. When trying to select an image through Wygwam the file manager only shows PDF files. Anyone any clue ...
0
votes
1answer
24 views

Wygwam: use apostrophes and proper quote marks

Does anyone know if it's possible to get Wygwam to replace inch and foot marks (" and ') with apostrophes and proper, left and right curly quote marks? So Don't becomes Don’t and "This" becomes “this”?...
0
votes
1answer
32 views

img tag being stripped out of front end

I place an image on a page using the file manager. I can see it in the editor, but when the image is displayed in the front end, all I see is the image path and not the image. When I look at the ...
0
votes
1answer
149 views

WYGWAM 4 is throwing PHP and Fatal errors on 2.10.3

Today I updated an old site from 2.2.1 to 2.10.3. I attempted to update some Add-Ons but ran into an issue with Wygwam. I downloaded Wygwam 4 from Devotee. Follow the update instructions but ran into ...
0
votes
1answer
182 views

Wygwam and ExpressionEngine 3 [duplicate]

Are there any plans to upgrade Wygwam to be compatible with ExpressionEngine 3? If not, any recommendations or issues on upgrading to EE3 and changing editors? Thanks, Carol
0
votes
1answer
154 views

Wygwam + CKeditor + Browse server not showing up after adding image2 plugin

I have updated CKeditor and Added the image2 plugin for image caption to work. Now image caption is working fine but the "Browse Server" button to add images from the server is missing. To manage the ...
0
votes
1answer
30 views

How to show image label when paste it in Wygwam field?

I need to show label (img alt or title property text) under the image when paste this image in Wygwam. Does exists the way to do this?
1
vote
1answer
77 views

What Addons are compatible with EE 3.0?

I am beginning the transition to EE 3.0 and have not been able to find a list of compatible plugins, add-ons, etc. Is there such a list?
0
votes
1answer
114 views

Wygwam is inserting words into the field by itself!

One of my channels has a Wygwam field set to use the "Basic" formatting toolbar. Whenever I save an entry, and then go back in to edit that entry, the word "Schedule" appears as the last line in the ...
0
votes
0answers
32 views

WYGWAM. window size click with no scroll

I am using WYGWAM 3.3.3 and EE 2.9.3 I have my WYGWAM set to 400pixels resizable. When I have a long entry when the edit page loads there is a scroll bar in the WYGWAM editor, but as soon as I click ...
0
votes
1answer
49 views

Force cache update Wygwam / Change timestamp

I was finally able to update Wygwam to the latest version (3.3.3). One user has contacted me to tell me he only saw gray fields instead of the normal Wygwam fields. I told him to empty his brower's ...
0
votes
1answer
36 views

Replacing Entries: Updating Playa/Wygwam from {page_x} to {page_y}?

Let's say you've got a bunch of entries in the "Original Generic Page" channel, which are getting replaced by pages with the same URLs in the "New Generic Page" channel. Assume also that entries are ...
0
votes
2answers
167 views

Wygwam / ckeditor errors on upgrade

I upgraded Wygwam 2.7.0 to 3.3.3. I run module update and I cleared my browser's cache. I am getting the next errors: Uncaught SyntaxError: Unexpected token ILLEGAL (ckeditor.js) config.js:10 ...
0
votes
2answers
123 views

Https problem with channel form

I have a problem with a channel form working over https.My form allows users edit their profiles for a staff directory and has a lot of fields including some assets , wygwam and matrix fields.When i ...
0
votes
3answers
26 views

Weird icons in Wygwam

I updated Wygwam to the most recent version (3.3.3) and now the icons in the toolbar all got messed up. I tried re-uploading the themes folder, and emptying the cache, but no luck so far.
0
votes
1answer
20 views

WYGWAM caching images?

I create an image and upload it to the server under a name, say Test Graphic A. Then inside WYGWAM, I click the picture icon, and choose Test Graphic A from the server. Everything is okay at that ...
0
votes
1answer
144 views

Channel form problem when using inline errors

I am using channel forms to publish articles and would like to use inline errors but when I have this enabled I get an error. A PHP Error was encountered Severity: Notice Message: Undefined property: ...
0
votes
1answer
70 views

Wygwam not loading

Updated EE v2.10.1 and using Wygwam v3.3.3 I have it set to initialize on click, and can see the field and all the content correctly. Clicking on the field makes it completely disappear. Doesn't ...
0
votes
1answer
42 views

Cell Padding in Wygwam

I am trying to use cell padding to add some white space in Wygwam table cells. It works in the editor view, but doesn't show up in the live view. (I am very new to Wygwam and know nothing about HTML.) ...
1
vote
1answer
72 views

Discussion Forum Email Templates HTML

I have changed Default Mail Format to HTML in email configuration but when I get email notifcations via the Discussion Forum it still contains HTML tags . e.g., <p> Anyone any idea?
1
vote
0answers
15 views

How to embed multiline LaTeX equations into Wygwam box

As an example, if I want to use something like: \begin{eqnarray} a &=& b ( d + c) + c \\ && bd + bc + c \\ a &=& bd + c(b + 1)\end{eqnarray}
0
votes
3answers
442 views

How to remove <p> tags from WYGWAM

I'd like to know how to remove automatic wrapping tags that outputs in page. <p class="summary">{sous_titre}</p> This is what I wrote inside my template. As you can see, I already put ...
1
vote
1answer
58 views

YouVersion Button in WYGWAM

I have a client site where there was a custom YouVersion button added to WYGWAM that stopped working after updating all the things. It's working on an Ee 2.6.1 / Wygwam 2.7.1 site. It's now running ...
0
votes
1answer
85 views

Channel Images in Wygwam, images dissapear

So, the Channel Images input for Wygwam works fine. We can add an image to the wygwam field, save it, and voila. When we edit the entry though, click the wygwam to edit, the images disappear. Not ...
0
votes
1answer
254 views

Display WGYWAM to the front-end using Channel Form Field

I created a form using channel fields and i'm trying to figure how to allow the WYGWAM features to display on the front-end so, the end-user can do some basic text formatting. {exp:...
1
vote
0answers
60 views

EE 2.5.5 not searching in custom wygwam field

I have a site that's using a custom wygwam field for the body of an article page. I've set the field up to be searchable, however, EE is only showing results that have the keyword(s) in the title. Is ...
1
vote
0answers
64 views

Wygwam not retaining Channel Images images

I want to use the Channel Images integration for Wygwam, but there seem to be two issues: 1.) No matter which size I choose for the image, it always uses the smallest image (I have 3 sizes set in the ...
1
vote
0answers
54 views

Customizing Wygwam & CKEditor to prefill width & height attributes

For the latest version of Wygwam, is there a way to: When an image is added, prevent the image dialog from automatically filling the width/height of the chosen image's dimensions Instead, prefill ...
0
votes
1answer
149 views

Is WYGWAM 3.3.3 Compatible with EE 2.10.1?

Can't find anything that indicates this in docs. Thanks
0
votes
2answers
53 views

File exceeds maximum dimensions and is not resizable

Site was moved to a different server. Trying to add/upload an image via the wygwam field but get the below error after selecting the image: File exceeds maximum dimensions and is not resizable. ...
2
votes
2answers
66 views

Full Paths from WYGWAM?

EE 2.7.3c / WYGWAM 3.3.2 / MSM / Native EE File Management All images/files are loaded on one domain but need to be used on both. WYGWAM is returning relative paths so the client has to manually ...
1
vote
2answers
135 views

WYGWAM 'Format' dropdown modification needed.

I would like to make some modification to the [‘Format”] dropdown box in WYGWAM but I can not find the file. (Normal, formatted, address, Heading, etc]. I figured out how to make the modifications ...
0
votes
2answers
43 views

I sound like a newb, but is CKeditor supposed to be installed onto the root of EE so Wygwam can actually work?

ok so this sounds basic; I've installed latest wygwam 3.3.3 and seemed to install fine. ok so is CKeditor supposed to be installed onto EE on the root? Because between CKeditor's lack of answers for ...
0
votes
1answer
70 views

Weird URLs for images from Assets

I'm troubleshooting a problem with an older, rarely updated site, so I'm not sure how recently this issue cropped up, though I'm fairly certain it worked when I handed it off. We have a Low Variable ...