Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

Filter by
Sorted by
Tagged with
0
votes
2answers
40 views

WYSIWYG-editor removes template partials/template variables

I am using Wygwam as WYSIWYG-editor. Now when I add a template variable or template partial inside an html-tag in a field which uses Wygwam it will be removed when switching from source to visual. ...
1
vote
0answers
16 views

CKEditor publisher toolbar missing from WYGWAM on ExpressionEngine 1.7

First...all of this is going to sound very novice...because it is. We had an issue at the server level and the WYGWAM broke. It's been restored by the Publisher(ish) toolbar is missing. I seriously ...
0
votes
2answers
26 views

WYGWAM freezes on Chrome when popping up a dialog box

When clicking the Link tool, or from the Link tool, clicking "Browse Server," or Create table, or Add Image, WYGWAM freezes for somewhere between 0-60 seconds. This just happens on the first clicks; ...
0
votes
1answer
114 views

Automatically add rel=“noopener” to hyperlinks set to open in a new window

Is there an easy fix that will append rel='noopener' to every link that’s set to open in a new window when using the hyperlink button in a text area field?
1
vote
0answers
35 views

WYGWAM + Font Awesome icon chooser. Possible?

I saw the "Font Awesome" plugin for CKEditor and got hyped, but couldn't get it to work. https://ckeditor.com/cke4/addon/fontawesome But that seeded the question: Is there a way to get a Font ...
0
votes
2answers
149 views

Wygwam is inserting words into the field by itself!

One of my channels has a Wygwam field set to use the "Basic" formatting toolbar. Whenever I save an entry, and then go back in to edit that entry, the word "Schedule" appears as the last line in the ...
0
votes
0answers
201 views

Wygwam, Channel Images and Blocks

I've looked at a bunch of posts on here but nothing specifically helps with this issue. Background: I like to offer users rich content choices and have achieved this in the past with a mixture of ...
4
votes
4answers
1k views

“Thumbnail could not be created for the image.” Error

I've recently migrated a site, and now when uploading pictures through the file manager in Wygwaym images large enough to require a thumbnail cannot be uploaded, very small images, however, can be. I'...
0
votes
1answer
151 views

wygwam error after move of server

I am new to ExpressEngine. One of my clients has a website built in EE by another developer. We have just moved the site to a new server, and now we are getting the following errors, if anyone can ...
0
votes
1answer
37 views

Wygwam character limit for Cyrillic text

I'm finding that Cyrillic text entered into a Wygwam field is truncated. Is this because there is a limit for character rendered in unicode?
1
vote
1answer
418 views

CKEditor Plugin Shows In Wygwam Configurator But Is Hidden From Publish Page

Using Wygwam 3.3.2 and ExpressionEngine 2.9.0 I'm trying to get the Enhanced Image plugin (http://ckeditor.com/addon/image2) for ckeditor added to our Wygwam installation. I have followed the ...
1
vote
2answers
280 views

Wygwam/CKEditor stripping out empty <i> tags (Font Awesome)

There was an earlier post related to this, but its solution was outdated. So I'm creating a new one. I am using ExpressionEngine 2.9.2 with Wygwam 3.3.2. Our site incorporates icons using FontAwesome ...
0
votes
1answer
70 views

Have WYGWAM image insert be able to select from multiple directories

I am currently using WYGWAM 3.3.3 with EE 2.11.1. I have WYGWAM using EE's file manager. Currently with file manager there are 6 different folders they can upload images and pdf's to. When they ...
11
votes
6answers
2k views

Stopping WYGWAM from assigning dimensions to images

Is it possible to stop WYGWAM from putting dimensions on images as inline styles. We want the images to be responsive. Thanks for any advice.
0
votes
2answers
157 views

Adding CKEditor Plugins to Wygwam 4.0.9 in EE3

I'm attempting to add a CKEditor plugin to Wygwam 4.0.9 in EE3, but the documentation I found in pixelandtonic and wygwam docs showing wrong upload folders. There is no such folders as themes/...
2
votes
1answer
619 views

Adding CKEditor Plugins to Wygwam

I'm attempting to add a CKEditor plugin to Wygwam, but the plugin is not showing in the config or editor even after adding it to the extraPlugins config and I have uploaded the CKEditor plugin to the ...
0
votes
2answers
306 views

Linking to Structure Pages in Wygwam: How to not use full URL?

I have a staging site running at a URL like client.clearbold.com. I'm using FocusLab's Config, so all my paths and domains are dynamic. When I link text in a Wygwam field, and choose a Structure ...
1
vote
2answers
241 views

Wygwam 'site page' link type not parsing when used within Low Variables variable

I am using: EE 2.7.2, Low Variables 2.4.0, WYGWAM 3.2.2 I have a WYGWAM field as a Low Variable, and within it, I am setting up some page links. When I create a link, under "Link Type" I chose "Site ...
1
vote
1answer
149 views

Transcribe + Wygwam + Structure links not working

When adding Structure Links to a wygwam field on a Transcribe entry that's not the default language, they are being rendered like this: <a href="{page_168}"> More info: I have a Transcribe ...
0
votes
1answer
55 views

EE3 structure remove index.php

When adding link "using structure page link type" via backend (wygwam) all links include index.php automatically, is this a bug?
1
vote
2answers
569 views

Need a regex ninja's help with replacing a YouTube string

I'm looking for some help with replacing YouTube embed codes with something that can be used with AMP pages https://www.ampproject.org/ Example, we would like replace this: <iframe ...
0
votes
2answers
201 views

Changing the <img> tag with CE Image?

So if you may or may not know, Google rolled out Amp'd pages and displaying these websites that are 'Amp ready' higher on the search results. Without getting into the details of Amp, we need to change ...
0
votes
1answer
86 views

Assets Image Path Issue with Wygwam on Front-end/View Entry Page

EE 2.6.1 Assets 2.3.1 Wygwam 3.3 We are having an issue where images from Assets are added to a Wygwam field, but do not display on the front-end or view entry page after save. They do appear fine ...
0
votes
1answer
56 views

Suggestion for fields to use for this type of content

I'm using EE 2.11.2, and am having trouble coming up with a good, user-friendly way to set up my fields to represent some dynamic content on a site I'm building. Can you offer a suggestion of a ...
0
votes
1answer
148 views

Why are Wygwam and Editor inline styles corrupting on save

I'm using both the Wygwam and Editor plugins however on saving an entry any inline styles (such as image width and height) appear as Does anyone have any ideas?
0
votes
1answer
50 views

Question on Wygwam from Pixel & Tonic

We use Wygwam for client to enter their content to EE. Client would like to enter order list type with A,B,C,D instead of 1,2,3,4. Can someone give me a hint how can I add option to client to choose ...
0
votes
1answer
36 views

Wygwam - Applying style to Unordered List

How can I apply a style in Wygwam editor so that the following code <ul> <li>Here's bullet point number one</li> </ul> Changes to this <ul data-bullet="ti-arrow-...
0
votes
1answer
154 views

Channel form problem when using inline errors

I am using channel forms to publish articles and would like to use inline errors but when I have this enabled I get an error. A PHP Error was encountered Severity: Notice Message: Undefined property: ...
0
votes
1answer
53 views

Force cache update Wygwam / Change timestamp

I was finally able to update Wygwam to the latest version (3.3.3). One user has contacted me to tell me he only saw gray fields instead of the normal Wygwam fields. I told him to empty his brower's ...
0
votes
1answer
88 views

WYGWAM causing Undefined property: EE::$view on validation failure of Channel Form

I'm using the latest version of ExpressionEngine (2.9.2) and the latest version of WYGWAM (3.3.3). I've a Channel Form which includes the WYGWAM field and when I submit the form I receive the ...
0
votes
1answer
134 views

Wygwam 'read more' option without new paragraph tags

I am using the wygwam add on, and clicking the "read more" icon to create an excerpt. However, whenever I do this, it creates a paragraph tag around the text before the read more and starts a ...
1
vote
2answers
114 views

Wygwam Grid Compatibility

The Wygwam changelog states that v3.3 "Added Grid compatibility." But when I create a Grid field, Wygwam is not offered as an available field type. EE 2.8.1 Wygwam 3.3.1 Any ideas? Thanks, Philip
0
votes
1answer
72 views

Weird URLs for images from Assets

I'm troubleshooting a problem with an older, rarely updated site, so I'm not sure how recently this issue cropped up, though I'm fairly certain it worked when I handed it off. We have a Low Variable ...
0
votes
1answer
46 views

Adding playa entry into field (e.g. related gallery)

Anyone know the best way to add a playa related entry (in this case a gallery) directly into a post area (wygwam or richtext field for example)? I need to have flexibility here, so could be 1 or 20 ...
0
votes
1answer
23 views

WYGWAM caching images?

I create an image and upload it to the server under a name, say Test Graphic A. Then inside WYGWAM, I click the picture icon, and choose Test Graphic A from the server. Everything is okay at that ...
0
votes
1answer
171 views

Wygwam + CKeditor + Browse server not showing up after adding image2 plugin

I have updated CKeditor and Added the image2 plugin for image caption to work. Now image caption is working fine but the "Browse Server" button to add images from the server is missing. To manage the ...
1
vote
0answers
43 views

Links out of Structure Listing in Wygwam is missing trailing slash

When adding a link in Wygwam through Structure Listing, the link is missing a trailing slash. Due to our SEO policy we would like to have a trailing slash in the url's. How to realize?
3
votes
2answers
85 views

Word-wrap when viewing source in WYGWAM

I don't recall this previously being the case, but lately I've been accosted by horrendous long lines and the need to use a scroll bar when viewing raw source in a WYGWAM field. Is there any way to ...
0
votes
2answers
58 views

File exceeds maximum dimensions and is not resizable

Site was moved to a different server. Trying to add/upload an image via the wygwam field but get the below error after selecting the image: File exceeds maximum dimensions and is not resizable. ...
1
vote
1answer
51 views

Using wygwam with readmore under contentelements

{content_a} {wygwam:excerpt} {value} {/wygwam} {wygwam:extended} {value} {/wygwam} {/content_a} I wanted to have a readmore button instead, The code above outputs ...
0
votes
1answer
31 views

Wygwam shows only PDF files but no images

I just downloaded the newest Wygwam 4.0.1 and installed it into a working EE 3.1.2 installation. When trying to select an image through Wygwam the file manager only shows PDF files. Anyone any clue ...
0
votes
1answer
68 views

Updated to latest Wygwam, Icons are all messed up

I'm using EE 2.8.1 and I just updated Wygwam from 3.3.1 to 3.3.3 by copying over system/expressionengine/third_party/wygwam and theme/third_party/wygwam folder contents over, then running "run module ...
0
votes
1answer
27 views

How to prevent Assets uploads within Wygwam for specific user group(s)?

I have created a restricted user group for external bloggers; I want to be able to prevent them from uploading images via Assets, but I'm not sure how. I've restricted access to the Assets module for ...
1
vote
2answers
373 views

Wygwam 2.7: How Can I Customize the Image Properties Modal?

I would like to customize Wygwam's Image Properties modal to display the following options only: Upload image files from local HD Add Alt text Add a caption I don't want site members to be able to: ...
0
votes
1answer
28 views

Wygwam: use apostrophes and proper quote marks

Does anyone know if it's possible to get Wygwam to replace inch and foot marks (" and ') with apostrophes and proper, left and right curly quote marks? So Don't becomes Don’t and "This" becomes “this”?...
0
votes
1answer
88 views

upgraded WYGWAM 3.3.3 - config icons not right

When I go into the toolbar config this icon http://d.pr/i/3UIj is used for inserting an image. No console errors. When I look at the actual publish page, everything is as expected. Tried clearing ...
0
votes
1answer
47 views

img tag being stripped out of front end

I place an image on a page using the file manager. I can see it in the editor, but when the image is displayed in the front end, all I see is the image path and not the image. When I look at the ...
0
votes
1answer
163 views

WYGWAM 4 is throwing PHP and Fatal errors on 2.10.3

Today I updated an old site from 2.2.1 to 2.10.3. I attempted to update some Add-Ons but ran into an issue with Wygwam. I downloaded Wygwam 4 from Devotee. Follow the update instructions but ran into ...
0
votes
1answer
191 views

Wygwam and ExpressionEngine 3 [duplicate]

Are there any plans to upgrade Wygwam to be compatible with ExpressionEngine 3? If not, any recommendations or issues on upgrading to EE3 and changing editors? Thanks, Carol
0
votes
2answers
62 views

Update WYGWAM's CKEditor manually

After the Safari-7.1-Update the CKEditor does no more work properly. There is a fix: CKEditor 4.4.5 with Safari 7.1 Fix Released Which packet do I have to download (Basic, Standard, Full) and where ...

1
2 3 4 5 6