Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

Filter by
Sorted by
Tagged with
11
votes
6answers
2k views

Stopping WYGWAM from assigning dimensions to images

Is it possible to stop WYGWAM from putting dimensions on images as inline styles. We want the images to be responsive. Thanks for any advice.
8
votes
3answers
1k views

Wygwam - automatically wrap media embed with custom html

I'm using Wygwam on a site, and I'm allowing content administrators to embed media (specifically, videos) within the main, body copy/content area. Is there a way to automatically wrap the embedded ...
7
votes
2answers
520 views

Insert Link dialog hangs using wygwam in Internet Explorer - not other browsers

When editing an entry ... highlight text, click ‘Link’ icon > the wrong dialog appears with ‘Select an Anchor’ and ‘E-mail Address’ (see image). There are similar problems in inserting an image ...
6
votes
1answer
650 views

Assets in Wygwam not displaying on front end in EE 2.6/Assets 2.1.1/Wygwam 2.7.1

Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively. I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {...
5
votes
3answers
793 views

Configure WYGWAM to use fonts from Typekit?

I use custom CSS for WYGWAM fields. I can use @font-face, but what if I want to use fonts via Typekit, is there a way to pull them in?
4
votes
4answers
1k views

“Thumbnail could not be created for the image.” Error

I've recently migrated a site, and now when uploading pictures through the file manager in Wygwaym images large enough to require a thumbnail cannot be uploaded, very small images, however, can be. I'...
4
votes
2answers
666 views

Removing unwanted newline characters in Wygwam

Wygwam automatically adds some extra space in <p> tags by default. Is there any way to remove them without editing the source in Wygwam? I'm using Wygwam 2.6.3. What is intended <p>This ...
4
votes
1answer
348 views

Dynamic Filepaths to Assets Files in Wygwam Fields

How does one go about building a dynamic link to a file managed by Assets within a Wygwam field? In other words, when we move our EE project from dev.example.com/projects/project_name to example.com, ...
4
votes
3answers
151 views

WYGWAM making [i] italicise content

I've a client who has written an article with footnotes. Those footnotes are notated by them adding [i] [ii] and so on. For some reason though, WYGWAM seems to take that as a cue to open italics. ...
4
votes
1answer
96 views

Initialize Wygwam within Custom Fieldtype

I'm developing a fieldtype add-on and within the fieldtype, I would like to include the option to let users choose Wygwam as the text element, if they have it installed. Is there some sort of a "...
4
votes
1answer
565 views

Wygwam character limit?

Is there a character limit on Wygwam / CKEditor? One of our clients just tried to add a very, very long entry (65k characters or so) and it spit the bit. Perhaps PHPMemory running out as well?
4
votes
1answer
79 views

WYGWAM “re-draw” lines in Chrome

One of my clients is having major "re-draw" issues with WYGWAM while using Chrome (Mac): http://i.stack.imgur.com/n8l4D.png The only way to temporarily lose the lines is to keep resizing the text ...
4
votes
1answer
88 views

How can I bind custom JS to a Wygwam field after it has intialised?

I'm using EE 2.5.2 and Wygwam 2.6.3. I need to bind some custom javascript to a Wygwam field on the publish/edit screen in the CP once the field has initialised. Specifically, I need to bind to ...
4
votes
1answer
247 views

Why is WYGWAM failing after upgrade

I've just upgraded from EE 2.5.3 to 2.6.1 and am fighting through all the damage it's done to my site. At the moment I'm stuck on the seeming failure of WYGWAM (3.1.1). I'm having the same issue ...
4
votes
1answer
569 views

WYGWAM PHP errors in CP after upgrade

A PHP Error was encountered Severity: Notice Message: Undefined index: config Filename: wygwam/helper.php Line Number: 535 A PHP Error was encountered Severity: Notice Message: Undefined index: config ...
4
votes
0answers
81 views

Wygwam+Safecracker: long URL gets limited to 60 characters and breaks HTML [closed]

Real URLs have been changed to protect the innocent, but the dummy URLs are the exact same length (197 characters unexpectedly truncated to 60) and similar format. When posting this to a Wygwam field ...
4
votes
0answers
138 views

Assets used in WYGWAM fields don't update when file is moved

I'm using Assets 2.1.4, WYGWAM 2.7.1 and EE 2.5.5. I have a WYGWAM field, and two assets directories, one local and one Amazon S3. In the Assets interface, I can move a file from local to S3 just ...
3
votes
2answers
594 views

How to add jquery spellchecker plugin to WYGWAM

How I would go about adding the jquery spellcheck plugin to WYGWAM?
3
votes
2answers
348 views

WYGWAM - text align center?

I just updated to Wygwams latest version and I don't see the "text align" option anymore. How do I restore it?
3
votes
3answers
640 views

Upload field has disappeared in WYGWAM

My client has alerted me that some time in the last 2-3 months, they've lost the ability to upload files directly through WYGWAM. I've updated WYGWAM to its most recent version, and disabled any ...
3
votes
1answer
261 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
3
votes
2answers
156 views

Styles not being applied correctly

I have a jQuery collapsing menu feature that I want my client to easily be able to create. The only thing that needs to be done is adding two styles to their text. One is the header of the menu, the ...
3
votes
1answer
93 views

Configure wygwam configuration via field parameter?

Within a channel form, is it possible to override/specify the editor configuration that wygwam uses? For example: {exp:channel:form channel="post"} <label>Post Content</label> {...
3
votes
1answer
646 views

Tell WYGWAM not to wrap certain text in a <p> tag

I've built in a shortcode-like method using mx_jumper that works well, for the most part. I have Matrix field called blog_images where the user can upload up to 10 images for a post. Then they include ...
3
votes
1answer
337 views

WYGWAM/CKEditor Skin

I’ve got something here that is absolutely not critical, but it's bugging me and I’ve been encouraged to post it here to see if anyone can help out. I am trying to change the skin of WYGWAM to one I ...
3
votes
1answer
234 views

Do I lose data if I change a text area field to Wygwam?

I have a live site with many entries and the client would like to change the Text Areas to Wygwam fields in order to leverage the Wygwam features. If I make this change, will I lose any existing ...
3
votes
3answers
227 views

HTML/JS stripped from templates

I'm trying to update template code on a EE site I inherited and whenever I save the template, after making my changes, the HTML formatting gets all screwed up and the JS is completely stripped out. ...
3
votes
1answer
461 views

How can I strip <p> tags from entry content, but only if it's wrapped around a <figure>?

On occasion a <figure> tag will make it through WYGWAM with a <p> wrapped around it which breaks my layout (and is incorrect formatting anyway). Can I remove just the <p> tags that ...
3
votes
2answers
739 views

style set wygwam

I have defined a new set of style to use in the wygwam editor and that works fine. I have called this file "my styles.js" and included it in /themes/third_party/wygwam_assets/ as suggested in the ...
3
votes
2answers
124 views

Any way to get Wyvern or Wygwam to set a tag PLUS its required attributes?

I know how to set up custom styles in Wyvern and Wygwam so that my client can apply, say, a <dfn> tag or <abbr> tag to some text. And I can set attributes within that tag. But the values of the ...
3
votes
1answer
122 views

Problems getting Wygwam's has_excerpt feature working with Low Variables

I'm using Low Variables (2.3.3) with a Wygwam (2.7) variable type. Is it possible to get the has_excerpt functionality working in this setup? I've tried the following code but it ignores it and just ...
3
votes
1answer
616 views

CKfinder / CKeditor / Wygwam on a CMS in a subdomain

Due to high traffic, we had to spread our website over two servers and a load balancer on top. The master and slave servers are synced one way, from master to slave. We set a subdomain (cms.domain....
3
votes
2answers
124 views

Use WYGWAM “site page” links in a multilanguage environment

I have a multilanguage site with wygwam and the client is making extensive use of the "site page" links. for the multilanguage part i use "multi language support" by biber ltd. Now i have a bodytext-...
3
votes
1answer
200 views

Assets and WYGWAM 2.7

I see in the latest version of WYGWAM 2.7 that if I use Assets 2.0.4 it will connect my files if I move or rename them. Does this affect just new files or is it 'clever' enough for all of the past ...
3
votes
2answers
85 views

Word-wrap when viewing source in WYGWAM

I don't recall this previously being the case, but lately I've been accosted by horrendous long lines and the need to use a scroll bar when viewing raw source in a WYGWAM field. Is there any way to ...
3
votes
1answer
150 views

Assets in Wygwam only inserting {assets_X} on first save

So, similar to this question when using Assets in a Wygwam field I am having to re-save an entry to get the image to output on the frontend. When I check what is getting saved to the db I get {...
2
votes
1answer
536 views

WYGWAM stripping classes and styles

If I add this code using WYGWAM source <h2 class="section-title">Some<span class="blue-text long-word">Title</span></h2> and publish, it works fine. But if I go back and ...
2
votes
3answers
727 views

autosave does not work as expected. Specifically RTE and WYGWAM

EE's autosave is not entirely clear in the Docs. Here are the facts: Autosave (tested versions 2.5.5, 2.6.1, 2.7.2) is on by default. http://ellislab.com/forums/viewthread/222582/#1023950 You can '...
2
votes
2answers
146 views

How to lock the field height and bring back the scrollbar?

It looks like in Wygwam 3.2.2, the field height grows with the content. It used to have a static height and a scrollbar would appear in the field if content was too tall for it. My client prefers ...
2
votes
1answer
792 views

Wygwam - Form & script tags being removed

I’m struggling with <form> and <script> tags being removed in WYGWAM. When these tags are added via source in WYGWAM and saved they show up on the page but when you go back into edit the ...
2
votes
1answer
378 views

Wygwam 3.0.2 PHP Error in EE 2.5.5

On a number of EE 2.5.5 sites with Wygwam 3.0.2, I'm getting this PHP error: A PHP Error was encountered Severity: Notice Message: Undefined index: defer Filename: wygwam/ft.wygwam.php Line ...
2
votes
2answers
132 views

How can I convert a text field to either Content Elements or Blocks without losing existing content?

A site I manage has thousands of entries across dozens of channels where the main textual content is stored in Wygwam fields. I'd like to convert (or perhaps duplicate and convert) those fields over ...
2
votes
2answers
140 views

Pre-populated content in Wygwam?

Is it possible to have Wygwam (or any custom field) pre-populated with content when you create a new entry? I'm aiming to give my client a table, with some cells already filled in.
2
votes
4answers
889 views

Is there a downside of using WYGWAM over Rich Text formatting buttons

I've always tried to avoid using WYSIWYG except for the main body field, thinking that it was better to try and keep as much as possible as plain text in the database. But the conflicting methods/...
2
votes
3answers
605 views

Possible to remove p tags from a table cell in Wygwam

I have a problem that occasionally a <p> tag is being added to a table cell, usually when someone pastes something into it. Is there a way to remove that <p> and just have the cell be an ...
2
votes
2answers
70 views

Full Paths from WYGWAM?

EE 2.7.3c / WYGWAM 3.3.2 / MSM / Native EE File Management All images/files are loaded on one domain but need to be used on both. WYGWAM is returning relative paths so the client has to manually ...
2
votes
1answer
619 views

Adding CKEditor Plugins to Wygwam

I'm attempting to add a CKEditor plugin to Wygwam, but the plugin is not showing in the config or editor even after adding it to the extraPlugins config and I have uploaded the CKEditor plugin to the ...
2
votes
1answer
211 views

Is there an alternative to webspellchecker.net in Wygwam?

We enabled spell checking in Wygwam and the 3rd party service (webspellchecker.net) doesn't even seem to understand simple things like contractions. For example if the word "aren't" is present it ...
2
votes
1answer
132 views

Loading multiple stylesheets in Wygwam

I am using a UI Kit for styling out the pages on a site. With the UI kit, there are multiple CSS files and js files in order to achieve the results of the rendered objects. Is there a way to ...
2
votes
1answer
72 views

Wygwam source button

i'm using the wygwam editor and i'd like to use the source button/option with my admin account. but the source button should not be visible/usable for other members. any idea how to do that? thanks!...

1
2 3 4 5 6