Skip to main content
The 2024 Developer Survey results are live! See the results

Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

Filter by
Sorted by
Tagged with
6 votes
1 answer
658 views

Assets in Wygwam not displaying on front end in EE 2.6/Assets 2.1.1/Wygwam 2.7.1

Just updated to EE 2.6 today, also updated Assets and Wygwam to 2.1.1 and 2.7.1 respectively. I have images in my Wygwam fields, if I var dump the raw data, the code stored looks like this: {...
Rob Sanchez's user avatar
  • 4,002
2 votes
1 answer
645 views

Adding CKEditor Plugins to Wygwam

I'm attempting to add a CKEditor plugin to Wygwam, but the plugin is not showing in the config or editor even after adding it to the extraPlugins config and I have uploaded the CKEditor plugin to the ...
Ed Long's user avatar
  • 31
11 votes
6 answers
2k views

Stopping WYGWAM from assigning dimensions to images

Is it possible to stop WYGWAM from putting dimensions on images as inline styles. We want the images to be responsive. Thanks for any advice.
Mike Dexter's user avatar
4 votes
1 answer
587 views

Wygwam character limit?

Is there a character limit on Wygwam / CKEditor? One of our clients just tried to add a very, very long entry (65k characters or so) and it spit the bit. Perhaps PHPMemory running out as well?
Jae Barclay's user avatar
3 votes
1 answer
203 views

Assets and WYGWAM 2.7

I see in the latest version of WYGWAM 2.7 that if I use Assets 2.0.4 it will connect my files if I move or rename them. Does this affect just new files or is it 'clever' enough for all of the past ...
Mitchell's user avatar
3 votes
1 answer
156 views

Assets in Wygwam only inserting {assets_X} on first save

So, similar to this question when using Assets in a Wygwam field I am having to re-save an entry to get the image to output on the frontend. When I check what is getting saved to the db I get {...
joshangell's user avatar
2 votes
2 answers
502 views

Wygwam - Creating a custom template

I'm using ExpressionEngine v2.7.2 and Wygwam v3.2.2 and I want to be able to add a custom template to the toolbar, to be able to add custom markup. I've looked at the documentation for both CKEditor ...
Kenny Bones's user avatar
8 votes
3 answers
1k views

Wygwam - automatically wrap media embed with custom html

I'm using Wygwam on a site, and I'm allowing content administrators to embed media (specifically, videos) within the main, body copy/content area. Is there a way to automatically wrap the embedded ...
ctrlaltdel's user avatar
7 votes
2 answers
523 views

Insert Link dialog hangs using wygwam in Internet Explorer - not other browsers

When editing an entry ... highlight text, click ‘Link’ icon > the wrong dialog appears with ‘Select an Anchor’ and ‘E-mail Address’ (see image). There are similar problems in inserting an image ...
Kip's user avatar
  • 71
4 votes
3 answers
157 views

WYGWAM making [i] italicise content

I've a client who has written an article with footnotes. Those footnotes are notated by them adding [i] [ii] and so on. For some reason though, WYGWAM seems to take that as a cue to open italics. ...
Steven Grant's user avatar
  • 2,473
4 votes
1 answer
351 views

Dynamic Filepaths to Assets Files in Wygwam Fields

How does one go about building a dynamic link to a file managed by Assets within a Wygwam field? In other words, when we move our EE project from dev.example.com/projects/project_name to example.com, ...
Nick Benson's user avatar
  • 1,785
4 votes
1 answer
572 views

WYGWAM PHP errors in CP after upgrade

A PHP Error was encountered Severity: Notice Message: Undefined index: config Filename: wygwam/helper.php Line Number: 535 A PHP Error was encountered Severity: Notice Message: Undefined index: config ...
Florian's user avatar
  • 251
3 votes
1 answer
265 views

Assets URL in Low Variables Wygwam field not displaying on Front end

Similar to this post I'm getting incorrect file paths being displayed on the front end when using Assets from within Wygwam. Unlike that post I'm actually getting this rendered on the front end: {...
Andy Homan's user avatar
2 votes
1 answer
549 views

WYGWAM stripping classes and styles

If I add this code using WYGWAM source <h2 class="section-title">Some<span class="blue-text long-word">Title</span></h2> and publish, it works fine. But if I go back and ...
Peter Eastwood's user avatar
1 vote
3 answers
511 views

Wygwam field dissapearing

Planning to switch from editor to wygwam, and when activating for a field for trial I get a complete blank field. The editors input-window flashes for a second, but no buttons are visible during that ...
Patrick Hvid's user avatar
1 vote
1 answer
328 views

Embed an exp:channel tag into Wygwam

Is it possible to put a exp:channel entries tag loop into a wygwam field? Simply placing something, e.g., {embed="Common/sidebar_people" show_channel="48"} ... fails. The "Allow EE Code" plugin I ...
Screenack's user avatar
  • 167
1 vote
1 answer
165 views

How can I disallow Javascript and CSS entered into WYGWAM fields?

I have a client that has a nasty habit of entering <style> and <script> tags and style="" attributes to WYGWAM content and I need to be able to cut them off at the pass. They should hire ...
Brandon Durham's user avatar
1 vote
1 answer
84 views

Request: Disabled image size inline css

The last few years we have been working for most of the time on responsive designed websites, and every time we are using ExpressionEngine and Wygwam module, we get complains from our clients ...
Rob Mol's user avatar
  • 31
1 vote
1 answer
197 views

What is causing Wygwam 3.2.2 error: SyntaxError: Parse error, TypeError: Result of expression 'u' [undefined] is not an object

After upgrade of Wygwam on Exp Eng 2.7.2 our module Wygwam 3.2.2 is not loading in the control panel due to the following errors... SyntaxError: Parse error /themes/third_party/wygwam/lib/ckeditor/...
Bob Foster's user avatar
1 vote
1 answer
536 views

Wygwam - stripping tags from ul li (class and id) [Advanced Content Filter (ACF)]

Good afternoon, after upgrading to the latest wygwam version i experienced the problem that the editor is stripping out content from wygwam fields. Not the visible parts but class and id fields from ...
Bas van Ginkel's user avatar
0 votes
0 answers
212 views

Wygwam, Channel Images and Blocks

I've looked at a bunch of posts on here but nothing specifically helps with this issue. Background: I like to offer users rich content choices and have achieved this in the past with a mixture of ...
Boshy's user avatar
  • 245