Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

Filter by
Sorted by
Tagged with
1
vote
1answer
51 views

Using wygwam with readmore under contentelements

{content_a} {wygwam:excerpt} {value} {/wygwam} {wygwam:extended} {value} {/wygwam} {/content_a} I wanted to have a readmore button instead, The code above outputs ...
0
votes
1answer
103 views

Wygwam not loading tool bar

All of a sudden wigwam stopped loading the tool bar. I can not click in the field, either to publish or edit, there is no field, no tool bar. Its been working great for 3 months. I am running EE 2.6.1 ...
1
vote
1answer
477 views

WYGWAM Increase Indent Not Working on Paragraphs

Since updating to WYGWAM 3.3 the ability to increase indent on text stopped functioning on standard paragraphs (ol and ul does work). Worse anything I had indented using this way has lost the styling ...
0
votes
1answer
30 views

Updated Version Wygwam for EE 1

I'm working on a site on EE 1, and need to update an old (2.0.4) version to a newer version, b/c theres some problem in IE. Is there anyway I can access EE 1 versions of Wygwam?
2
votes
1answer
211 views

Is there an alternative to webspellchecker.net in Wygwam?

We enabled spell checking in Wygwam and the 3rd party service (webspellchecker.net) doesn't even seem to understand simple things like contractions. For example if the word "aren't" is present it ...
2
votes
1answer
92 views

Advanced Settings don't get saved (Wygwam)

I'm using EE 2.8.0 and updated to Wygwam 3.3. I'm adding some advanced settings in the Wygwam configuration (eg.g for the Basic set) in the CP - when saving and going back to the Wygwam configuration ...
0
votes
1answer
66 views

How do you use HTML5 elements in WYGWAM?

I see that WYGWAM added support for HTML5 elements (section, figure, etc.) in their changelog, but I cannot figure out how to enable or use them. Can someone enlighten me?
2
votes
2answers
486 views

Wygwam - Creating a custom template

I'm using ExpressionEngine v2.7.2 and Wygwam v3.2.2 and I want to be able to add a custom template to the toolbar, to be able to add custom markup. I've looked at the documentation for both CKEditor ...
0
votes
1answer
20 views

Wygwam Link List - Hide Hidden Enteries

We have an instance of wygwam. When the user clicks the link button a list of all entries comes up for the user to choose from. This list contains both open and closed entries, is there a way to ...
2
votes
1answer
96 views

Document Link Target New Window

Can the target tab drop down be defaulted to "open in new window" when linking to uploaded docs?
0
votes
1answer
76 views

All upload destinations not visible in assets when opened from wygwam

I have several different upload destinations in my site, primarily one for images only, named "Images", and one for all kinds of files, named "Documents". I've chosen Assets to be the filemanager to ...
0
votes
1answer
112 views

Wygwam error after upgrade

I've upgraded a site to EE 2.7.3 and upgraded Wygwam to 3.2.2 , but now when I try and edit or publish a new entry, I get the error below: Fatal error: Call to undefined method Wygwam_helper::...
0
votes
1answer
39 views

Wygwam 2.7 not processing Assets tags after bulk conversion

I have a client site in which I need to convert a very large number of existing entries from ExpressionEngine's native File Upload functionality to Assets in order to take advantage of S3 storage. I ...
1
vote
1answer
114 views

Load EE Field Type in Third Party Module

I am trying to load wygwam field type into a custom module, on my localhost the following works: require_once(APPPATH . 'fieldtypes/EE_FieldType.php'); require_once(PATH_THIRD.'wygwam/ft.wygwam.php');...
0
votes
1answer
58 views

How to make "Site Page" link field in Wygwam show URL?

When I create a link in Wygwam, a box appears that lets me choose "Site Page" and select an entry from the Pages module. My problem is that I have several pages with the same name, because each page ...
2
votes
0answers
53 views

SSL and Wygwam not loading tool bar

Any one know if there is a setting in Expression engine for the WYGWAM editor for https? When I access through https my tool bar disappears? Any ideas? Thanks, Dan
0
votes
1answer
174 views

ACK! Can't edit fields - getting WYGWAM error after EE & WYGWAM upgrade

EE v2.7.3 - Build Date: 20131210 / Wygwam - 3.2.2 when I go to: CP Home -> Add-ons -> Fieldtypes OR CP Home -> Administration -> Channel Fields -> (any field group even if there is no wygwam ...
1
vote
1answer
637 views

Adding a custom class to ol or ul lists

I'm attempting to add some sort of functionality to WYGWAM that will add a custom class to a ol or ul lists. So for example: <ol class="custom"> .... .... </ol> I've tried editing a ...
1
vote
1answer
286 views

WYGWAM Hangs (504 Gateway Time-out) when adding apostrophe

I have a Channel Form on the frontend that contains a WYGWAM field. The field works fine unless I add an apostrophe. If I do, after hitting submit, it hangs and I get a "504 Gateway Time-out" error. ...
1
vote
2answers
50 views

Wygwam - adding link cannot close window

EE 2.7.3 WYGWAM 3.2.2 When using Internet Explorer I try to add a link using WYGWAM and after I enter the URL i click OK and the pop up window will not close. Is there a fix for this?
1
vote
1answer
30 views

Wygwam error "Cannot redeclare class Wygwam" error after 2.7.2 upgrade

After upgrading to 2.7.2, I am getting an odd "Cannot redeclare class Wygwam" error in the control panel. This prevents entries from opening, and also accessing the Fieldtypes list. Any solution? ...
1
vote
2answers
257 views

Wygwam & CKeditor wordcount

I'm looking to use the wordcount plugin for the CKeditor in WYGWAM. Wordcount states it is compatible with version 4 of CKeditor, which is in v3 of WYGWAM. So my question is - Is it possible to get ...
1
vote
2answers
93 views

Wygwam is not saving images

I uploaded an image in the file manager, when I edit my channel entry and use the image icon inside of the wygwam editor window i find the file and it previews correctly. I add it to the page and ...
1
vote
2answers
245 views

Wygwam 'site page' link type not parsing when used within Low Variables variable

I am using: EE 2.7.2, Low Variables 2.4.0, WYGWAM 3.2.2 I have a WYGWAM field as a Low Variable, and within it, I am setting up some page links. When I create a link, under "Link Type" I chose "Site ...
0
votes
0answers
88 views

Drag & drop image doesn't work

I'm running EE 2.7.2, Wygwam 3.2.2. Drag and drop image into the field doesn't work. After saving my entry and opening the page, I can view source and see the following: <img alt="" src="data:&...
0
votes
1answer
74 views

Wygwam if conditional

Basically i want to know if its possible for expression engines if tag to check if a wygwam field contains images. I know its possible to pull through just images like so: {my_wygwam_field ...
0
votes
2answers
306 views

Can you use Wygwam within Grid field?

My question is pretty straight to the point. I want to use WYGWAM as a data type within the Grid field, but it doesn't give me the option to select it? Anyone know if this is possible? I know it ...
2
votes
1answer
339 views

WYGWAM Content Templates Blank

I've successfully used WYGWAM (CK Editor) Styles before but I cannot get the Templates to work. I have a relative path in my WYGWAM settings like so: And I'm just getting this: I have the following ...
1
vote
1answer
194 views

What is causing Wygwam 3.2.2 error: SyntaxError: Parse error, TypeError: Result of expression 'u' [undefined] is not an object

After upgrade of Wygwam on Exp Eng 2.7.2 our module Wygwam 3.2.2 is not loading in the control panel due to the following errors... SyntaxError: Parse error /themes/third_party/wygwam/lib/ckeditor/...
2
votes
1answer
133 views

Loading multiple stylesheets in Wygwam

I am using a UI Kit for styling out the pages on a site. With the UI kit, there are multiple CSS files and js files in order to achieve the results of the rendered objects. Is there a way to ...
7
votes
2answers
520 views

Insert Link dialog hangs using wygwam in Internet Explorer - not other browsers

When editing an entry ... highlight text, click ‘Link’ icon > the wrong dialog appears with ‘Select an Anchor’ and ‘E-mail Address’ (see image). There are similar problems in inserting an image ...
3
votes
1answer
93 views

Configure wygwam configuration via field parameter?

Within a channel form, is it possible to override/specify the editor configuration that wygwam uses? For example: {exp:channel:form channel="post"} <label>Post Content</label> {...
1
vote
1answer
143 views

Wygwam - IE8 issue - editor doesn't load and throws javascript error

We're having an odd issue with several sites we run on ExpressionEngine for clients using IE8 and 9 in the control panel. I've seen similar problems here on the forum but nothing that fits the bill ...
2
votes
1answer
72 views

Wygwam source button

i'm using the wygwam editor and i'd like to use the source button/option with my admin account. but the source button should not be visible/usable for other members. any idea how to do that? thanks!...
1
vote
1answer
55 views

is there a way to put javascript and css in the wigwam editor in expression engine?

I'm trying to put this slider (scroll halfway down the page) into my site, which is built on expression engine using the wigwam editor. i have the javascript saved here http://whitewashed....
1
vote
0answers
303 views

Wygwym replace file: The file could not be written to disk

I'm using wygwam 3.2.2 and EE 2.7.2. I'm attempting to overwrite a file from the upload diaglog "The file could not be written to disk." However, this is only on certain user groups. The super-admin ...
1
vote
1answer
23 views

Getting 500 error when trying to convert textile field to Wygwam field

I am trying to convert a field type from a textarea with textile formatting to use Wygwam. I am getting a long hang time and then a 500 server error. The amount of articles using this field is over ...
2
votes
2answers
146 views

How to lock the field height and bring back the scrollbar?

It looks like in Wygwam 3.2.2, the field height grows with the content. It used to have a static height and a scrollbar would appear in the field if content was too tall for it. My client prefers ...
8
votes
3answers
1k views

Wygwam - automatically wrap media embed with custom html

I'm using Wygwam on a site, and I'm allowing content administrators to embed media (specifically, videos) within the main, body copy/content area. Is there a way to automatically wrap the embedded ...
2
votes
2answers
58 views

WYGWAM in comments form

I need to use WYGWAM in comment form. Now I use {exp:comment:form} as it is shown in EE documentation. But it is necessary for me that users could format the text with power of WYGWAM! How can I embed ...
1
vote
0answers
60 views

Securing files that are linked through a Wygwam field

I'm working on a site that has certain pages that are going to be restricted to members only. It's using an external membership database to authenticate members, not EE's native members. Some of the ...
2
votes
1answer
354 views

"Automatically turn URLs and email addresses into links" not working on Wygwam fields

I've got a channel using several kinds of fields (textarea, matrix, wygwam), and I need the "Automatically turn URLs and email addresses into links" functionality on the channel. I've set the option ...
1
vote
1answer
166 views

Getting image files for META tags if in entry

Basic blog setup using Wygwam for the primary field in the entry. Inside the file management, I have Image Manipulations set to manipulate any images uploaded and used formatted for social media. For ...
0
votes
1answer
166 views

Content Elements wygwam not displaying

Can anyone tell me what I'm doing wrong here? Nothing displays at all. content_elements it the name of my content elements custom field {content_elements} {wygwam} {if "{element_name}" == "...
1
vote
1answer
108 views

Error when using WYGWAM 3.2.1 & Assets 2.2.2 with EE < 2.6

According to the WYGWAM Installing and Updating page, WYGWAM requires ExpressionEngine 2.4 or late. However, if you are using both WYGWAM 3.2.1 and Assets 2.2.2 (may be the same for older versions) ...
0
votes
1answer
138 views

Control Panel with Masked CP CORS issues

MSM Setup EE 2.7.2 The site I am working on has masked CP access sitting on a subdomain of the site. This is a MSM setup in which the MSM sites are subdomains of the primary site. Something like: ...
4
votes
1answer
97 views

Initialize Wygwam within Custom Fieldtype

I'm developing a fieldtype add-on and within the fieldtype, I would like to include the option to let users choose Wygwam as the text element, if they have it installed. Is there some sort of a "...
1
vote
1answer
240 views

Wygwam fields disappeared from entry screen

I am using Wygwam 3.2.1 and it has been working fine, but now the field titles are showing on the entry screens but the field and text that had been previously entered is not visible. (it is still ...
1
vote
1answer
72 views

Wygwam Embeds being Removed on Edit Entry

Trying to embed a javascript embed, like from Survey Monkey, into a Wygwam 3.2.1 field and when the entry is edited and saved, the embed is removed. Any ideas?
1
vote
2answers
174 views

Wygwam 3 no longer show table borders

Since updating to Wygwam 3, when you add a table it no longer shows table cell guides. So all you see is nothing. No way to see which cell you are in or even if a table was inserted at all. I ...