Questions tagged [wygwam]

WYGWAM is a custom fieldtype built by Pixel & Tonic which adds WYSIWYG editing capabilities to textarea fields using CKEditor.

Filter by
Sorted by
Tagged with
1
vote
0answers
17 views

CKEditor publisher toolbar missing from WYGWAM on ExpressionEngine 1.7

First...all of this is going to sound very novice...because it is. We had an issue at the server level and the WYGWAM broke. It's been restored by the Publisher(ish) toolbar is missing. I seriously ...
1
vote
0answers
36 views

WYGWAM + Font Awesome icon chooser. Possible?

I saw the "Font Awesome" plugin for CKEditor and got hyped, but couldn't get it to work. https://ckeditor.com/cke4/addon/fontawesome But that seeded the question: Is there a way to get a Font ...
1
vote
0answers
43 views

Links out of Structure Listing in Wygwam is missing trailing slash

When adding a link in Wygwam through Structure Listing, the link is missing a trailing slash. Due to our SEO policy we would like to have a trailing slash in the url's. How to realize?
1
vote
0answers
20 views

How to embed multiline LaTeX equations into Wygwam box

As an example, if I want to use something like: \begin{eqnarray} a &=& b ( d + c) + c \\ && bd + bc + c \\ a &=& bd + c(b + 1)\end{eqnarray}
1
vote
0answers
69 views

EE 2.5.5 not searching in custom wygwam field

I have a site that's using a custom wygwam field for the body of an article page. I've set the field up to be searchable, however, EE is only showing results that have the keyword(s) in the title. Is ...
1
vote
0answers
64 views

Wygwam not retaining Channel Images images

I want to use the Channel Images integration for Wygwam, but there seem to be two issues: 1.) No matter which size I choose for the image, it always uses the smallest image (I have 3 sizes set in the ...
1
vote
0answers
64 views

Customizing Wygwam & CKEditor to prefill width & height attributes

For the latest version of Wygwam, is there a way to: When an image is added, prevent the image dialog from automatically filling the width/height of the chosen image's dimensions Instead, prefill ...
1
vote
0answers
64 views

Wygwam fields disappearing and causing EE 2.9.2 to lock up

I'm having an issue with the latest WygWam Module after moving to a new server and updating to EE 2.9.2. I was on EE 2.2.1 and moved everything over and upgraded about a month ago. Ever since then ...
1
vote
2answers
114 views

Wygwam Grid Compatibility

The Wygwam changelog states that v3.3 "Added Grid compatibility." But when I create a Grid field, Wygwam is not offered as an available field type. EE 2.8.1 Wygwam 3.3.1 Any ideas? Thanks, Philip
1
vote
0answers
67 views

How do I add custom styles to Wygwam using a hook?

I want to add an extension to wygwam that allows me to add my own customized dropdown to the toolbar with different css styles. No idea where to start. I want simple styles for pull-quotes and lists. ...
1
vote
0answers
95 views

Wygwam, channel entry form, and HTML character entities

I think it started about the time I updated to EE 2.8, but I'm not sure. It could have been a Wygwam update too. In any event, my channel entry form featuring a Wygwam field has stopped working when ...
1
vote
0answers
59 views

Best practices: Images in entries with custom HTML5-attributes

I want the images in my entries look like: <a data-footer="xy" data-title="xy" data-toggle="lightbox" href="img.jpg" title="xy"> <img class="img-responsive" alt="xy" src="/path/img.jpg" /...
1
vote
1answer
51 views

Using wygwam with readmore under contentelements

{content_a} {wygwam:excerpt} {value} {/wygwam} {wygwam:extended} {value} {/wygwam} {/content_a} I wanted to have a readmore button instead, The code above outputs ...
1
vote
1answer
30 views

Wygwam error "Cannot redeclare class Wygwam" error after 2.7.2 upgrade

After upgrading to 2.7.2, I am getting an odd "Cannot redeclare class Wygwam" error in the control panel. This prevents entries from opening, and also accessing the Fieldtypes list. Any solution? ...
1
vote
0answers
303 views

Wygwym replace file: The file could not be written to disk

I'm using wygwam 3.2.2 and EE 2.7.2. I'm attempting to overwrite a file from the upload diaglog "The file could not be written to disk." However, this is only on certain user groups. The super-admin ...
1
vote
0answers
60 views

Securing files that are linked through a Wygwam field

I'm working on a site that has certain pages that are going to be restricted to members only. It's using an external membership database to authenticate members, not EE's native members. Some of the ...
1
vote
1answer
166 views

Getting image files for META tags if in entry

Basic blog setup using Wygwam for the primary field in the entry. Inside the file management, I have Image Manipulations set to manipulate any images uploaded and used formatted for social media. For ...
1
vote
0answers
204 views

Broken IMG urls using Channel Images, Publisher Lite, and Wygwam

EE 2.7.0, CI 5.4.8. Wygwam 3.1.2, and Publisher Lite 1.0.10. I’m using CI to handle uploads and then the Wygwam/CI button to insert images directly into a body of text. Publisher Lite drafts and ...
1
vote
1answer
260 views

File and Image Upload in a Wygwam field in a Safecracker Form

I was trying to find confirmation about whether the Browse Server button in the Image and File Upload functionality in Wygwam could be used in Safecracker. Currently the windows pop open fine, but the ...
1
vote
0answers
123 views

Separating Matrix Fields for Use with SafeCracker (Wygwam Fields)

--Update-- Got the loop to work and content pulls in (forgot to put my {exp:channel:entries} tag pair around the safecracker tags). Styling was pretty simple, but I had to change the wygwam field to ...
1
vote
0answers
126 views

WYGWAM double wrapping email links when emailProtection is set to encode

I have an editor configuration set up using emailProtection. emailProtection is set to Encode. If the user adds an email link in the WYSIWYG editor, when it is rendered in the page, it has the ...
1
vote
0answers
64 views

If I use any text with "eval" in it the page throws a PHP error (e.g. "evaluation")

I'm using WYGWAM 2.7 and expressionengine 2.5.5. I get this error: A PHP Error was encountered Severity: Warning Message: Please contact support about failure Filename: libraries/Functions.php ...
1
vote
2answers
374 views

Wygwam 2.7: How Can I Customize the Image Properties Modal?

I would like to customize Wygwam's Image Properties modal to display the following options only: Upload image files from local HD Add Alt text Add a caption I don't want site members to be able to: ...
1
vote
1answer
29 views

wygwam upload assets set keyword

Izzit possible to input keyword right on the wygwam uploader. Now when I right click it only show "view file" I wish there is a way that I can have "edit" so our editor can input some keywords for ...
0
votes
2answers
211 views

Is there any way to strip inline styles added by the client? [duplicate]

My client has an incredibly bad habit of adding inline styles to tons of elements on the page. One of the many reasons I was hired to do this job is because of my focus on semantics, yet they still ...
0
votes
2answers
210 views

Wygwam / ckeditor errors on upgrade

I upgraded Wygwam 2.7.0 to 3.3.3. I run module update and I cleared my browser's cache. I am getting the next errors: Uncaught SyntaxError: Unexpected token ILLEGAL (ckeditor.js) config.js:10 ...
0
votes
2answers
432 views

Wygwam Adding Extra Span Tags with Font-Size Style

I am running into an error when editing content in Chrome on Mac. I upgraded to Wygwam v2.7 to ensure I was using the latest version. I am using EE v2.5.3. When adjusting paragraph text, if I delete ...
0
votes
1answer
151 views

Why font size box was removed from WYGWAM

I have posted my problem under some other thread too. Just want help in restoring the ditto content within a WYGWAM field type after an EE upgrade and WYGWAM version upgrade. The versions upper than ...
0
votes
2answers
138 views

Replacing Wygwam p tag with h1 also adds an empty p

I have the following to strip out the p tags that are auto generated by Wygwam. For some reason it's not happening for me! <h1>{exp:low_replace find="<p>"}{hero_article:articles_title}{/...
0
votes
1answer
70 views

Have WYGWAM image insert be able to select from multiple directories

I am currently using WYGWAM 3.3.3 with EE 2.11.1. I have WYGWAM using EE's file manager. Currently with file manager there are 6 different folders they can upload images and pdf's to. When they ...
0
votes
2answers
149 views

Wygwam is inserting words into the field by itself!

One of my channels has a Wygwam field set to use the "Basic" formatting toolbar. Whenever I save an entry, and then go back in to edit that entry, the word "Schedule" appears as the last line in the ...
0
votes
3answers
26 views

Weird icons in Wygwam

I updated Wygwam to the most recent version (3.3.3) and now the icons in the toolbar all got messed up. I tried re-uploading the themes folder, and emptying the cache, but no luck so far.
0
votes
3answers
1k views

How to remove <p> tags from WYGWAM

I'd like to know how to remove automatic wrapping tags that outputs in page. <p class="summary">{sous_titre}</p> This is what I wrote inside my template. As you can see, I already put ...
0
votes
1answer
58 views

Add <br> button in WYGWAM toolbar

Is there a way to add a button to the WYGWAM styles or controls that allows user to easily insert a <br> tag inside a paragraph?
0
votes
1answer
74 views

Wygwam if conditional

Basically i want to know if its possible for expression engines if tag to check if a wygwam field contains images. I know its possible to pull through just images like so: {my_wygwam_field ...
0
votes
1answer
59 views

Only the first upload directory shows in assets when used with wygwam

When using the main assets window, all of the available upload directories are available to choose from in the left hand navigation. (See Screenshot 1) When using the popup generated by wygwam when ...
0
votes
2answers
630 views

Why are the Wygwam toolbar icons not showing?

I am running Expression Engine 2.6.1 and Wygwam 3.0.2 but the icons do not show up in the field. I could use some help getting them to show up properly. I get the following error when the page loads ...
0
votes
1answer
161 views

How can I setup a table with ingredients in alphabetical order with a letter label and make it easy for client to update?

Please refer to the table at http://www.tomsofmaine.com/research/ingredients for reference. I currently have a Matrix field setup to add new ingredients and generate a table and it works beautifully. ...
0
votes
2answers
703 views

Conflict with Channel Images and Wygwam

When I install Channel Images, all of my Wygwam text fields disappear on the publish entry pages. I can still see the channel field title for the Wygwam field, but the wysiwyg is gone. Has anyone else ...
0
votes
1answer
188 views

Preserving Pixel & Tonic Fieldtype Settings After Migrating to EE2

I'm in the process of migrating a site from EE1 to EE2. I successfully upgraded to EE2, but all the P&T addons (Matrix, Wygwam, Playa & Field Pack) seemed to default to either text, select, ...
0
votes
2answers
44 views

WYSIWYG-editor removes template partials/template variables

I am using Wygwam as WYSIWYG-editor. Now when I add a template variable or template partial inside an html-tag in a field which uses Wygwam it will be removed when switching from source to visual. ...
0
votes
2answers
26 views

WYGWAM freezes on Chrome when popping up a dialog box

When clicking the Link tool, or from the Link tool, clicking "Browse Server," or Create table, or Add Image, WYGWAM freezes for somewhere between 0-60 seconds. This just happens on the first clicks; ...
0
votes
1answer
155 views

wygwam error after move of server

I am new to ExpressEngine. One of my clients has a website built in EE by another developer. We have just moved the site to a new server, and now we are getting the following errors, if anyone can ...
0
votes
2answers
157 views

Adding CKEditor Plugins to Wygwam 4.0.9 in EE3

I'm attempting to add a CKEditor plugin to Wygwam 4.0.9 in EE3, but the documentation I found in pixelandtonic and wygwam docs showing wrong upload folders. There is no such folders as themes/...
0
votes
2answers
201 views

Changing the <img> tag with CE Image?

So if you may or may not know, Google rolled out Amp'd pages and displaying these websites that are 'Amp ready' higher on the search results. Without getting into the details of Amp, we need to change ...
0
votes
1answer
56 views

Suggestion for fields to use for this type of content

I'm using EE 2.11.2, and am having trouble coming up with a good, user-friendly way to set up my fields to represent some dynamic content on a site I'm building. Can you offer a suggestion of a ...
0
votes
1answer
28 views

Wygwam: use apostrophes and proper quote marks

Does anyone know if it's possible to get Wygwam to replace inch and foot marks (" and ') with apostrophes and proper, left and right curly quote marks? So Don't becomes Don’t and "This" becomes “this”?...
0
votes
1answer
48 views

img tag being stripped out of front end

I place an image on a page using the file manager. I can see it in the editor, but when the image is displayed in the front end, all I see is the image path and not the image. When I look at the ...
0
votes
1answer
164 views

WYGWAM 4 is throwing PHP and Fatal errors on 2.10.3

Today I updated an old site from 2.2.1 to 2.10.3. I attempted to update some Add-Ons but ran into an issue with Wygwam. I downloaded Wygwam 4 from Devotee. Follow the update instructions but ran into ...
0
votes
1answer
191 views

Wygwam and ExpressionEngine 3 [duplicate]

Are there any plans to upgrade Wygwam to be compatible with ExpressionEngine 3? If not, any recommendations or issues on upgrading to EE3 and changing editors? Thanks, Carol