Hot answers tagged

23

The following list should get you started: ExpressionEngine Add-On Development Docs: links to guidelines, reference material, and tutorials for developing Plugins, Modules, and Extensions for ExpressionEngine ExpressionEngine Add-on Development Recipes: a collection of articles and tutorials to help you learn how to build ExpressionEngine add-ons Add-On ...


7

As a general rule of thumb: if it’s compatible with EE4, it’s compatible with EE5, too. The jump from 4.3 to 5.0 was necessary to facilitate the change in license model, not because of breaking changes in EE’s APIs.


4

If somebody will have the same error - check if you have Solspace FreeForm . I had the same issue because of this (FreeForm v.4.0.4). Fix - temporary remove freeform folder. You can return it back after update will finish.


3

Disclaimer: I represent Exp:resso (Store). You're not able to use Matrix for product modifiers but in the vast majority of cases you wouldn't need to. Store's own modifiers matrix is fairly flexible providing a way to name your own modifiers along with optional individual or shared SKUs, optional price adjustments, and individual stock control. At present, ...


2

If you're able to compile all of your data into something like a spreadsheet, you may be able to use one of the import add-ons like Solspace Importer, Data Grab, or Data Import. I've been using Solspace Importer for something similar to what you want to do, and it works well--and accomplishes a big chunk of the batch processing that I need. However, in my ...


2

EE2 add-on's are NOT compatible with EE3. Add-on authors are making the transition, but depending on the complexity of the add-on and the availability of the developer, some will take time. You can view a list of the current add-ons that are EE3 ready here... https://devot-ee.com/add-ons/filter?&f=ee3 And here is a semi-comprehensive list of other add-...


1

You have a few options. If it's just extensions, you can use this configuration override to disable all extensions: $config['allow_extensions'] = 'n'; Add that line to the end of your config.php file. That might allow you access to your Control Panel to move forward with removing add-ons. Another option is to (backup these tables first) truncate your ...


1

Hrm, well that line in ext.rte.php in the 5.3.0 release is: var $docs_url = DOC_URL.'add-ons/rte/control_panel/index.html'; So based on that error, I would assume the DOC_URL constant is not yet defined, or isn't being type interpereted as a string. So try this: var $docs_url = ''; If the pages loads, this smells like it could be a bug; start by ...


1

Looks like Dreamweaver added a random _notes folder to the system/expressionengine/controllers/cp directory, which caused the problem. Derek at Ellis Labs lead me in the right direction to figure it out! https://ellislab.com/forums/viewthread/248756/


1

You will have to login with your super admin account and go to the settings panel. From there you will need to navigate to the security panel. You should see your member group on the right hand side and you will need to check the boxes for the permissions you want to grant to that member group. (as seen in the picture below)


1

Disclaimer : I'm the developer of Charge so am biased on this. Yes - this is all quite simple with Charge. You'd simply use the standard front-end entry form as usual and set the entry status to a pending state, then use the built in entry actions in Charge to update the status to live after a successful payment. This can all be used with recurring ...


1

You should look the at the folder system/plugins/, which is where EECMS 1 keeps its plugins, and look for the name of each plugin or a readme file. The best place to look for new versions is devot-ee. Almost all EECMS add-ons can be found there. The EECMS 2 plugins are separated into 4 categories: fieldtypes; accessories; modules; plugins. All of the them ...


1

ExpressionEngine has had some updates to do date localization and relative dates. The particular line from the core that is causing your issue is Line 4166 in expressionengine/libraries/Template.php. There are a number of solutions here for your problem. Ideally line 349 should check to make sure it is a string as well because strtotime will only work as ...


1

EE 2.8 will consider any tag variable that contains "format=", "timezone=", or ":relative" a date variable. Do you have any tags within your exp:rest tag pair that contain any of those phrases? For example, these made up variables would be considered date variables: {foo format="%Y"}, {bar timezone="America/Chicago"}, and {oldest:relative}.


1

The first thing I would try is ensure that all addons (fieldtypes, extenstions, modules, plugins) are updated and then re-uploading the 2.7.2 EE files. if that doesn't work, you may need to rollback to your backup of the site and try again.


1

AD.#1 - Well, both have own pros and cons. Pros of Expresso Store is their documentation and support. Cons - some modules/options available in CartThrob are not available here (weight per SKU, gift registry) AD.#2 - It is up to what do you mean by "flexibility". I have worked on Magento site and now I'm working on Expresso and Expresso + EE looks more ...


1

Removing Freeform (and putting it back after the update has finished) works for me still.


1

Just had the same issue upgrading to 2.7.3 and thought I should let people know that the removing free form, then pasting it back in after upgrade solution still seems to work.


Only top voted, non community-wiki answers of a minimum length are eligible