Hot answers tagged

4

Well, There are two ways to do so. Server side: In your {exp:channel:form} tag, Add parameter rules:captcha="required" Client side: Use jquery.validate.js to make field required. Include this js library: http://cdn.jsdelivr.net/jquery.validation/1.15.0/jquery.validate.js Put the class required in input field. Use jquery to run the code before form ...


4

Spam is an uphill battle, any solution made by man to stop it can be broken by man to abuse it. The unfortunate truth is that traditional spam solutions are very short term and don't scale. What I have noticed, though, is that on sites where similar things happen quite often the registrations stem from a couple of the same IPs and blocking them from the ...


4

For our FreeForm forms, we use the following code: {if freeform:captcha} {freeform:captcha}<input type="text" name="captcha" style="width:140px;" /> {/if}


3

There is not a hidden config that I'm aware of...


2

This has bitten me a few times and it has always been a path issue. Double check your captcha preferences. Also, make sure the captcha directory/folder is writable by your webserver


2

Are you logged in while viewing the form? Native EE CAPTCHAs don't display for Super Administrators.


2

Check the permissions on your images/captchas directory. It needs to be writeable so the system can store Captcha images in there.


2

You can remove the {captcha} tags from the templates, or comment them out: {!-- {captcha} etc.. --} and / or turn the captcha off on each channel by going to the channel preference for the relevant channel: Admin > Channel Admin > Channels > Edit Prefs Captcha docs


2

I had my fields hard-coded instead of using {freeform:form} tag as mentioned here: http://www.solspace.com/forums/viewthread/17716/#63420 This solved the issue.


2

If you can see the CAPTCHA sometimes then you don't have a problem with permissions or the GD library. Are you logged in to the site/CP when you can't see the CAPTCHA? There is a setting to show CAPTCHAs only to users that aren't logged in.


2

Unfortunately, requiring a captcha is site-wide, not form-specific. I'd suggest instead looking at Snaptcha, which is far more effective and requires no input from the user.


2

If you are not using the EE native member templates, then instead of making the trigger word a random word (might be difficult to guess, but can theoretically still be hit by spammers), you can simply add a hash in front of the trigger word so the URL can't be accessed, like: #member of if you are using a custom config file, you can do it like this: $...


2

You'll need to use some ajax and create an endpoint, ergo refreshing just the captcha. Fortunatly, once you have that in place actually creating a captcha is totally easy, there's a helper in the system but the function is also available via ee itself : //create a captcha and return the HTML $captchaHtml = ee()->functions->create_captcha(); https://...


1

Thanks Derek Hogue for the reply. But I have found a work-around for this. I manipulated the config file according to the URI.Changed the LINE #173, and added an IF-ELSE condition. if(stristr($_SERVER['REQUEST_URI'],"<Mypage_URI_Where_I_Dont_Cant_Captcha>") || stristr($_SERVER['HTTP_REFERER'],"<Mypage_URI_Where_I_Dont_Cant_Captcha>")){ $...


1

If CAPTCHA is enabled and the image isn't showing then it could be a couple of things. Your CAPTCHA directory isn't writeable so EE can't create the image. You don't have the CAPTCHA code in your form. Since you are getting the error message I would guess that it's option 1. But, please post your template code otherwise it's all guesswork on our part.


1

Here's what I've done to completely stop spam members from registering on my default EE member registration forms while still allowing those forms to be used without needing any add-ons. Make sure spam members are actually using the EE forms by adding a new member field that will be filled in with the current URL of the registration page. Hide it on the ...


1

There is no fool proof way of preventing spam. Captcha solutions are obtrusive to the user experience and not very effective, which is why they are not recommended as the only line of defence. Eric Lamb has written a good article entitled "Avoiding CAPTCHA With ExpressionEngine" in which he also presents the solutions he recommends. As the developer of ...


1

The best solution ended up being Snaptcha: http://devot-ee.com/add-ons/snaptcha. I was originally thinking I'd add a custom field to Composer the same way you add EE's default captcha, but with snaptcha it automatically adds itself inside your form tag and (I assume) just works. Really convenient: just enable and all of your forms get it.


1

For anyone with the same issue, make sure that you go to Admin > Channel Administration > Channel Form and then choose Yes for Guest Captcha for the relevant channel.


1

The solution, as posted by Ben in the devot-ee support forums, is to try making each tag unique as follows: {exp:snaptcha:field id="1"} {exp:snaptcha:field id="2"} That fixed it for me. I now have two user registration forms on the same page and both submit as they should.


1

in your template code you have an opening form tag before your user tag: <form class="edit invert validate-edit require-terms"> {exp:user:register and therefore your output looks like this: <form class="edit invert validate-edit require-terms"> <form name="register" class="edit invert validate-edit" id="member_form" method="post" action="...


1

Quick check - if the captcha is not displaying, and they can still submit the form... then the chances are they are logged into the backend of the EE control panel and their member group has captchas disabled. If the captcha is not displaying, and they cannot submit the form due to captcha non entry. Then i would first suggest looking at the path for the ...


1

you could use Snaptcha's {exp:snaptcha:field} template tag but you would need to run the field validation yourself. there are instructions on how to do this in the docs but some php knowledge is required.


Only top voted, non community-wiki answers of a minimum length are eligible