3

Concerning a statement from EllisLab, they posted a blog-entry on 13th April, 2016 telling that EE2 and EE3 are PHP 7-compatible: https://ellislab.com/blog/entry/time-to-upgrade-php


2

I just gave it a shot and it looked like the install worked fine, but the control panel loaded up with a bunch of errors. It looked like they could likely have been suppressed by turning off E_NOTICE or changing E_STRICT in error reporting since they didn't look like errors that would stop anything from working.


2

Been running EE3 (3.3.3) with php7, and it runs smooth as a baby's butt. There are a whole lot of problems with add-ons tho I've realised. Solstice TAG throws a nasty error making it impossible to add new entries. DataGrab is not working (Well, the UI is, but no imports are made, and no import-setups can be saved). Don't know about any other add-ons (...


1

This has been fixed in the latest version of Tagger. The issue was due incorrect URL generation if CP Session ID and Cookies where used.


1

I have run a site locally on PHP 7 without any problems. EE usually only requires a minimal version of PHP. As I've said, no issues so far.


1

I'm running EE 2.8.1 on PHP 5.5.10 and I've not noticed any problems so far. You should be safe.


Only top voted, non community-wiki answers of a minimum length are eligible