Hot answers tagged

6

As of 2.8 it's changed slightly... So if you want to disable "secure forms" you'll need to use this in config.php instead of what is posted elsewhere. $config['disable_csrf_protection'] = "y"; More info here: http://ellislab.com/blog/entry/sessions-login-modals-and-secure-forms-in-expressionengine-2.8


5

I was almost certain that Custom System Messages was causing this problem. The template offline message could be set in the preferences, but it was not. As Custom System Message has a greater priority over EE offline template, and no template was set, it was not working. The template was set inside Custom System Message The problem is solved.


4

You shouldn't see the site in online mode if you have set $config['is_system_on'] = 'n'; in your config.php file. If you are seeing the site, I'd guess one of the following is true: You are editing the wrong config.php file You are still logged into the control panel as a SuperAdmin. Clear browser cookies to be sure and confirm that you see the login ...


4

is not possible that some add-on can be affected on this. You need to be sure, that you are not login as SuperAdmin. Because Super Admin can see site even in offline.


4

You are correct. The only thing that you will need to do is open up system/expressionengine/config/database.php and change the hostname username password and database and change the settings to match your new MySQL server credentials.


4

A coworker had this same problem earlier this week and added 'application/octet-stream' to the mime types to solve this.


3

Sorry for the trouble. This is an issue in EE 2.9 and will be fixed in the next release. For now, you can get around it by specifying the cache driver in your config.php: $config['cache_driver'] = 'memcached';


3

Take the standard method and add in your subfolder name before index.php in the RewriteRule. <IfModule mod_rewrite.c> RewriteEngine On RewriteCond $1 !\.(gif|jpe?g|png)$ [NC] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ /SUBFOLDER/index.php/$1 [L] </IfModule>


3

You are probably not going to get the answer you are looking for and I have no idea why EllisLab chose to do what they did when building EE as I am not part of their team. Having said that I recommend you email them and ask them personally. But to answer your main issue of changing paths and urls easily. EllisLab has setup EE to handle a bunch of ...


3

If by config variables, you mean the ones on config.php, it's pretty easy to do. On your config.php add the following code: global $assign_to_config; if(!isset($assign_to_config['global_vars'])) $assign_to_config['global_vars'] = array(); Now, you can create early parsed template variables. Let's say you set the mail protocol used by a System Config ...


3

The correct array key for the database user is username not user $config['database'] = array ( 'expressionengine' => array ( 'hostname' => 'localhost', 'username' => 'username', 'password' => 'root', 'database' => 'dennis', ) );


2

I can see no one answered this for you. I'm having issues with autosave, maybe my explanation about how it works will answer your question. Maybe the issue I'm having is the same? autosave does not work as expected. Specifically RTE and WYGWAM


2

I recently had this same issue. I resolved this way. I pointed my staging domain to: | staging_subdirectory / public_html And file structure looked like this: --system --config --public_html | |staging_subdirectory -system -config -public_html -index.php -admin.php -etc. I deployed production to / and staging to /...


2

If you are going to set it in config.php (instead of index.php or admin.php), you have to set it to 2 instead of 1. $config['debug'] = 2;


2

I use the Focus Labs 'master.config' system rather than the Bootstrap one but it's basically just a variation on the same theme AFAIK so hopefully this input will still be applicable. What I've found is that whilst, in theory, you're supposed to create the upload destinations before you can redefine them with your config file, in practice it is possible to ...


2

This is caused by not having a trailing slash on the server_path parameter in the upload directory config. The Focus Labs documentation within the master config doesn't include the slash $env_config['upload_preferences'] = array( 1 => array( 'name' => 'Uploads', 'server_path' => $images_path . '/uploads', '...


2

Turns out this was due to Transcribe, we needed to use {exp:transcribe:uri path="/"} paths!


2

This is not currently possible with Store - the way Omnipay is integrated with its abstracted settings methods it only looks in the database. A good feature request for Vector though! (Likewise for CartThrob.)


2

Figured it out. FROM php:fpm-alpine Doesn't include the mysql mods. I had to add this line to my dockerfile for php container: RUN docker-php-ext-install mysqli pdo pdo_mysql


1

What are you trying to accomplish? We typically allow multiple domains to point to the same site, but then use .htaccess to redirect them to a single, canonical domain. This would prevent your issue, as well as protect you from duplicate content SEO penalties.


1

It sounds like you need to take a look at the Multiple Site Manager add-on from EllisLab.


1

I had the same problem after updating Wygwam from 3.2.2 to 3.3.3 on EE 2.7.3. I found that it's a browser cache issue. After clearing out the cache, the icons were back.


1

I was able to find the answer to my problem. I found that my server email was the issue. So I set up an account with Sendgrid and it immediately fixed my problem. I found others complaining of the same issue with the same versions I have and said that the site server sometimes has issues and those emails get blocked immediately and don't even go to spam, ...


1

There is nothing built into the EE core that would allow you to do this. You have a few options though. The easiest would be to use something like Better Pagination which will allow you to setup different Pagination URLS. The other option is to build the url you want and use some template logic to grab the correct URL.


1

As I said in my comments: I was still able to click on Admin> General Configuration link which showed a very basic form, when I entered the correct path, I was once again told that I had to set the config.php to 666, which I did and everything is fine. Thanks guys - I am a true newbie to ExpressionEngine - thanks for being there


1

Not all configurable options are in the default config file. This is one of them. But the good news is that you can set an override in your site's config file just by adding it the following: $config['tmpl_file_basepath'] = '/path/to/your/templates'; It is possible to override many things in this way, to get the array key examine the ID of the input for ...


1

There was a change in Assets 2.2.3, "config settings no longer require slashes in the array values". If you want Asset to ignore PHP, HTML and JavaScript files, you can try this: $config['assets_ignore_file_patterns'] = array('^.*\.(php|html|htm|js)$'); Important step: after changing the config, you have to update the indexes.


1

Sure, try this in your config file: $config['assets_ignore_file_patterns'] = array('/\.html$/');


1

EE CP don't use variables from index.php. Only from config's or from admin.php. Index.php is only effected on Frontend. For other sites the system preference is keep in DB (exp_sites table). So you just need to change it for each site. p.s. possible you setup your first site site_url in admin.php - you need to removed for your model.


1

Right, I've solved this by adding paginate_base="news" into the channel:entries tag and it works correctly now. I have no idea why it was broken in the first place though!


Only top voted, non community-wiki answers of a minimum length are eligible