People who code: we want your input. Take the Survey
3

I've added a {ce_counter} variable to the elements loop. Open the ft.content_elements.php file and navigate to the replace_tag function. Insert $i_counter = 0; just before the foreach $data loop. In the loop, look for the // Counter section and add: $i_counter++; $tagdata_parsed = str_replace('{ce_counter}', $i_counter, $tagdata_parsed); In the loop, ...


3

Unfortunately, it's not currently possible (as of Content Elements 1.6.10) to rename a Content Element. The only workaround is to delete an element and create a new one. I've made a feature request for this to be added though.


2

You have to wrap the element_name in quotes: {if "{element_name}" == "Address Content"}


2

Mailed KREA-Support, here´s the solution: {if "{element_name}" == "Kasten"} will do the trick.


2

Looks like you're just missing conditionals based on the image {count}. This should get you in the right direction. I didn't add in your CE Image tags. {gallery} {if element_name=="galleryname"} {images} {if count == 1} <a class="fancybox-buttons" data-fancybox-group="button" href="{image}" title="pic{count}"> <...


2

You could do it with Matrix and create a column for every possible piece of content, although it could get unwieldy. Or maybe Entry Widgets will do what you need.


2

I would suggest you use EE categories for your product categories rather than channels. Each product tile is an entry in the products channel, and each tile is assigned to one or more categories which determines which product grid it shows up on. The index/category page is then just a list of the categories in your product categories group, and the product ...


2

I think your idea of using Matrix rows or Krea Content Elements to set up separate pages is a good one. In the past, I've just used a single Wygwam field in conjunction with Simple Pagination. The Simple Pagination plugin makes it possible to split up an entry into an unlimited number of pages by simply entering {pagebreak} I suppose the nice thing ...


2

One alternative would be to create a text fieldtype in which the client could simply enter the video ID, which you would then parse into the Vimeo embed code within the template. It's not perfect, but it's a potential solution. You might simply have to do an element name lookup to distinguish it from any other textfield options you have provided as an ...


2

Open up ft.assets.php file (located at third_party/assets/ft.assets.php), find the method "replace_element_tag" and add this as the first line in that method: $this->EE->load->add_package_path(PATH_THIRD.'assets/'); Sometimes EE would lose that package path and I'm not entirely sure why.


2

If I recall correctly, then it was not possible to have CE RTE and Wygwam on the same page due to conflicting CKEditor instances.. If you switch out all your CE RTE fields for CE Wygwam fields, it should work again.


2

There is no officially sanctioned way to do this for Blocks. And, as far as I'm aware, there is no third-party add-on that will make this easy. Like sheferd said, you're going to want to make a backup, find the field ids in the database, etc. In Blocks, create a new block type by going to Add-Ons → Modules → Blocks. Create a block type with a single Wygwam ...


2

I had a similar issue in the past moving a large amount of content from one field to another in a different channel. I used MySQL to achieve this, unfortunately I'm not too good with MySQL and it was some time ago and I can't find the link I used the query from but hopefully this points you in the right direction. What I did was; Most importantly make sure ...


2

I have done this sort of migration a couple of times and it is doable but not straightforward. Broadly you have to first get your old site to dump out the content of the field for each entry concerned in a format you can work with (i.e. some kind of structured file) and then create an appropriately capable fluid field and write some SQL to insert this ...


1

What you probably need is Bloqs - the EE3 version of an EE2 addon called Blocks It is a well supported, stable add-on doing the similar things to Content Elements. There is a migration path from Blocks EE2 to Bloqs EE3, but I don't know how easy it is to migrate from Content Elements to Blocks/Bloqs, so might be worth checking on that.


1

You could use Content Elements? Create a new field type called "Event Pricing" selecting Content Elements as the field type, then when editing the field remove all the default ones, then add your own custom ones from the bottom, where you can type in the label and select the content type: "Pricing Header" (Header content type set to h3 for example) "Price" (...


1

Check if custom field with short_name "nieuws_description" already exists in custom fields settings.


1

I then click on the "Save Changes" button, and it loads up the screen where I can begin to add the different CE types as I please and populate them with content... except after all the custom fields I created, I see all the default fields as if they had never been deleted... O.o Today has been released new version of Content Elements and this bug ...


1

It's always the way - you solve you're own question after posting but Ive left it up in case anyone else might struggle with this for some reason. I got it to work with the following code, a mixture of 'total_files' and limiting entry numbers in the assets/files variable. It doesn't seem tidy, but it does work. (NB Im not using Content Elements built in ...


1

Managed to resolve this with the help from Mark Croxton. Using a list target each content type with the same variable name. Example below: {exp:stash:set_list name="content-section-1" parse_tags="yes" parse_depth="2"} {c} {heading} {stash:content}{value}{/stash:content} {/heading} {wygwam} {...


1

In case any others might be struggling with this annoying problem: it's a compatibility issue, get the latest Field Pack (2.2) and everything works as it should :) The Field Pack Changelog lists the following updates for Content Elements support: Added support for {element_name} tags within Content Elements. Fixed compatibility issues iwth Content ...


1

First, try deleting and re-adding the entire Wygwam folders as there may be a corrupt or missing file. Second, update to the latest Wygwam (3.3.1 now).


1

Well, this was quite frustrating but I hacked together a workaround that at least lets me move forward and will make due for this use case. It seems the issue stems from a database migration. I dumped the DB from production and loaded it up locally, which is where the non-render issue presented itself. I was able to force the errant entries back into ...


1

The issue was (even though it wasn't being used), I had another wysiwyg available to use alongside the wygwam. Per P&T docs, this causes an issue. I simply removed the wysiwyg from the field type options and this fixed the issue: http://pixelandtonic.com/blog/wygwam-3


1

Your closing wygwam tag needs a forward slash /. {content_elements} {wygwam} {if "{element_name}" == "Content Left Side" OR "{element_name}" == "Content Right Side" } <div class="col-lg-6"> {value} </div> {if:else} <div class="col-lg-12"> {value} </div> {/if} {/wygwam} ...


1

Content Elements and Wygwam are not currently compatible. The CE devs did contact us and we're working with them on that compatibility; but it isn't available yet.


1

I had an issue with format buttons not showing on the front end of my Channel Forms, latest release needs you to render the css file on your site, maybe this is the issue as I assume CE will need to release an update to ensure this is picked up also.


Only top voted, non community-wiki answers of a minimum length are eligible