Hot answers tagged

21

Double check the database.php settings file. It's most likely to be some kinda of database connection issue. It may be that your host has changed the IP of it's DB server or something is blocking the connection. See if you can log into the database directly through your hosting control panel or phpMyAdmin with the same credentials.


21

The guys at P&T did come back to me in less than 24 hours with a fix. I'll post it here in case someone runs into the same problem. Take a look at the columns in exp_playa_relationships table in the database. Does it have a field parent_var_id? If no, then the version you should set is 4.1. If yes, does it have a field parent_is_draft? If ...


12

Broadly speaking, as the error says, you are not connecting to your database. So, check to make sure everything is "plugged in" properly. Things to check: /expressionengine/config/database.php - file exists - triple check you are using the correct database info for your current server/environment (host, username, password, and database name) - file has ...


11

A white screen of death normally means that a PHP error has occurred but it's being suppressed. They should normally be shown if you are logged in as a superadmin but sometimes aren't depending on your config. Here's some things to try to make the error visible: Go into your admin.php and change $debug to 1 instead of 0 (it's under "Error Reporting"). ...


11

Jesus Christ, never EVER enter a comma in EE. I bet you brought down gmail yesterday too.


10

Take a look at my comment on this post: "no input file specified" - .htaccess Might be the same issue: if so, you need to add a ? to the RewriteRule (to index.php) in your htaccess, for example: From RewriteRule ^(.*)$ /index.php/$1 [L,QSA] To RewriteRule ^(.*)$ /index.php?/$1 [L,QSA]


9

So some quick googling, while MediaGirl was typing, found the answer here. When EE updates, it’s running through each update file in order, and those update files can be found at /system/installer/updates/. They look like ud_231.php, where 231 is the version number that’s being updated. When EE finishes running through the routines in that update ...


9

This came up on Stack Overflow recently and prompted a semi-official response: This message will likely be removed in a future release. It's causing too much confusion than help and isn't entirely necessary. Yes it would be helpful for the developer log to let you know which addon is causing the problem, but the logistics of parsing backtraces to find ...


7

If I recall correctly, the trigger itself is not enough - you need to append your action to the last segment At least, thats what I figured to be the problem when I had this. I had to go to /profiles/login/ and /profiles/profile/ etc and then this worked fine. Although this could be a bug - but is the way that I've done it.


7

The "You are not authorized to perform this action" error in this case was caused by users using their browser's back button while testing the form. Adding the secure="no" parameter to the exp:low_search:form tag fixed the problem: {exp:low_search:form secure="no"}


7

Thanks for the pointers, all. In this case, I ended up having to increase several timeout limits: First, to address the original fastCGI error: /etc/httpd/conf.d/fcgid.conf FcgidIOTimeout 90 This fixed the PHP/fastCGI error, but revealed a 500 Error coming from Nginx timing out. The fix: /etc/nginx/nginx.conf keepalive_timeout 125; proxy_read_timeout ...


7

You will get that error if you have secure forms enabled, and you submit a form without including a valid XID in the post. More here: http://ellislab.com/blog/entry/putting-the-secure-in-secure-mode-forms Add this to your form: <input type="hidden" name="XID" value="{XID_HASH}"> You can disable secure forms in your config, although this is not ...


6

Another useful tip that I discovered recently is that you can actually override any @ suppressed errors via the xdebug.scream config setting. This isn't much use in production environments where you presumably won't have Xdebug installed (and you should be hiding any errors anyway), but if you add the following snippet to your local dev environment's php.ini ...


6

Looks like in /system/expressionengine/modules/blacklist/mcp.blacklist.php on line 593 it's pinging: http://ping.expressionengine.com/index.php. Most likely an oversight on EL


6

Big thanks to Joel Bradbury for solving this one. I needed to add $config['disable_csrf_protection'] = 'y'; to my config. Here's why: It'll be because the tokens have been generated on a different base domain, and then it's moved and gotten stuck. Normally they're regenerated when they're detected as expired, but if it see's them as not expired, but ...


5

Hi @Andrew error 500s are server errors. To my knowledge EE does not log such errors. You would need to request/access the logs from your host provider. Here's some info on where to access the logs if you're hosting locally using MAMP. The specific server logs you'd want to look at would be the Apache logs, Access and Error which can ofter be located in the ...


5

I use the Sitemap-Module V 2.6 from PutYourLightsOn. This caused the error. When I disable the module all is fine. The most recent version of this module is 2.6.2. I installed it, but the problem persisted. The message Message: Undefined index: field_id_sitemap__ping_sitemap gave me the hint to try to disable the sitemap module. I will ask the programmer ...


5

The most common Publish Page DB error for site where member can publish they entries is happens because spammers registered too many accounts. And Publish page just going down when it trying to load the authors list. In Safecracker you don't have author list field, so it's why this issue is not effected on SC form. But you can tested it just trying to open ...


5

This one's not worth tracking down the root of to be honest -- this is most definitely not what embeds are for, and I'm not surprised you're hitting an error when trying to load this giant hunk of PHP as an embed. My advice is to work with ExpressionEngine, not against it by cramming dozens of lines of PHP into a template. I'd look at moving your custom ...


4

The 2.5.4 release changed the exp_security_hashes table structure. Any addons that were attempting to manually create an XID hash (EE uses them for secure form processing) are likely to have been caught out by this. In your case it looks as though the Rating module is the culprit. It doesn't look as though Solspace have released a patch yet so you'd need to ...


4

The culprit is probably $site_pages['templates'][$eid]. A couple of obvious things to check would be: What's in the templates array? Find out with var_dump($site_pages['templates']); Check where $eid is set. It's a bit of a leap of faith, but since the error looks like it relates to a template that isn't there, is there any chance you've assigned that page ...


4

Either delete that show_sidebar column in the DB or comment this query out in the upgrade script.


4

We'll have an official release out for this shortly, but in the meantime, open up system/expressionengine/third_party/assets/ft.assets.php. Your line 523 should look like: foreach ($data as $file_id) { try { $vars['files'][] = $this->EE->assets_lib->get_file_by_id($file_id); } catch (Exception $exception) { // ...


4

I have ran into the same issue on MediaTemple and have fixed it by modifying the .htaccess file. For me, my old base .htaccess references index.php and was missing a '?' after it. First place I would check is .htaccess and go from there.


4

If you are using EE 2.7+ there is a new current_query_string global variable you can test against. {if current_query_string} {redirect="404"} {/if} Or, for versions less than EE 2.7... Install the Mo Variables Extension and enable the setting that gives you a {query_string} variable. Then in your homepage template you can do {if query_string} {...


4

If you were using 2.4 you probably need to update FreeMember to the latest version to address changes in EE for the 2.7.x releases. Safecracker is now part of the channel module. You can download the latest version at https://github.com/expressodev/freemember


4

It turns out this error was caused by a misconfiguration of the SSL certificate at the web host's end. After getting the error on Exp:resso Store pages using https, I tested a page load of the home page (a non Store page) and got the same error. I concluded it wasn't an Exp:resso Store specific issue. I eliminated htaccess as the source of the error by ...


4

Turns out, this has nothing to do with Store at all. Found my answer on StackOverflow: Since PHP 5.3.9 there's a new configuration setting called "max_input_vars" which limits the number of input variables. The default setting is 1000. Also check if Suhosin is installed, because there's also a similar setting.


4

ExpressionEngine has a protection against Cross-site Request Forgery - CSRF and a documentation available here. You just have to add that line to your form: <input type="hidden" name="csrf_token" value="{csrf_token}"> And send the data in your AJAX request. I had the same problem today and that fixed it for me.


4

I just encountered this, and found that I had to follow the instructions in this Dreamhost wiki entry to truly enable fileinfo functions. (The default "shared" fileinfo support didn't cut it.)


Only top voted, non community-wiki answers of a minimum length are eligible