7

I assume that EE's native file upload functions use the Upload class, but what exactly does the Upload class do to validate and sanitize? Does it check MIME type using some sort of actual file analysis, or does it simply rely on what the browser reads it as? The Upload class uses the $_FILES array and it does use $_FILES[]['type'], but we do some ...


5

The problem lies in that you can upload multiple files using FreeForms File Upload Field Type - so you can't just use name="file1" as your field name. To make this work, you have to pass the field type as a post array, so name="file[0]" for the first file (and if you have multiple files name="file[1]", name="file[2]" and so on. So, the resolution (for me ...


5

Add the trailing slash for the 'server_path' also. /** * Custom upload directory paths * * The array keys must match the ID from exp_upload_prefs */ $env_config['upload_preferences'] = array( 1 => array( 'name' => 'Home Page Slideshow', 'server_path' => $images_path . '/home_slideshow/', 'url' =&...


5

Channel Images can do that and a lot of other neat stuff: http://www.devdemon.com/documentation/channel-images


5

The CE Image plugin has a watermark functionality (and much more), check 'watermark' on this page: http://www.causingeffect.com/software/expressionengine/ce-image/user-guide/parameters


5

Here is one approach: Put the users in a member group that has the member preference "Can edit entries authored by others" set to "No" Use Channel Images or Channel Files to manage the file uploads. These add-ons have per-entry file management, so they will create separate directories per Channel entry. This combination effectively makes it so that ...


4

You can use your original code if you prefix variables with the Grid field's short name. The purpose of the prefix is to avoid conflicts with the outer Channel Entries loop; it doesn't affect functionality. {gallery_images} {gallery_images:community_image} <img src="{path}_thumbs/{filename}.{extension}" alt="{title}"> {/...


4

EllisLab addresses this issue on a blog post. Part of it: If you encounter problems with uploading files check the following: Login to your CP and go to Tools, then Utilities, then PHP Info. If you see --disable-fileinfo on that page (I recommend using your browser’s search function) then you will need to contact your host and have them provide a version ...


4

I just encountered this, and found that I had to follow the instructions in this Dreamhost wiki entry to truly enable fileinfo functions. (The default "shared" fileinfo support didn't cut it.)


4

A coworker had this same problem earlier this week and added 'application/octet-stream' to the mime types to solve this.


3

By default, the members of the guests group cannot upload to EE; this is a permissions issue, but, it's permissions within EE, not with the filesystem, which is why CHMOD'ing to 777 didn't help. Here's a link to a previous post with this problem, and a solution.


3

If you have favicon.ico in your website root folder--i.e., so the favicon's URL is http://yoursite.com/favicon.ico, then you do not need to include a link to it in your HTML header. Browsers will automatically try /favicon.ico when they find no link in the header (and, some will try /favicon.ico even when do find a link in the header…). However, if you do ...


3

There's not one way to do this with EE. It all depends on your code. You should find the section (or sections) of your site templates that have the meta tags. Then add your favicon tag there too. To make sure you have the correct path to the favicon, open the favicon link in your browser. Example: <link rel="shortcut icon" href="/favicon.ico" type="...


3

This is bug with ckeditor upon which WYGWAM is built. Pixel and Tonic have said fix is coming soon in new release of WYGWAM.


3

If you have command line access on the server, you can setup a Symbolic Link: http://www.wallpaperama.com/forums/linking-files-with-symbolic-links-linux-unix-shell-command-tutorial-guides-t479.html Apparently you can also set up a Symbolic Link without command line access using PHP: http://perishablepress.com/use-php-to-create-symbolic-links-without-shell-...


3

I've seen instances where PDF uploads won't work in Firefox if you've got ExpressionEngine XSS filtering file uploads. In Admin -> Security and Session Preferences, set "Apply XSS Filtering to uploaded files?" to "No". I'm not a fan of disabling security measures like this, but I've found no other solution.


3

I've had this same problem. I solved it by simply using {if segment_1 == "abc"} statements to not include my jQuery on any page (segment) that had Channel Forms loading it's own jQuery. You can also overwrite the jQuery file that EE/Channel Form includes with your version of jQuery -- I have found EE's version to be slightly different to what I download ...


3

The image problem is usually caused by the setup at your hosting provider (Nexcess?). I believe you can fix this by setting the correct base path for CE Image, as described here. EDIT: And this is an example of how to set it at Nexcess: $env_config['ce_image_document_root'] = '/chroot/home/account/domain/html';


3

With that error when uploading a PDF the first thing to take a look at is Admin ‣ Security and Privacy ‣ Security and Sessions and see whether "Apply XSS Filtering to Uploaded Files" is set to "yes." If it is, try setting it to "no" instead. If that clears it up and you don't want to globally stop applying XSS filtering to uploaded files then there is a ...


2

I managed to get this working. Here's how. I made a hack for VZ Exif (by Eli Van Zoeren) that reads in orientation data. You can use this with CE Image to accomplish conditional rotation based on the photo's orientation. Click here to download the hack. Put the hacked plugin in ./system/expressionengine/third_party/vz_exif/pi.vz_exif.php Install and enable ...


2

How do I find out what might be wrong with the images? There could be one (or more) of several things going on. Here are some things to check: Verify that you can upload an image to the upload directory in question. Content → Files → File Manager → click "Upload File" button and upload to your directory. If you succeed then your images are ...


2

I had this same problem and after some head scratching, found that for some reason the other member groups didn't have file upload priviledges. So, check: Content -> Files -> File Upload Preferences -> Edit (select at least one location) And check that at least one upload location allows the Member Groups to upload files.


2

I am using Focus Lab's EE master config so I had to add a trailing slash on my directory paths in the config file. This is what I had: 1 => array( 'name' => 'Images', 'server_path' => $base_path . '/uploads/images', 'url' => $base_url . '/uploads/images/' ) This is what fixed it: 1 => array( 'name'...


2

I'd suggest reuploading the Matrix theme files. It's possible they were missed or corrupted if you recently upgraded.


2

I believe ExpressionEngine actually takes care of the issue for you by automatically encoding the spaces as %20. You shouldn't need to use a plugin or enable PHP. To check this just output the Grid row's {file_url} and you should see it encoded. {my_grid_field} <li>{my_grid_field:file_url}</li> {/my_grid_field} If the file you uploaded was ...


2

You can not natively upload all the files at once with grid. But you can individually select them for each cell in the grid


2

This is caused by not having a trailing slash on the server_path parameter in the upload directory config. The Focus Labs documentation within the master config doesn't include the slash $env_config['upload_preferences'] = array( 1 => array( 'name' => 'Uploads', 'server_path' => $images_path . '/uploads', '...


2

1: create template with this html file name & content 2: use ftp to upload file


2

Assets is the most advanced file manager for EE, so if it doesn't do it then there isn't an out of the box solution for EE.


2

The new method that replaces get_upload_preferences is called get_file_upload_preferences. All you need to do is change that method name in your code, the parameters should be the same.


Only top voted, non community-wiki answers of a minimum length are eligible