Hot answers tagged

5

If it doesn't need to be particularly secure, create a separate sub-domain, and set up a global variable to show different statuses depending on which sub-domain they're on. If you're using FocusLab Master Config this is simple, otherwise try something like this in your main public index.php file under where it says "CUSTOM CONFIG VALUES": switch($_SERVER["...


3

You are missing the opening { on the href's tag, and {title_permalink} has an underscore _ not a dash. <li><a href="{title_permalink="site/essay"}">{title}</a></li> See EE Docs on Permalinks


3

This is bug with ckeditor upon which WYGWAM is built. Pixel and Tonic have said fix is coming soon in new release of WYGWAM.


3

To get all your paths/urls changed is a bit of a PITA since they are located in so many different sections of the CP. The easiest way to do this is with an addon. The two most popular are: Deeploy Helper $22 (I prefer this one - use it on almost every build) or REElocate (free)


2

Yes you can do that, but have to drop the reliance on {title_permalink} or {path}. Your showroom/index template would catch both the listing and details pages, alternatively you can introduce additional elements to separate listing and details, for example: /showroom/{cat_url_title} would use the index template /showroom/details/{cat_url_title}/{url_title}...


2

This is an old topic with plenty of useful information that seems to mirror your question. Hopefully this is helpful to you: https://stackoverflow.com/questions/13213812/getting-the-trailing-slash-back-in-expressionengine-2


2

I think you're on the right track with switchee, and something like the following should work: {your_relationship_field} {exp:switchee variable="{your_relationship_field:channel}" parse="inward"} {case value="news"} <a href="{url_title_path='news/entry'}">{your_relationship_field:title}</a> {/case} {case ...


2

Of course! The path variable can be put aside and you can create the links by your own. Just code the href attribute as you need. Some samples: <a href="{path='channel/index'}">{category_name}</a> <a href="#{category_url_title}">{category_name}</a>


2

In your config.php, you can set the site URL like this, and it should work on both your localhost and live server without needing to be updated. $config['site_url'] = 'http://' . $_SERVER['HTTP_HOST']; Or, you can put the literal URL in there, and edit it once you move the file from server to server.


2

Set the value of $config['site_url']on the file system/expressionengine/config/config.php. But you gonna maybe have to set another variables, too: $config['cp_url'] $config['tmpl_file_basepath'] $config['avatar_path'] $config['avatar_url'] $config['captcha_path'] $config['captcha_url'] $config['theme_folder_path'] $config['theme_folder_url'] And don't ...


2

Wrap the email address tag with the No Formatting plugin tags. {exp:no_formatting} {email} {/exp:no_formatting}


2

This is set on per-channel basis, not per-field. Go to Admin -> Channel Administration -> Channels, click "Edit Preferences" next to your channel and set "Automatically turn URLs and email addresses into links?" to "No".


2

I'm not sure of this behavior being applied to other fields than comments, but maybe it worth to try. On Control Panel > Admin > Security and Privacy > Security and Sessions, look for Apply Rank Denial to User-submitted Links.


2

The url title is not specified in your script. I would recommend putting the url title in a data attribute in the html code. <a data-urltitle="{url_title}" class="fancybox project {categories}{category_name} {/categories}" href="{large_image}" title="{title}">...</a> then get that attribute in the js // Add buy now button var urltitle = this....


2

You can use the {cp_session_id} global variable to create a control panel link. See the documentation here. {if logged_in_group_id == "1"} <a href="{cp_url}?S={cp_session_id}">go to admin</a> {/if}


2

In ExpressionEngine, unlike in other CMS's, templates aren't assigned to channels. Templates are loaded based on template group/template name convention, and those templates display the content of whatever channel (or channels) you specify in the channel:entries tags that you use in those templates. (See docs on URL structure.) Generally then, you'd link to ...


2

Your issue is nothing to do with ExpressionEngine. The template you are uses javascript to smooth-scroll within the page. It appears to be configured properly for in-page scrolling, but not for links arriving from other pages. This is a consequence of how the scrolling utility you are using is written - it needs to check for whether it is being called ...


1

Blatants response was very helpful in figuring out how to proceed. I hired someone to get this working exactly as needed, and here is the code that I am using: var changed = 0; function myFunction() { var re = /type/; a = document.getElementsByTagName('a'); for (index = 0; index < a.length; ++index) { if (changed==1) { a[...


1

Assuming your dropdown is named and id's as city_select and has the vlaues set to the URI that you wisdh to add, like this : <select id="city_select" name="city_select"> <option value="Portland">Portland, Oregon</option> <option value="USA">USA, Earth</option> </select> The below is pure jquery : <script&...


1

So jchrono-battle is correct in that anchor tags (properly known as fragment identifiers) are never sent to the server, but that doesn't seem to be the issue. OP stated the issue is the anchor is never being rendered to the page, not that the server doesn't know what the anchor is. I would check to be sure that any templates, snippets, embeds, etc. are ...


1

You need to post a page that has been assigned to use Structure. Check Structure » Settings and use one of those channels.


1

CK Editor, which is the basis for WYGWAM and Wyvern, will do this when links are added with the link button. Also look at VZ URL: devot-ee.com/add-ons/vz-url-extension which will check links for validity when entered.


1

Channel relationship issue. Problem solved.


1

We just released Wygwam 3.3 which fixes compatibility issues with Internet Explorer 11.


1

It definitely sounds like your control panel URL configuration isn't correct. This needs to be set to match the URL you use to access the control panel, so it can generate the links correctly.


1

Another option is to use Focus Lab's Master Config. It connects into your config.php file and creates the concept of multiple server environments with their own individual configuration options. It also sets a lot of the path and URL config variables dynamically, making moving between servers painless.


1

Check the Channel Preferences for this Channel for the Automatically turn URLs and email addresses into links option. It sounds like you have it set to "Yes" and this is causing the malformed HTML. Control Panel Location: Admin > Channel Administration > Channels > Edit Preferences Documentation


1

I've been having a similar issue for several months with Title Master and haven't been able to get any assistance from the developer. I eventually had to abandon using a "url title" that was composed of multiple components and do something a little more old fashioned.


1

In general, don't try to force EE to use a trailing slash. Do the opposite - make the canonical links without a trailing slash. Seriously, that is the way EE likes it, and you are pushing shit uphill trying to do anything else. Don't use a 301 htaccess redirect - that's ridiculous, because EE generates all URLs without a trailing slash. Then you would be ...


1

I believe Channel Categories only returns the category names, not the entries themselves. If you need to return a channel entry, you'll need to use the Channel Entries tag as well (or instead). So you'll need something like {exp:channel:categories channel="portfolio" show_empty="yes" style="linear"} <a href="{embed='embeds/.getEntryForCategory' cat='{...


Only top voted, non community-wiki answers of a minimum length are eligible