3

openssl_verify is a PHP function, so you need to install it for PHP, normally it's installed as standard, so guess you're using an abnormal PHP installer...? Here's a reference to a bug report that was created. It may be as simple as you've not got the php.ini module line uncommented: extension=php_openssl.dll PHP OpenSSL Installation reference.


2

It is pretty straight forward to move an EE site. The instructions from EllisLabs are pretty comprehensive - EE server migration instructions.


2

Looking it up I found this solution that worked for me: sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /tmp/mysql.sock I thought I'd post this in case anyone else runs into this error.


2

First thing to check is the obvious - is the product out of stock? Have you definitely submitted an item_qty? If those don't work - the best way to diagnose issues like this is to check the Network tab in your browser's developer tools. Make sure the form fields are getting submitted as you expect, and if successful you should see only a single 302 redirect ...


2

Bchavez, Try to check the configuration files of ExpressionEngine, I guess there is a problem about the server path and or the url path settings. Did you install EE on the root of your server, or inside a folder? If it's inside a folder you have to configure the paths.


1

http://flowingmotion.jojordan.org/2013/07/19/12-steps-to-rebuild-your-wamp-server-without-losing-your-data/ This seems generally useful. Make sure you reinstall the same version of WAMP. Things like your config files and your entire web root are the most important to back up. Make sure you know all of your users and passwords. You can't just make a backup ...


1

Agree with Lloyd_07. In addition, if you have got the time, you could setup environments https://github.com/focuslabllc/ee-master-config/tree/EE3 But if you dont want that, just a if else in config.php for ex. if ($_SERVER['HTTP_HOST'] == "example.com") { $config['cp_url'] = 'https://example.com/admin.php'; $config['theme_folder_url'] = 'https://...


1

You could also update the config.php file where the image paths are set, see ee docs regarding this migration process. https://docs.expressionengine.com/latest/operations/moving.html


1

It's more a Wamp problem that an EE one, But open this file, inside your wamp install: wamp/bin/apache/conf/extra/httpd-vhosts.conf edit it and add (have to put path of your local site here: wamp/bin/apache/conf/extra/httpd-vhosts.conf : <Directory "D:/local_site_directory/www/site_name"> # maybe there is some comments here ... Options ...


1

Thanks for the replies it was not an EE error but a problem with the mod_rewrite on the Apache server


1

I like to add this System Config Override variable to my config.php file... $config['site_url'] = "http://localhost:8000/"; ...then change it depending on your environment. This way at least I have one less thing to update in the database between environments. I prefer that type of configuration to be in PHP anyway. Perhaps using more of the Config ...


Only top voted, non community-wiki answers of a minimum length are eligible