People who code: we want your input. Take the Survey

Hot answers tagged

5

From what I saw in a comment from Mark Croxton here: http://devot-ee.com/add-ons/support/stash/viewthread/8717 EE tries to cache tags that are used multiple times within the same template. To get around this, there's a "random" keyword that EE looks for that will cause it to use a separate marker for this tag (causing the tag to parse twice) The problem ...


4

The loading of the template needs to be done as follows: $this->EE->load->library('template',null,'TMPL'); Now it works.


3

Okay, first, turn off early parsing for the myassetsimage variable. Then try and use Asset's {url} variable (see docs) in CI Img's src-parameter instead of the Low Variables name. That means that your code would look like this: {exp:low_variables:pair var="myassetsimage"} {exp:ce_img:pair src="{url}" width="640" height="400" class="img-polaroid" alt=""} ...


3

Man, take a look at the function _parse_sub_template used on stash. Mark Croxton, the developer of stash, cloned the tagdata and parsed it. // clone the template object $TMPL2 = $this->EE->TMPL; unset($this->EE->TMPL); // parse variables $TMPL2->tagdata = $this->_parse_template_vars($TMPL2->tagdata); // parse simple conditionals $...


2

Ok so this was ridiculous easy to fix. What we did was move the XML from it's static file and inserted it into its own template within our active template group and it worked. So if you're having this problem just template the XML and go nuts. All we had to change in our JS here was var url = "OUR URL"; to var url = "{path='<our template group>/&...


2

Well.... You were right, Adam. Apparently the host switched on Magic Quotes. Not sure why, but they did. I disabled it in the php.ini file and the site is back to normal. NEVER thought of that. Thanks for your quick response!


2

The easiest solution would be to use Mo Variables which provides an early parsed {logged_in_member_id} which will allow you to use it as a dynamic value in your URL path. {exp:rest url="/api/get-default-profile-image/{logged_in_member_id}/" format="json" parse="inward"} {default_profile_image} {/exp:rest}


2

Looking at the content of your lv_article variable, you could just use the variable syntax instead of the tag syntax: {lv_article} Having early parsing enabled has no effect when using the tag syntax, only when using the above variable syntax.


2

If it's two plugin tags that you are needing to nest, see changing parse order for nested tags using the parse="inward" parameter.


2

Stash embeds can be parsed at three different stages in the parse order of their parent template: process="start" - embed the template before any other variables and tags in your template are parsed. The tags in the embed will be fully parsed before being included in the parent template, unless you set parse="no". If you do set parse="no", the embed behaves ...


2

You should be able to use an html entity to overcome this. Try changing your [I] (capital i?) to: [&#73;] in your EE entries and see if that works.


1

Stash is very useful sometimes, but also is notorious for exactly this kind of obscure fail behaviour. Just look at the kind of questions asked about stash in this forum and you will see that you are not alone in encountering baffling behaviour. There probably is a cute / concise solution to your problem: I'm not sure I have such for you, but do have two ...


1

Alright, I did a fix. I renamed my en, fr and es fields with a prefix label_. In my template I did this: {/stash:nocache} {exp:low_variables:parse var="var_eleads_countries"} <option value="{var_eleads_countries:code}"> {var_eleads_countries:label_{segment_1}}</option> {/exp:low_variables:parse} {stash:nocache} The nocache tag is ...


1

If it's not coming through, I'd bet it's malformed JSON, or more likely, your array structure is incorrect. https://ellislab.com/expressionengine/user-guide/development/usage/template.html#parsing-variables An easy way to test this is to dump your final array to the developer logger as json, and just compare the structure to how it should be as an array. ...


1

If I understand correctly, you only want to execute the exp:ajw_export tag if the logged in member ID is 1. For this, you don't need the low_variables:parse tag. Instead, in the Low Variables settings, make sure Early Parsed Member Data is set to Yes. Then use (simple, pre EE2.9) conditionals: {if logged_in_group_id == 1} {exp:ajw_export sql="SELECT * ...


1

I found out why the index file was being parsed. I using Stash to render my templates and I was missing the closing tag for exp:stash:set for this partial!


1

My pragmatic solution would be to just enable PHP on output.


1

Two additional "routing" addons: Template Routes http://devot-ee.com/add-ons/template-routes Router http://devot-ee.com/add-ons/router


1

It sounds like you are looking for a way to manage redirects using ExpressionEngine. You could do it with htaccess, yes, but it's really convenient to do it with EE. Take a look at Detour Pro. Since you have some redirects that are repetitive in nature, it's possible you could make use of Detour Pro's "Wildcard Redirect" or "Wildcard Redirect with Segment ...


1

This is a bug noted in EE2.5.3+ - https://support.ellislab.com/bugs/detail/18336 - I ran into this one myself. It's been fixed as of EE2.7.2 - http://ellislab.com/expressionengine/user-guide/about/changelog.html#version-2-7-2 (bug #19624)


Only top voted, non community-wiki answers of a minimum length are eligible