We changed our privacy policy. Read more.
2

The :all_options tag pair was actually removed removed two years ago, well before Field Pack 2.0 came out. We removed it because EE doesn’t parse tags for fields that don’t have any data; it just removes them. And 99% of the time, people used the :all_options tag pair in cases where they would expect the options to appear regardless of whether a checkbox ...


2

I had the same problem post upgrade from EE 2.8 to 2.10 and found that I needed to change the conditionals as follows to make them work again: {if '{my_checkboxes:selected option="value"}' == '1'}


1

{if '{my_matrix_column:selected option="text"}'}popup{/if} This should definitely work, according to the Field Pack docs. You could also just loop through and do your conditional inside the loop: {my_matrix_column} {if option == "text"}popup{/option} {my_matrix_column}


1

Kindly got an answer from the great guys over at Pixel and Tonic. You need to add this to your expressionengine config file. $config['safecracker_option_fields'][] = 'fieldpack_checkboxes'; $config['safecracker_option_fields'][] = 'fieldpack_radio_buttons'; $config['safecracker_option_fields'][] = 'fieldpack_dropdown'; $config['safecracker_option_fields'][] ...


1

I'd been having issues with PT Checkbox in a Safecracker form as well. For me, this worked: {options:field_name} {label:field_name} <input type="checkbox" id="field_name[]" name="field_name[]" value="{option_value}"{checked}>{option_value} {/options:field_name} Where field_name represents the actual field name. This is EE 2.6.1, Safecracker 2....


Only top voted, non community-wiki answers of a minimum length are eligible