People who code: we want your input. Take the Survey

Hot answers tagged

7

Thanks for listening to my talk and staying awake. It really is crucial to get a good base setup and thanks for reaching out to us for advice. Key mods we use suPHP, EAccelerator, Deflate, File Cache, MemCache, FastCGI (and some other non-cache related mods) and EE works very fast. Not sure on APC but I cannot imagine there being much difference. The key ...


7

If you are seeing a white screen there's an error happening and you need to display that error to be able to know how to proceed. (See the EE user guide about Blank Pages.) To show that error, edit your folder's index.php file and replace $debug = 0 with $debug = 1. Revisit your site and you should see the error. If you see something like this: A Database ...


5

In my experience suPHP tends to have a small negative impact on overall performance, and either FastCGI or mod_php (DSO) will run faster with less resource use, specifically CPU use. FastCGI uses noticeable more memory than DSO, but on the other hand is arguably 'more secure' than DSO for a multi-site environment. For securing DSO, mod_ruid2 might be an ...


3

I agree with @foamcow's answer. Also, change your SFTP and MySQL passwords and look at .htaccess in case they injected some redirects.


2

The Nginx page for ExpressionEngine has sample configs, that should work for EE 1.6.x. And, here are more examples in an Archived EE Forum Thread on Nginx. And, more good info is available in this Current EE Forum Thread on Nginx. I think that any info you find on the web about using Nginx with EE should be applicable to EE 1, even if the example uses EE 2. ...


2

.host file just overwrite DOMAIN -> IP determination which usually do DNS server before you computer send request to Web server. So you can't manipulate urls on server with it. Your web server (apache/nginx) must be ready to get request with domain "mytempdomainsite.com.au" (or have default setting for ip) and redirect to your web folder. This is only way....


2

You just need to create subfolder msm-site-two and put inside index.php with $assign_to_config['site_name'] = 'msm-site-two'; $assign_to_config['site_url'] = 'http://000.000.000.000/msm-site-two/'; and your second site will be available by url 000.000.000.000/msm-site-two/


2

CE Cache and ExpressionEngine's cache="yes" are not true caches. I hate that they advertise themselves as "caches" - they are not! They simply cache ExpressionEngine template parsing's output at a very high level, the entire PHP stack and ExpressionEngine core still needs to run. Not to mention database traffic, even for non-logged in members due to EE's ...


2

I checked http://qatarphil.net and got a blank page, but with http://qatarphil.net/index.php I get the "Your config file does not appear to be formatted correctly." message. Which is positive. It looks like your files are all in place and the domain issues are worked out. Also, check the official install instructions here: http://ellislab.com/...


2

The first thing to do is remove the code but you should also look to see there is anything else that has been touched. Reinstalling completely may be unnecessary but it won't do any harm. If you store any personal information of users you should also determine whether or not this has been taken and your client needs to decide whether or not to inform them ...


2

The answer to this question turns out to be a lot simpler than once though. Looks like the main issue was that I didn't have two hidden required fields included: <input type="hidden" name="from" value="" /> <input type="hidden" name="subject" value="Email Contact" /> For some reason this caused my form to malfunction.


1

Your best bet is still to open a support ticket with HostGator and asking them to 'whitelist' those mod_sec rules that are causing the problem. As EE5 isn't as common as say WordPress, most hosting providers therefore don't have the relevant rules whitelisted as they don't have clients that have run into the issue (yet). If you ask them nicely they might be ...


1

Reading the docs, it will utilise the control panel language format or logged in user format. Were you logged in on the Macbook? Similar question and alternative answer for multi-language: How do I format the date in a foreign language?


1

Apparently to resolve this you have to hack the /system/expressionengine/libraries/Core.php file. From @set_time_limit((REQ == 'CP') ? 300 : 90); to @set_time_limit((REQ == 'CP') ? 800 : 90); Not pretty nor advisable.


1

Roll this: http://php.net/manual/en/function.ini-set.php into your main index.php file, and set your max_execution_time via that method. It only sets it for that script execution, so you may have to put it in your system index.php file as well, depending on your use case. This really isn't an EE thing (unless someone manually set it like how I'm ...


1

New Relic is a fabulous tool for this.


1

1) Verify the template files system path is correct: Design > Templates > Global Preferences 2) Generally speaking, you can clear the current cache by navigating to "Tools > Data > Clear Caching". You can also try deleting all of the cache files in the /system/expressionengine/cache/ folder but I haven't tried that for this type of scenario.


1

Whenever I encounter this issue, I always find it's either because of permissions or the path. If your permissions are all fine, you might double-check the path with the host, just to make sure. Doing so has cleared up this problem for me in the past (even when it seemed the path was correct).


1

I'm running EE 2.8.1 on PHP 5.5.10 and I've not noticed any problems so far. You should be safe.


1

@cscott, were you saving your templates to the file system? I assume yes because you mention ftp. Check in your Exp Eng control panel under design > templates > global preferences. Is the file directory for templates that points to still valid? Are there any files there when you look using an ftp client? Next check the 'synchronize templates' and see if ...


1

You may have already resolved this, but in case you haven't or for anyone else running into this issue, I resolved it by adding the following to my nginx.conf file within the http {} tags located at /etc/nginx/nginx.conf on your server: proxy_buffer_size 128k; proxy_buffers 4 256k; proxy_busy_buffers_size 256k; Then restart your nginx service via SSH ...


1

The index.php and admin.php files in each site's document root references the shared system directory for all the sites. So, if the sites were on different servers you wouldn't be able to access the system folder path which lies on another server.


1

I had this problem recently after the host upgraded to PHP 5.3.27. The front of the site worked fine but when I tried to log in to the CP (after logging in) I got the white screen of death. Are you able to log in at all? My problem was that the new version of PHP had been compiled, quite correcty, with an oAuth plugin. This caused a problem with an old ...


1

Those PHP features were deprecated long ago, EE core is certainly not using them. You may however run into issues with add-ons, especially on older sites running EE 2.2. On your up to date versions though you should be fine. I know a large number of EE sites are using PHP 5.4 these days with no issues.


1

After much rolling back, redeploying, branching, merging, and banging my head, looks like it was something to do with the FocusLab portable configuration setup. I set this up locally on the site after I FTP'd it down from the host but before I made my first GIT commit, so a full rollback and deploy didn't undo this part of the system. Note, we use FocusLab ...


1

I generate XML files for orders for clients in a very similar format - I use {exp:query sql=""}...{/exp:query} for the lot. Eg, I don't touch any exp:channel / order:items / embeds etc. Can spit out ~1500 orders and relevant details in no time - We have a separate function that can run live currency conversion on the order totals in these XML files - whilst ...


1

Which hosting provider do you use? What version of IIS/Windows do they use? You can try to add a web.config file to your root <configuration> <system.web> <customErrors mode="Off" /> <compilation debug="true" /> </system.web> <system.webServer> <rewrite> <rules> <rule name="...


1

Can you force C:\path\to/webroot/folder instead? I have that in use on a Win server with EE. You might also change from Imgsizer to CE Image - when I did that I was able to remove the base_path type parameters from my plugin calls.


Only top voted, non community-wiki answers of a minimum length are eligible