12

Sounds like the field's settings have gotten mixed up at some point. I'd try switching the field to "XHTML" formatting, and select the option to "Update all existing channel entries with your new formatting choice?". Once that's done, then switch back to "None" formatting and update all existing again. Hopefully that will resolve for you.


4

We just released Wygwam 3.1.2 which brought back the text alignment buttons.


3

Not sure if you want to use a plugin or not but you could strip out anything you don't want using Hacksaw: http://devot-ee.com/add-ons/hacksaw Something like this might do it for you: {exp:eehive_hacksaw allow="<strong><br />"} <strong>{facilities:title}</strong><br /> {facilities:facility_street_address}<br /&...


3

Had this problem too. Looks like they removed it from the default set-up. First thing to check is under 'themes/third_party/wygwam/lib/ckeditor/plugins' you have the 'justify' plugin installed. If not just download it here (http://ckeditor.com/addon/justify?page=1) and place the whole folder in the plugins folder. Next you need to be in 'system/...


2

I always do this with a simple plugin which runs unformatted text through EE/CodeIgniter's format_characters() method (though rather than use the plugin tag in my template, I usually select it as the formatting method for that field or Matrix column). I've thrown it up on GitHub just now.


2

Do you have 'Automatically turn URLs and email addresses into links?' set to 'no' in the channel's preferences?


2

This is set on per-channel basis, not per-field. Go to Admin -> Channel Administration -> Channels, click "Edit Preferences" next to your channel and set "Automatically turn URLs and email addresses into links?" to "No".


2

You should be able to do this by changing the expected content of your field from a number/integer to "any" which is basically a string and so will not be treated as a number.


1

You can try to install MX Universal Editor, but I can't guarantee anything about this. http://wiseupstudio.com/expressionengine/mx-universal-editor.html


1

It sounds like you would do best to make use of a WYSIWYG Field Type addon. There are several. I think the ones that get the most use are Wygwam, Expresso, and Wyvern. https://devot-ee.com/add-ons/wygwam https://devot-ee.com/add-ons/expresso https://devot-ee.com/add-ons/wyvern They are all built on top of CKEditor. This field will allow content editors ...


1

Okay, it turns out it’s a bug that manifests when using the RTE in Safari. Switching to Chrome gets rid of the problem (though I'm not 100% sanguine about telling clients that they need to avoid a specific browser if they want to be able to use soft returns).


1

Sounds like you're hitting this bug perhaps... There is a patch at the bottom: https://support.ellislab.com/bugs/detail/19405


1

It looks like the issue was that EE was ignoring the "allow override on publishing page" formatting preference, so even though I set the text formatting to "none" in the entry, it was being ignored in favor of whatever the default format preference was for the field in question. Updating from 2.7.1 to 2.7.2 corrected the issue and caused the preference to ...


1

Make sure to check the particular Channels preferences admin > channel administration > channels > Edit the preferences for the channel in question and look for "Channel Posting Preferences" and in particular "Default HTML formatting in channel entries" - set this to: "Allow ALL HTML". I suspect it may be set to: "Convert HTML into characters entities"


Only top voted, non community-wiki answers of a minimum length are eligible