Hot answers tagged

11

The upgrade from EE2 to EE3 is a major step - from EE3 to EE4 not such a big one. So getting your site to EE3 is the thing to focus on. How hard this will be will very much depend upon how your EE2 site is set up, and in particular what add-ons you are using. To be able to upgrade to EE3 you need to get your copy of EE2 up to a late version (I think 2.10....


7

Totally agree with Steven's comment, I'll give my own answer though as we recently went through similar. We were migrating to a new server and took the opportunity to build php 5.5 on the server to skip a version and save us the hassle of any major version upgrades again anytime soon. Here was our strategy. Upgrade all sites to latest EE build Upgrade all ...


6

Alright, let's do this. I got you, fam. I've done several 2 > 5 upgrades, both small sites and some real big ones. First thing, so far no client has opted to go the rebuild route. Generally it would take longer than the upgrade process (so more money from them), and I would only recommend it to a site that was in such bad shape (templates are a mess, PHP ...


5

Have you checked all of your installed add-ons for updated versions? White screens are also typically a sign of hidden errors, so make sure that display_errors is enabled in your PHP environment, and set the $debug value in the admin.php file to 1. That may reveal a PHP error that identifies the problem. If that doesn't help, and you think you have the ...


4

If somebody will have the same error - check if you have Solspace FreeForm . I had the same issue because of this (FreeForm v.4.0.4). Fix - temporary remove freeform folder. You can return it back after update will finish.


4

Funnily enough I'm going through exactly the same process at the moment. I'm undertaking a conversion from LG Poll to VWM Polls. If you don't care about these errors, you can just set the field's type to 'text' in the exp_channel_fields table, which will at least get your site working again. Then if you don't want to upgrade or migrate LG Polls you can ...


4

For the sake of completeness you can fix this with a simple SQL query to add the required column. See see this official EE thread


4

EE Recommends that you're on 2.10.1, this way you're less likely to run into issues. You'll want to make sure you have EE3 compatible plugins. The EE3 upgrade process requires you to change a lot of your EE2 files/directories to adhere to the new EE3 standards. https://docs.expressionengine.com/latest/installation/upgrade_from_2.x.html Edited for clarity ...


3

Actually, I would strongly suggest to upgrade add-ons first, then EE. This isn't only for Solspace add-ons, but any add-on for EE. Make sure you update your add-ons to the latest version available for EE1 first, then upgrade to EE2. Sometimes, you need to then upgrade the add-ons to the latest version available for EE2. This usually gives you the smoothest ...


3

Add this right above line 194 in admin/expressionengine/libraries/Extensions.php: $this->EE->load->helper('string');


3

When updating freeform, you need to delete the old directories before uploading the new: Updating: Within your sites ./system/expressionengine/third_party/ directory, delete the freeform folder and upload the new one from the /system/expressionengine/third_party/ directory in your download package. Within your sites ./themes/third_party/ directory, delete ...


3

Solspace has the Solspace Importer Module with Solspace Gallery Importer designed to do just this.


3

For now, Freeform is not compatible with EE2.7 - check the blogpost here http://www.solspace.com/blog/entry/compatibility_with_ee_2.7.0/


3

I wouldn't go updating a production server without running any tests first. I'd mirror your production server first and then test the sites individually. That's the only way you'll guarantee to be headache free.


3

I added the required column hash in phpmyadmin and I was able to get rid of the error. then I did a manual upgrade because Devdemon updater failed at ver 2.6.1


3

To get all your paths/urls changed is a bit of a PITA since they are located in so many different sections of the CP. The easiest way to do this is with an addon. The two most popular are: Deeploy Helper $22 (I prefer this one - use it on almost every build) or REElocate (free)


3

From these errors it looks like the paths are pointing to folders that don't exist (because you're moving from a local setup to live). Have you ever used a multi-environment config like Focus Lab's Master Config? Since you can't log into the control panel and it looks like the issue has to do with paths, you could get the paths reconfigured using a multi-...


3

The first error indicates that some if-statement in your template is wrong. Maybe you have a " sign to much? If this error is on all pages maybe some embeded template has it - if not it can be in a specific template. See this: {if ""y"} The second PHP-error just tells you theres been some output to the browser before the standard output (the template) has ...


3

My apology - looks like with one of update I missed procedure for version <1.3.4. It is no more global settings in MX Google Map (most of them was replaced with ee config.php varibles). I will add this update function in next build. Right now you can just run next query update exp_fieldtypes SET has_global_settings = 'n' WHERE name = 'mx_google_map' ...


3

The big daddy of googlemaps add-ons for EE2 is http://devot-ee.com/add-ons/google-maps but afaik there's no seamless upgrade path. You could contact objective html and ask though.


3

I wouldn't say it's a pain. It certainly should be a planned event though. There was a great podcast about this a few months ago over on the Ctrl+Click podcast. Check it out here: http://ctrlclickcast.com/episodes/upgrading-ee I've upgraded 100's of Wordpress sites many times and probably about 50 EE sites. Despite Wordpress having the one click update, I ...


3

I located this line (found at 721) in /system/expressionengine/libraries/Session.php and removed login_state from the query - so from this: ee()->db->select('member_id, admin_sess, last_activity, fingerprint, sess_start, login_state'); to this: ee()->db->select('member_id, admin_sess, last_activity, fingerprint, sess_start'); // login_state ...


2

In your config.php, you can set the site URL like this, and it should work on both your localhost and live server without needing to be updated. $config['site_url'] = 'http://' . $_SERVER['HTTP_HOST']; Or, you can put the literal URL in there, and edit it once you move the file from server to server.


2

Set the value of $config['site_url']on the file system/expressionengine/config/config.php. But you gonna maybe have to set another variables, too: $config['cp_url'] $config['tmpl_file_basepath'] $config['avatar_path'] $config['avatar_url'] $config['captcha_path'] $config['captcha_url'] $config['theme_folder_path'] $config['theme_folder_url'] And don't ...


2

I have never seen this. I'm guessing there is something in your environment that EE doesn't like. I found a PyroCMS thread which mentions this error. That CMS is (was) build on CodeIgniter. It mentions in that thread that you need to have the iconv extension installed. This extension is enabled by default in recent versions of PHP, so that would likely make ...


2

Yeah, you've got a mess on your hands. Try this no add-on method. If it doesn't help you out, notacouch's suggestion to use IfElse should be helpful. {if entry_id == "20" && cf_product_options:total_rows > "0"} <hr class="soften"> <h2>Configuration Options</h2> <table class="table table-striped table-bordered ...


2

The EE1 docs are still available for download. Just look in the top right corner for a link to download the zipped docs. You can look for the section about the email module, which should do exactly as you need. In this case, it may be easiest to just work with what you have. Upgrading to 2.7 from 1.6.8 could be quite an undertaking. Sometimes it works out ...


2

Shortly after posting this - I think I found the problem. It appears the _updates_relationships_for_grid() function didn't fire in the ud_270.php upgrade process... no idea why though since the upgrade didn't fail or error at any point. Having manually executed the SQL necessary on this function, it looks like it's working now.


2

There's no need to update 1 before upgrading to 2, that's some Cargo Cult voodoo. That error is specific to the installer attempting to run third_party update routines (often). Temporally remove third_party and try the installer again.


2

The fact that you're unable to get through to their company for a sales question should be a red flag, imo. However, as far as I know, there are no renewal costs involved with CartThrob.


Only top voted, non community-wiki answers of a minimum length are eligible