Hot answers tagged

9

Go to Add-ons > Modules > Wygwam > Editor Configurations and select the configuration you want to edit. Look for the Restrict allowed HTML? setting and make sure it is set to No.


8

You can do this without editing the Wygwam source. First you need to create a custom config file for CKEditor. Create a JavaScript file called something like 'ckeditor_config.js' and then set Wygwam to use it. You can do this by adding an advanced setting to your Wygwam editor configuration. Add the 'customConfig' setting and enter the path to the JavaScript ...


7

In the Wygwam editor config, in advanced settings, add the 'autoGrow_maxHeight' setting and make it equal to the 'height' setting.


7

For any variable that needs extra processing, like the Wygwam variable type, use the tag syntax rather than the variable syntax: {exp:low_variables:single var="my_wygwam_var"} Note that having early parsing on or off is irrelevant for the tag syntax, so you can leave it off.


5

I was able to fix this by adding back in the indent block plugin from CKEditor. The process of doing so is as follows... Download the CKEditor Indent Block Plugin. Make sure to download the version that matches the version of CKEditor being used by WYGWAM. Check the WYGWAM changelog if you're not sure. Unzip and install that folder to themes/third_party/...


4

Instead of modifying CK Editor files which would likely get nuked if you update the add on you are best to make a customConfig in the Editor Configurations. Change this and save this out to where you keep your front-end templates. var typkitID = 'XXXXXX'; CKEDITOR.on( 'instanceReady', function(ev) { var $script = document.createElement('script'...


4

I found the answer. Devotee has a list here.


3

This is bug with ckeditor upon which WYGWAM is built. Pixel and Tonic have said fix is coming soon in new release of WYGWAM.


3

For developers: Not easy, the display_field() method from wygwam gets its settings early on. However you maybe able to pluck apart the toolbars in the hook "wygwam_config". See https://github.com/pixelandtonic/wygwam_super_admin_source for an extension that adds a "source" button for super-admins. You could use that as a basis to remove / set other config ...


3

This is a pretty easy to resolve. Simply open up: /expressionengine/third_party/wygwam/mcp.wygwam.php and change line 139 from: $all_sources = ee()->assets_lib->get_all_sources(); to $all_sources = $this->EE->assets_lib->get_all_sources(); Looks like this is the only reference to the ee() global in the codebase. Because this code block ...


3

I believe to do so, you would need to create a Custom Style Set for Wygwam. See the Wygwam Docs over a Pixel & Tonic. Though, I recommend creating a class instead of an id. Since someone will most likely add more than one media embed sometime in the future. Additionally, this StackExchange post deals with editing the Wygwam .js for custom sets.


3

Following on from Aelvan's answer here is the code I use to automatically resize images in Wygwam fields and remove the dimensions. It also stops them adding stupidly large images. It requires CE Image, but why wouldn't you have that installed anyway? {exp:ce_img:bulk max="300" crop="no" allow_scale_larger="no" add_dims="no" attributes='style="float: right; ...


3

Looking carefully at your error message, you may have some incorrect capitalization of the EE_Fieldtype class file name. EE_Fieldtype.php is the correct way (uppercase F, lowercase t). Likely your localhost is case insensitive but your server is not.


3

The font size button added inline CSS, which is bad practice for modern web development. The better method is to add a custom style set with semantic, re-usable classes like .important or .featured that the user can apply to their content. If you have existing content that used the font size button, you can preserve those styles by setting the "Restrict ...


3

It's a BBCode problem: http://ellislab.com/expressionengine/user-guide/general/bbcode.html Pretty sure the issue here is the first [i] only, all subsequent [ii], [iii] should not be replaced as bbcode by EE. A dirty but effective method would be to change the very first instance of [i] to [i] which is the html entity for the letter i. I tried a ...


3

"Transfer Needs for Europe's Biggest Sides in Summer" isn't an entry_id and should not be in the where in clause. Wygwam is pulling those entry ids from EE's page ids. Check the page module and any config overrides.


3

Did you just upload the folders and have them over write the existing ones? If so, this doesn't always work well, especially with a large addon like WYGWAM. Try, deleting the folders on the server and uploading them fresh.


2

I had this same problem and after some head scratching, found that for some reason the other member groups didn't have file upload priviledges. So, check: Content -> Files -> File Upload Preferences -> Edit (select at least one location) And check that at least one upload location allows the Member Groups to upload files.


2

Until we get a better autosave fix from ellislab I went ahead and make a really simple extension that integrates the autosave plugin for CKeditor into wygwam. The extension uses the ckeditor autosave plugin, which saves the content of the wygwam fields into local storage as you type, and prompts you to import any missing content on pageload. Hopefully this ...


2

I figured it out. The Browse Server button only appears when the upload directory belongs to the current site. In the Wygwam settings you can create different configurations. By default there are the Basic and Full configuration. You can use the clone function to duplicate the configuration you're using now. For me this is Basic. After you clone it you can ...


2

It turns out that you must have at least one upload location (for that site, if MSM is enabled) present in order to set the upload location in Wygwam. For instance, I just performed a migration of Wygwam (2.7.1) data from using the native EE uploads to using Assets (2.2.2). Initially, I moved all of the images from the native upload location to an assets ...


2

This is not currently possible with any of the wysiswyg editors for EE. Have you considered making a feature request?


2

EDIT: Please see the accepted answer above from Dylan as an approach for handling this type of functionality. nonprofit_tech's suggestion to try using a custom style set does work, but it involves a two-step process: the content administrator must first add the custom wrapper from the style set dropdown, and then embed the media via the toolbar's media ...


2

I just tested an IE8 page load using IE Tester with WYGWAM 3.2.1 installed and there wasn't an error. WYGWAM is at version 3.2.2 as of Nov 13, 2013 so I'd suggest an upgrade as the first step.


2

Wygwam Super Admin Source does exactly what you need.


2

is not needs in path here <script src="http://whitewashed.richiesiegel.com/slider.js" type="text/javascript"></script> p.s. EE is not parsed tags in entries w/o special add-ons


2

I have found (and apparently you have too!) that using one css file that 'imports' multiple is the way to go. I point WYGWAM to my wygwam-style.css file which includes: @import url("/css/reset.css"); @import url("/css/dynamic-content.css"); Reset.css is just a basic css reset that I use on the front-end of my site, so I figured it'd be best if it was ...


2

You just need to vary your syntax slightly: {if '{my_wygwam_field images_only="yes"}'} {my_wygwam_field images_only="yes"} (image code) {/wygwam_field} {/if} This way you're actually telling EE to parse that first tag (inside the conditional statement) - you need to do it this way because it's a tag pair requiring a parameter,so simple ...


2

We just released Wygwam 3.3 which fixes compatibility issues with Internet Explorer 11.


2

The problem lies in updating expression engine to the latest version. 2.7.3 here’s the code i changed in /system/codeigniter/system/core/Security.php Current function in 2.7.3 /* public function entity_decode($str, $charset = NULL) { if (strpos($str, '&') === FALSE) { return $str; } if (empty($charset)) { $...


Only top voted, non community-wiki answers of a minimum length are eligible