Hot answers tagged

9

Go to Add-ons > Modules > Wygwam > Editor Configurations and select the configuration you want to edit. Look for the Restrict allowed HTML? setting and make sure it is set to No.


8

You can do this without editing the Wygwam source. First you need to create a custom config file for CKEditor. Create a JavaScript file called something like 'ckeditor_config.js' and then set Wygwam to use it. You can do this by adding an advanced setting to your Wygwam editor configuration. Add the 'customConfig' setting and enter the path to the JavaScript ...


7

In the Wygwam editor config, in advanced settings, add the 'autoGrow_maxHeight' setting and make it equal to the 'height' setting.


7

For any variable that needs extra processing, like the Wygwam variable type, use the tag syntax rather than the variable syntax: {exp:low_variables:single var="my_wygwam_var"} Note that having early parsing on or off is irrelevant for the tag syntax, so you can leave it off.


6

These tags are stripped out of the editor view because the "Restrict Allowed HTML" setting is set to YES for that field's WYGWAM configuration. Changing this setting to NO fixes the issue. Go to Add-Ons -> Modules -> Wygwam ->(your toolbar config) and set the "Restrict Allowed HTML" setting to 'no'.


5

Having recently upgraded an EE v1.6.8 site to v2.6.1, I had to re-save each of the Wygwam fields to fix the "defer" PHP notice. http://website.com/manage.php?D=cp&C=admin_content&M=field_group_management


5

I now have definitive answers. Basically neither works with autosave. EllisLab have noted that their Grid fieldtype doesn't work either. EllisLab https://support.ellislab.com/bugs/detail/19838 P&T Have responded with: Unfortunately, Wygwam currently doesn't have support for EE's auto-save functionality, but I've added to our list to look into for ...


5

I was able to fix this by adding back in the indent block plugin from CKEditor. The process of doing so is as follows... Download the CKEditor Indent Block Plugin. Make sure to download the version that matches the version of CKEditor being used by WYGWAM. Check the WYGWAM changelog if you're not sure. Unzip and install that folder to themes/third_party/...


4

We just released Wygwam 3.1.2 which brought back the text alignment buttons.


4

Instead of modifying CK Editor files which would likely get nuked if you update the add on you are best to make a customConfig in the Editor Configurations. Change this and save this out to where you keep your front-end templates. var typkitID = 'XXXXXX'; CKEDITOR.on( 'instanceReady', function(ev) { var $script = document.createElement('script'...


4

To make sure extra processing is done before the var is put in the template, use the tag syntax rather than the variable syntax: {exp:low_variables:single var="my_wygwam_var"}


4

You can disable CKEditor’s content filtering functionality by going to Add-Ons > Modules > Wygwam > [your config name], and changing the “Restrict allowed HTML?” setting to “No”. That’s a new setting as of Wygwam 3.1, so you may have to update Wygwam first.


4

CKEditor (which is the editor used by Wygwam) has a feature called Templates that you can use for this. With CKEditor content writers can select a template from a list by clicking the Templates button in the toolbar. A template is a predefined piece of HTML that is inserted into a document. Using this feature, the user does not need to start ...


4

I figured it out. I needed to set Restrict allowed HTML? to 'No' in the Wygwam configuration settings. This is located on the WYGWAM Module settings page. Works as expected now.


4

I found the answer. Devotee has a list here.


3

Everything was due to me having DevDemons Channel Images installed. Without their WW-plugin they seems to kill each other :/ Many Thanks Brad at P&T for sorting this out for me! /patrick


3

Had this problem too. Looks like they removed it from the default set-up. First thing to check is under 'themes/third_party/wygwam/lib/ckeditor/plugins' you have the 'justify' plugin installed. If not just download it here (http://ckeditor.com/addon/justify?page=1) and place the whole folder in the plugins folder. Next you need to be in 'system/...


3

Following on from Aelvan's answer here is the code I use to automatically resize images in Wygwam fields and remove the dimensions. It also stops them adding stupidly large images. It requires CE Image, but why wouldn't you have that installed anyway? {exp:ce_img:bulk max="300" crop="no" allow_scale_larger="no" add_dims="no" attributes='style="float: right; ...


3

You might want to remove the closing </p> as well: {exp:low_replace find="<p>|</p>" multiple="yes"} ... {/exp:low_replace}


3

65k characters is just the limit of a MySQL TEXT column. You will need to edit the appropriate exp_channel_data database column (using PhpMyAdmin or similar) and change the column type to LONGTEXT.


3

Can I tell WYGWAM not to wrap text that starts and ends with {} in a paragraph tag? If not, other suggestions?? For WYGWAM, I don't think you can do that specifically, but you might be able to modify how it responds to paragraph tags by adjusting the Advanced Settings for your configuration. If that doesn't work, you could try Streeng to kill the empty &...


3

Make sure that the particular Wygwam editor configuration assigned to this custom field has a chosen upload directory. To double check this go to... Modules > Wygwam > Editor Configurations ...and in the editor configuration settings you will see a select menu labelled "Upload Directory" where you assign this.


3

I've done it before. Take a look at the display_field method of ft.wygwam.php. You'll see that it's fairly simple to instantiate a WYGWAM field. A few calls to the Wygwam_Helper class to load the JS/CSS. There are also some helpers for properly formatting the data. You'll need a textarea with an id, and also the ID number of a WYGWAM config. I don't want to ...


3

This is a pretty easy to resolve. Simply open up: /expressionengine/third_party/wygwam/mcp.wygwam.php and change line 139 from: $all_sources = ee()->assets_lib->get_all_sources(); to $all_sources = $this->EE->assets_lib->get_all_sources(); Looks like this is the only reference to the ee() global in the codebase. Because this code block ...


3

I believe to do so, you would need to create a Custom Style Set for Wygwam. See the Wygwam Docs over a Pixel & Tonic. Though, I recommend creating a class instead of an id. Since someone will most likely add more than one media embed sometime in the future. Additionally, this StackExchange post deals with editing the Wygwam .js for custom sets.


3

For developers: Not easy, the display_field() method from wygwam gets its settings early on. However you maybe able to pluck apart the toolbars in the hook "wygwam_config". See https://github.com/pixelandtonic/wygwam_super_admin_source for an extension that adds a "source" button for super-admins. You could use that as a basis to remove / set other config ...


3

This is bug with ckeditor upon which WYGWAM is built. Pixel and Tonic have said fix is coming soon in new release of WYGWAM.


3

Looking carefully at your error message, you may have some incorrect capitalization of the EE_Fieldtype class file name. EE_Fieldtype.php is the correct way (uppercase F, lowercase t). Likely your localhost is case insensitive but your server is not.


3

The font size button added inline CSS, which is bad practice for modern web development. The better method is to add a custom style set with semantic, re-usable classes like .important or .featured that the user can apply to their content. If you have existing content that used the font size button, you can preserve those styles by setting the "Restrict ...


3

It's a BBCode problem: http://ellislab.com/expressionengine/user-guide/general/bbcode.html Pretty sure the issue here is the first [i] only, all subsequent [ii], [iii] should not be replaced as bbcode by EE. A dirty but effective method would be to change the very first instance of [i] to [&#105;] which is the html entity for the letter i. I tried a ...


Only top voted, non community-wiki answers of a minimum length are eligible