I'm having an issue trying to display cart_total on a CartThrob cart overview template.

I have several items in the cart.

Both of the following display $0.00 for a total:



Yet cart subtotal works just fine:


Other tags for displaying shipping totals, taxes, etc are also working.

Scratching my head a bit, or maybe I'm just missing something obvious.

Thank you in advance for any suggestions or solutions.

  • Did you ever figure this out? having the same issue
    – Thomas K
    Commented Jul 12, 2014 at 17:52
  • I actually went around and around with this issue for awhile. I'll post an answer here for what I figured out to see if it applies to what you are seeing, and what I did to solve it.
    – oliverb
    Commented Jul 13, 2014 at 0:32

2 Answers 2


This was a bizarre issue that I eventually figured was due to a recent EE / CartThrob upgrade issue. It was several weeks ago, so I don't have the exact details but this is the basics of it.

When I opened phpMyAdmin, and had a look at the cartthrob_settings table, I saw that the product_channels entry was referencing the wrong channel ids. It was referencing other channels that held regular site content.

I then went to the CartThrob Modules settings > Products tab and deleted the two product channels in there and pushed submit. But that didn't actually update the product_channels entry in the cartthrob_settings table. I would go to the product channels tab and try and add the product channels, but the updated settings weren't being properly set. Tried different combinations of this for about 20 minutes.

At this point, I figured I had a botched recent upgrade. I could have tried just editing directly in phpMyAdmin but I figured that there were probably other things that were out of place.

So I took the store down and uninstalled cartthrob, and went into phpMyAdmin and dropped all the cartthrob tables.

I took screenshots of all the settings I had, reinstalled, applied the settings and everything has been running smoothly ever since. A couple of hours of work, I hope this helps anyone else to figure things out and maybe find a faster route for repairing the issue.

  • P.S. running EE v2.7.3 and CT v2.5
    – oliverb
    Commented Jul 13, 2014 at 1:05

I had the same problem and discovered the issue was that I had my unit price field in the products channel set to "text_input" rather than "carthrob_price_simple". Once I changed this, and had to re-enter all the unit prices for all the products, it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.