0

I have created tags group "Attributes", which contain tags for product colors, material which was made etc.

I have set that tag field as searchable, but I have hit a wall on searching site using tags from the "Attribute"

Example: searching for "red Pinto Paris armchair" where 'red' is an attribute tag, 'Pinto Paris' is the product name (EE title entry field) and an 'armchair' comes from the product description (EE entry field). I'm able to search for "Pinto Paris armchair" but is not show up only those armchairs tagged as a red.

Search snippet looks like:

{exp:search:simple_form channel="products" search_in="everywhere" result_page="search" no_result_page="search/noresults" status="retail|open" where="all" results="12"}
          <label for="keywords">Search</label>
          <input type="text" name="keywords" id="keywords" placeholder="Search" />
          <button type="submit" name="submit"><i class="icon-chevron-right"></i></button>
{/exp:search:simple_form}

Any clue what can be wrong?

Thanks

  • How are you building your search form? Are you using Super Search? Can you show some template code? – Solspace Jun 27 '14 at 2:44
  • I'm using simple search form tag from EE. Snippet code added to OP – JackTheKnife Jul 3 '14 at 17:38
1

Tag data should be saved to exp_channel_data, and therefore be searchable. Super Search can search Tags like this. Although I'm not sure for EE's simple_search form, I assume it would also work fine.

Is the Tag field set as searchable? If not, please set it as searchable in the custom field settings in the EE CP. You may need to re-save the entry so that the data ends up in exp_channel_data.

| improve this answer | |
  • Re-save solved my problem. Thanks – JackTheKnife Jul 7 '14 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.