2

I am trying to get the {extra:...} tags to work (per the docs) in EE4 but am having no luck.

In my config.php file, I have the following:

$config['seolite_tab_title'] = 'SEO';
// Pull additional info for SEO Lite
// channel_id => array(field_id => tag_name)
$config['seolite_extra'] = array(
  // home channel:
  '5' => array(
    'robots' => array(
      'field_id' => 62,
      'field_type' => 'text'
    )
  ),
);

The SEO Lite template (in the CP) is as follows:

<title>{title}</title>
<meta name='description' content='{meta_description}'>
<link rel='canonical' href='{canonical_url}'>
<meta name="robots" content="{extra:robots}">

The output is fine for the first three lines, but the robots tag outputs like so:

<meta name="robots" content="">

On the Devot:ee site, someone noted that the extra tags don't work in EE4. Is this correct? If so, does anyone have a workaround/fix (besides just using the field natively with EE code/syntax)?

0

In case anyone else is looking for the answer to this - it has been fixed in v1.5.5 which can be downloaded here: https://github.com/bjornbjorn/SEO-Lite/releases

Changelog: http://wedoaddons.com/seo-lite/changelog

| improve this answer | |
  • Any chance to make this work also on EE5? I'm experiencing the same problem with a 5.x installation. @Bjørn – Milksamsa Apr 15 at 7:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.