0

If a not cached page is accessed for the first time, give an error message (EE cache is disabled from the control panel).

When this same page is accessed one more time, the page is well displayed, no error message.

How this problem could be solved ?

Using this CE Cache syntax for the main template:

    {exp:ce_cache:it id="ce_principal" global="no" seconds="604800"}
        {exp:stash:get name='main_content'}
    {/exp:ce_cache:it}

(EE cache is disabled from the control panel)

Inside the CE Cache control panel page, if i want to see a cached page appears this error message:

Fatal error: Uncaught Error: Call to a member function hasModule() on null in /home/mysite/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php:1179 Stack trace: #0 /home/mysite/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(943): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModule('ce_cache&S=1c17...')

1 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings('ce_cache&S=1c17...',

'view_item', 'file&item=ce_ca...', '663b4b', 'global', 'js_main') #2 /home/mysite/system/ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array) #3 /home/mysite/system/ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\mysite\Core\Core->runController(Array) #4 /home/mysite/system/ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))

5 /home/mysite/www/admin.php(147): require_once('/home/cistosara.. in

/home/mysite/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php on line 1179 enter image description here enter image description here

1

It looks from the last error you reported that the CP issue is being caused by a configuration error - EE is trying to delete an entry from a table that doesn't exist (the table exp_ce_cache_tagged_items).

The table is installed by CE-Cache during initial install and / or updates if it does not exist. The table is defined both in CE-Cache 1.10.1 (EE2) and CE-Cache 2.0.2 (EE3), so whether your install is a new build or an update from an earlier version, this table should be present.

If it is absent (you could check by having a look at the MySQL database for the site using a MySQL utility such as SequelPro or phpMyAdmin) you probably need to add it back... either doing so manually in the MySQL or uninstalling / reinstalling the add-on from a clean copy of the add-on code (the install code will recreate the table if it is not present when the install routine runs). Reinstalling is probably the better option here, as the absent table may not be the only issue with the install.

If fixing the missing table doesn't do the job, post back with info on whether the errors change after the table is back in the MySQL, and also things like which version of the add-on and EE you are using and so on.

HTH

2
  • 1
    Hi thanks a lot for your reply ! The way to the solution was before my eyes, but I did not see it !! So lazy that I did not even make the connection between the error message related to a table associated to CE Cache..... With Navicat MySql I just did a simple copy and paste, problem solved in 1 min. I thought it was the end of the world, and i didn't even dare to think. I guess during the migration from the localhost to the physical server, some tables have leaked !! Thanks again for your help. – Stéphane May 30 '19 at 1:41
  • All the problems I've related seems to be solved. I cleared the whole Ce Cache, navigated through the website. All is fine ! It is not anymore the end of the world ! – Stéphane May 30 '19 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.