2

Using EE 2.7.0 and Importer 2.2.3 and trying to set up a members import. The csv has been saved out of open office as a utf-8 " enclosed and comma-delimited.

I have 3 lines to test this with, using the first lines as headings.

On import, it recognizes my file, then does the import 'successfully'. However, nothing gets entered into the members group I have designated. I have checked to make sure the group is unlocked, and that my file is formatted correctly. It tells me it runs correctly, but nothing happens to the fields.

2013-10-14 18:50 Start Time: Run Time: 0.024 seconds Import Location: Control Panel Number of Queries: 10 Member Inserted: 0 Members Updated: 0 Total Members Processed: 0 Member IDs: End Time: 6134-10-15 18:50 * Press the ESC key to close window.

Incidentally, I ran this on the full sheet of 700+, and it noticed I had batche processing and said it did the amount on my sheet, but again, nothing went in.

Any ideas?

  • Can you give an example of the data stored in the CSV, and what columns you are mapping with member data in EE? Are members imported at all? Is the issue only with member group assignment? If the member group assignment is incorrect, in what other group are the users winding up? – Solspace Oct 15 '13 at 18:13
  • No members are imported at all, even thought it says it ran correctly. I can't post any information here, as it is sensitive info, but I saved it from open office with delimiters and quotes in utf8 format. There is no error, only it does nothing. – Aaron Oct 15 '13 at 20:42
  • How about example data that also happens to have the same issue? This is eventually what we're going to have to look at and test on our side to try and reproduce the issue. Since I don't think attachments are allowed here (unless you post a link to the problematic exmaple file?), you could drop us a line with the file. solspace.com/support We might need a direct look as well, so feel free to provide credentials in your support ticket :) – Solspace Oct 16 '13 at 18:05
  • Yep I will send on a support ticket, thanks guys. – Aaron Oct 17 '13 at 8:07
0

It turns out from looking it over with Solspace that if you tick that the first row is your field names, and leave one blank, the import wont work. You have to keep this field with some text in it.

0

I ran into this same issue. For me it was a new custom member field that was set to be Required. In other words this field wasn't being used on the old site so wasn't part of the import data. Since it was required Importer silently rejected every record.

Definitely operator error but something to check if you get tripped up like I did!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.