0

So using - Transcribe 1.5 and EE 2.6

Basically when i have channel information outputting to json within ee, when another page is requesting this via ajax, transcribe redirects to the translated json route rather than the template route.

$this->EE->session->tracker is updated with this new route because of the ajax request

which then means when i change the language using language switcher it uses the ajax url rather than the requesting page. (doesn't use referrer).

1
  • Please edit your question to be more clear about what you're asking, what you've already tried, errors, all relevant code.... – Anna_MediaGirl Aug 26 '14 at 20:00
0

You nailed down exactly why this one is happening. Transcribe by default looks at the native tracker array in the ExpressionEngine core when determining the page to switch to when changing languages. I would recommend taking a peek at the {exp:transcribe:no_match} tag http://eeharbor.com/transcribe/documentation#tag-reference

1
  • Amazing! Ended up just routing this through a php file with a file_get_contents but this is much better. – Andrew Sep 4 '14 at 19:56
0

Found the solution, although this then outputs both language entries:

Use transcribe="disable" in the channel entries tag!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.