0

I am trying to get an existing EE site working with MSM. I upgraded the site earlier from 2.1.2 to 2.9.3. Once that was working, I then installed MSM 2.1.7. When I enable MSM in the CP I get several PHP errors:

Message: apc_delete_file() [function.apc-delete-file]: Could not stat file /nfs/c10/h04/mnt/123456/domains/domain.com/html/system/expressionengine/config/config.php, unable to delete from cache. Filename: core/EE_Config.php Line Number: 1222

Message: Cannot modify header information - headers already sent by (output started at /nfs/c10/h04/mnt/123456/domains/domain.com/html/system/codeigniter/system/core/Exceptions.php:170) Filename: core/EE_Input.php Line Number: 213

Message: Cannot modify header information - headers already sent by (output started at /nfs/c10/h04/mnt/123456/domains/domain.com/html/system/codeigniter/system/core/Exceptions.php:170) Filename: libraries/Functions.php Line Number: 446

Once this happens, trying to access any page on the site gives "Site Error: Unable to Load Site Preferences; No Preferences Found" messages. Disabling MSM in the config.php gets the site working again, but how do I complete this so that MSM is working?

0

The first message would kind of cause the following 2. The first error also implicates APC (Advanced PHP Cache).

I would disable APC for the time being to see if you can bring the MSM site back up. If this works then I would guess there's some sort of EE Config / Cache conflict.

I couldn't hazard an exact resolution as I haven't worked with MSM for quite an while, and while I have used APC and MSM, never together (a quick search for MSM & APC doesn't yield much). But I hope this at least helps you test and narrow down the issue!

Also, MSM is an EllisLabs product, perhaps they'll give you a bit of support on this?

2
  • I do not know if I can disable APC because this is on a shared hosting server, but I will investigate that. Thanks! Apr 21 '15 at 15:21
  • For testing, I do beleive you can turn APC on or off via htaccess by setting a definition somewhere, worth a punt :) Keep the question history fresh and let us know how you get on!
    – Blatant
    Apr 21 '15 at 15:54
0

It turns out that there was a bug in EE. It took several weeks to get it resolved, but this fixed it:

https://support.ellislab.com/bugs/detail/20959/php-error-after-upgrade-from-2.9.2-2.10.1-in-admin-section

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.