0

I just updated an EE v2.x single site to EE v5.24. The update went fine and the primary site is working as it should. I then enabled MSM and setup a second site.

Note: Both sites are setup under subdomains.

The second site's index page is blank no matter what I do. I have verified the correct info in the 2nd site's admin.php & index.php. Also, when I try to access the CP using the 2nd site's URL, I get the following error:

Parse error: syntax error, unexpected '[' in /nfs/c11/h03/mnt/196778/domains/sanborns.thedesigncore.com/html/engine/ee/EllisLab/ExpressionEngine/Boot/boot.php on line 70

I also noticed that when I try to change the Default Base URL for the 2nd site in the URL & Path Settings to the 2nd site's subdomain, it keeps switching it back to the 1st site's subdomain.

Any help is appreciated.

0

When a system setting doesn't update (or rather reverts when you try to update it) that suggests the variable is being set somewhere else.

Most likely way to do this is via system configuration override settings.

Have a look in your site's config.php file (system/user/config/config.php) - if you have migrated from EE2.x then it is possible that the original system was using some manual over-rides for system variables. AFAIK the upgrade process leaves any non-standard config entries in the config.php file - so these may have been carried over with the update. It might be that one or more of these legacy overrides is causing confusion to EE.

HTH

| improve this answer | |
  • Thanks for the tip. I checked the main (Site 1) site's config file, index.php & admin.php and there is nothing setting the default base URL. I'm wondering if the error I mentioned is a sign that there was something that went wrong during the update. – mediapimp Jun 26 '19 at 22:37
  • I also double checked index.php & admin.php of Site 2 and all of the paths & URLs are correct. – mediapimp Jun 26 '19 at 22:38
  • Actually, I was incorrect. There was a value set for the base url in the config file. I removed it and now I am able to change the value to the correct URL in the CP. But Site 2 is still generating a blank page when I visit its URL. I have a default template group setup and a bare bones index page, but it does not get displayed at all. – mediapimp Jun 26 '19 at 22:51
  • Also just noticed that on every page in the CP, the green successful Preferences Updated notice is showing by default. I feel like the update must have gone wrong in places and may be causing my issues. – mediapimp Jun 26 '19 at 23:22
0

Figured it out. On my server when a new domain is setup, it defaults to an older version of PHP. So the first domain was running PHP7, but the second was running PHP5.

Switching the second domain to PHP7 fixed everything.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.