0

I'm trying to debug why SuperSearch isn't posting the query string into the URL segment.

I have a document library search area (domain.com/library) that has with a number filters: article type, language, author, date range etc. If I select any one or combination of these and hit submit the returned page is the same as the originating one. SuperSearch doesn't post the selection into the URL, eg domain.com/library/search&authors=conan-doyle. It simply returns domain.com/library/

If on the other hand I manually type or follow pre-compiled links such as domain.com/library/search&authors=conan-doyle then the correct entries are filtered.

It was working previously. Then during a server migration I hit on some git versioning issues that resulted in me having to rollback a number commits. Even though none of the lost commits had anything, seemingly to do, with the SuperSearch forms.

Only SuperSearch's form submit isn't working. Other forms on the site (FreeForm, Newsletter sign ups) all work.

I've scoured EE's debug=on log a number of times and dug around in Chrome's developer tool. But nothing is calling out at me "here's the problem".

Does anyone have any suggestions as to how I may go about debugging the issue?

0

It sounds like your super_search:results tag has the redirect_post parameter set to no.

By default, Super Search will redirect a POST search to contain the search query in the URI on the results page, similar to how it does on Google searches, etc. This allows your users to bookmark search queries, etc. To override this behaviour, specify this parameter with a value of no.

(Docs.)

| improve this answer | |
  • Thanks Derek. But sadly that's not the case. – Seb Aug 12 '15 at 19:54
0

I'm an idiot.

I had commented out the following htaccess rule:

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php/$1 [L]

And that simply broke Super Search. Once reinstated it and added the extra ? in RewriteRule ^(.*)$ /index.php?/$1 [L], because the new server runs php as FastCGI, then everything worked as expected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.