0

after upgrading from EE 5.4.2 to EE 6.0.6 my tag cache (system/user/cache/templategroup-name/tag_cache) is growing very quickly. (Info: At the same time I upgraded the server from PHP 7.3.x to PHP 8.0.x)

I deleted the cache 1 hour ago, now it's about 40.000 files with a total of ~250MB. There might have been about max. 1000 unique users in here. The site has ~1.500 posts and ~50 static pages. [Edit: 20 hours later the folder is 1,8GB in size …]

With EE5 the whole system-folder was always under 30MB.

In my templates I use the tag-cache mostly with refresh=30

This does not seem normal to me. Is there any advice?

Thanks in advance!!!

2
  • You should enable the debug mode and found the errors on which section? It is related the EE then you should create the bug ticket on the EE github or that errors are related any addon than you have to contact of the add-on. You should post some of the errors here so we can help you according to it.
    – ZealousWeb
    Jul 5 '21 at 4:18
  • There are no errors to be found in the debugging-output.
    – BNetz
    Jul 6 '21 at 20:05
1

I would start off with enabling Output Profiler and inspect the template log on few pages, to see if something's not completely expected there (specifically related to cache)

The next thing I would check is the server time settings, along with the timestamps of the tag cache files. It looks to me like the cache files are being created too often, instead of respecting 30 min refresh interval.

1
  • You are right - indeed the caches are build too often, the same file every minute or so. But how can I use this knowledge to fix the problem?!
    – BNetz
    Jul 5 '21 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.