0

EE 2.7.1 and Assets 2.2.1

I have a Grid fieldtype (static-images) with an Assets column named image and a few native text field & dropdown columns. When I have at least one row in the Grid, I get the following error in the frontend:

A PHP Error was encountered

Severity: Notice

Message: Undefined index: grid_row_id

Filename: assets/ft.assets.php

Line Number: 1310

(I also get the usual "Cannot modify header information" PHP Warnings after that.)

I've reduced the template code that displays the Grid field to the following, which still triggers the PHP Notice:

{static-images}
    {static-images:image:url}
{/static-images}

Any ideas?

Free Bonus Bug! If I mark the Assets Grid column as "Required" but don't add a file, the in-column error message shows "The %s field is required." :p

1

Assets 2.2 requires EE 2.7.2 to work with Grid - that was mentioned in the yesterday's blog post about the release :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.