0

I have an online shop which uses CT and offsite payment processing. Upon returning to the store after a successfull (test)purchase I recieve those errors:

Strict Standards: Declaration of Matrix_ft::post_save() should be compatible with EE_Fieldtype::post_save($data) in /Users/user/Sites/site/dev.site.de/system/expressionengine/third_party/matrix/ft.matrix.php on line 3753

Strict Standards: Declaration of Matrix_ft::save_settings() should be compatible with EE_Fieldtype::save_settings($data) in /Users/user/Sites/site/dev.site.de/system/expressionengine/third_party/matrix/ft.matrix.php on line 3753

Strict Standards: Declaration of Matrix_ft::post_save_settings() should be compatible with EE_Fieldtype::post_save_settings($data) in /Users/user/Sites/site/dev.site.de/system/expressionengine/third_party/matrix/ft.matrix.php on line 3753

Warning: Cannot modify header information - headers already sent by (output started at /Users/user/Sites/site/dev.site.de/system/expressionengine/third_party/matrix/ft.matrix.php:3753) in /Users/user/Sites/site/dev.site.de/system/expressionengine/libraries/Functions.php on line 415

At the moment I have really no clue what that might be about. Offline payments go through without any problems and I am not using anything Matrix related in that part of the shop.

So any hints in the right direction would be great. Thanks!

1

Have you updated Matrix & EE yet? It's not a Cartthrob issue i'm afraid.

4
  • I'm on the latest Matrix (2.5.10) and EE 2.7.3. – Marc Apr 26 '14 at 12:40
  • Well, for now, i'd look at a temporary solution like this - stackoverflow.com/questions/12229113/… – JohnWBaxter Apr 26 '14 at 16:02
  • Thanks John for your input. I'll wait a couple of days and see what P&T might chip in and otherwise I'll contact the server company and ask them. – Marc Apr 26 '14 at 16:20
  • You can probably add that in yourself with a local php.ini tbh, but good luck with it either way :) – JohnWBaxter Apr 26 '14 at 17:29
0

I have run into a similar error which can usually be fixed by adjusting the notification template code but could not find any errors this time. Eventually managed to work around it by placing the following code in the extload.php file.

error_reporting(E_ALL & ~E_STRICT & ~E_NOTICE);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.