1

A client wanted to be able to drag/drop the ordering of some customers on their site, so I've changed the customers channel in Structure from being a listing to being a page based channel and was going to have one "page" per customer.

The problem I'm having now is all existing (and new) rows have a Structure tab, but are missing these fields.

  • "Structure parent entry"
  • "Hide from nav?"
  • "Listing channel"

In the channel sidebar (where you can view fields) these fields appear but have no icon next to them (the eye) and can't be dragged onto the Structure tab.

Has anyone come across this before?

  • 1
    Have you reset your layout? – Peter Lewis May 29 '14 at 9:34
  • 1
    Hi Peter. Yeah that was the first thing I tried. It appears you can't go from Structure listing entries and change them to pages type entries and have it work. Unfortunate. Perhaps due to not create page entries in exp_sites? In any case it was irresolvable so I had to recreate the channel and entries. – JamesNZ Jun 16 '14 at 2:00
2

Sounds like some crossed wires with your publish layout. Reset the layout, refresh the page, and try again.

| improve this answer | |
  • 1
    Yeah resetting the publish layout was the first thing I tried. It was actually a Structure issue where listings couldn't be changed to a page type. This ended up being an irresolvable issue where I had to re-create the channel unfortunately. Thanks. – JamesNZ Jun 16 '14 at 1:59
  • What @kgrote suggested worked when I tried it just a few moments ago on an ExpressionEngine 2.9.2 site running Structure 3.3.17. – Brooks Seymore Sep 29 '15 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.