1

UPDATE September 25, 2014: I reverted once, but now I'm trying again with an update to 2.9.0 and facing the same issue. If anyone has any insight it would be appreciated!

UPDATE 2 I think I may have found the source of the issue. It appears that a parallel install of the site used for QA, was interfering. When I renamed the folder containing that site, the problem went away. Now I need to track down why it was loading from the wrong place. Perhaps a bug in my config_bootstrap.

UPDATE 3 The theme_folder_path variable is set to the location in one of the other installs, so that explains why it was loading incorrectly, now I need to figure out where in the blazes that is being set. None of the usual suspects seem to have it.

UPDATE 4 I searched my entire database for what I could think of (probably serialized data, and I don't know where to look), and I searched all my configuration files and I couldn't find anywhere that theme_folder_path was being set. I tried saving an update in the control panel and the change held, so my best guess is that the wrong value was in the database somewhere. I've now improved my config_bootstrap setup so that it should set the correct themes folder for each version of the site automatically. Is there any way to see where config items shown in the control panel are being loaded from? I will post an answer to the question that will hopefully help people with this issue in the future, and will probably award the bounty to Rob Sanchez who put the most effort into trying to help me.


I upgraded from 2.5.5 or thereabouts to 2.7.3 on my local environment some time ago. After I got my relationship related addons, queries, and templates sorted out it all worked fine.

Today I finally got around to updating the production site, and after applying the above mentioned fixes the front end of the site works fine, but the back end has some issues:

  1. On every page of the control panel I get an TypeError: d.ee_focus is not a function error
  2. On entry form pages, the format buttons don't load and the image and write mode buttons don't work
  3. clicking on accessories pops me to the top of the window but accomplishes nothing else.

There were some permission errors during upload of the files for the new version of EE, but at this point I think I've reuploaded everything at least 3 or 4 times. I suspected the themes folder, but have reuploaded from 2 different sources of 2.7.3 and nothing fixes it. I've disabled pretty much all the addons I can without losing data and that hasn't fixed it either.

I've searched the entire systems folder and themes folder for ee_focus and cannot find it. I do find it in themes/javascript/compressed/jquery/plugins/ee_navigation.js from older versions, but not in 2.7.3.

Where is the error coming from? Is it causing all the other control panel strangeness? Help me Obi Wan Kanobi, you're my only hope!

  • I think I'm going to have to give up and revert to a backup. I've replaced all the files with files from a working local install and I'm still getting the errors. It must be some kind of database problem, or it is not in system or themes somehow. – UltraBob Jul 4 '14 at 2:16
  • 1
    It has become impossible to determine a correct answer for this question because I had to revert the website and correct the issue before I could track down the problem. – UltraBob Jul 4 '14 at 5:37
  • I'm trying this update again, and having the same issue. – UltraBob Sep 25 '14 at 7:29
  • Did you see this from the ee forums: ellislab.com/forums/viewthread/237724 – Romans-8---31-39 Sep 25 '14 at 13:30
  • I have seen that thread. I've reuploaded my themes folder tons of times, and removed anything I can think of that could possibly contain old code that it might be loading from. – UltraBob Sep 25 '14 at 21:32
1

Here is some preamble about the process of discovering the issue, but the quick thing to check that worked for me is in the heading below, so feel free to skip ahead to see if that gives you the solution before reading the preamble.

Google searches turned up sparse results for this issue, but all results pointed to an old version of the themes folder being used instead of the current version. I tried very hard to make sure that the themes folder I had was the most current one, and that no other themes folder could be being loaded somehow by mistake by reuploading the current themes folder form EllisLab and deleting all older backups of the themes folder (themes_old if you follow the upgrade instructions to the letter). None of this seemed to work.

I tried uploading a fresh copy of the nerdery theme to see if that might make a difference, and noticed that the list of available themes did not match my list. The thing that really tipped me off was that the nerdery theme was listed as Nerdery-Theme-master and the install I had just made was in a folder called nerdery. When I selected Nerdery-Theme-master in the list and submitted I got a bunch of errors about things not being found. I remembered having noticed in the past that I had for some reason installed nerdery with a weird name (that reason is lost to time) so I went looking for that folder in the cp_themes libraries of other site installs and found it in my dev install.

TLDR; This is the important bit

I'm sure at some point during debugging this I had looked at Admin->General Configuration, but I hadn't noticed the problem. Looking again this time, I found the site path of my dev server in the Theme Folder Path field. This seems to have been stored in the database, as I could see no evidence of it existing in my configs anywhere. Updating the entry to the correct path corrected the problem, and I then added it into my config_bootstrap to make sure each version of the site gets the correct themes folder everytime going forward.

| improve this answer | |
  • Correcting the theme folder path fixed the problem for me in one case. – 4midori Mar 20 '15 at 21:14
0

I remember having this issue; I was able to resolve it by copying the file from an older version of EE (replace the version in your installation).

If you're not comfortable with that, try switching to a different CP theme -- I recommend Nerdery (http://devot-ee.com/add-ons/nerdery) -- and see if that fixes the issue?

| improve this answer | |
  • I tried copying in an earlier version of that jquery file, and that didn't help, any idea what file I need? – UltraBob Jul 3 '14 at 13:26
0
+50

Do you have Zoo Flexible Admin installed? Older versions of this will trigger a d.ee_focus is not a function error on EE 2.7+

| improve this answer | |
  • Nope, but I have seen that thread, and lots of others recommending a themes folder reupload. I've reuploaded tons of time, and removed anything I can think of that could possibly contain old code that it might be loading from. – UltraBob Sep 25 '14 at 21:31
  • In the Chrome inspector, it should show you the exact file and line number where the error occurs. You can click it to be taken to the script containing the error. My guess its it's a third_party script that's doing this. – Rob Sanchez Sep 25 '14 at 21:53
  • In both firebug and Safari (and Chrome if memory serves, I'll check later, it showed admin.php) which is obviously loading other stuff in. – UltraBob Sep 25 '14 at 22:10
  • Much of the CP JS will be aggregated by admin.php, so don't be discouraged by that. It'll be important to note the exact url (w/ query string) where the error is occurring. – Rob Sanchez Sep 25 '14 at 23:10
  • Please see the question for updates, if you can help me figure out where to look for that variable the bounty is yours. – UltraBob Sep 26 '14 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.