0

Emails are not getting sent from my EE site. It doesn't work for password reset, order confirmations from Expr-esso store, or when I use Communicate.

I have enabled email debugging and set protocol to Mail, then tried to send an email via Communicate. I didn't see any debugging info.

I am trying to use Mandril and have set protocol to SMTP and set server/port/username/password. Emails still not sent -- and I don't see any evidence of an attempt in Mandrill API logs.

Oddly - I can't seem to change the SMTP username and password under email configuration. When I edit those two fields along with other fields, everything else gets saved properly except username & password. They retain the original values. The password is not correct and needs to be fixed.

Where are the details for email configuration saved? I have been looking in the database and files, but not really finding anything.

Also, any suggestions on how to troubleshoot this problem?

  • Long shot, but... Could your browser be auto filling these fields in? If you have them saved try removing the saved data from your browsers saved passwords. – sheferd Dec 8 '15 at 0:35
  • I'll investigate that. Do you know where these details are saved, though? – ExpressionEngineNewbie Dec 8 '15 at 2:56
  • Usually under browser preferences > security & Privacy. for Firefox its Preferences > security > saved logins. not too sure for others though – sheferd Dec 8 '15 at 11:46
1

I can't speak for your Mandril setup, but make sure your server is set up correctly first. I'm assuming some Linux flavor. In an SSH terminal, run this command:

echo "Test email content" | mail -s "Test email subject" -a "From: fromaddress@mydomain.com" "destinationaddress@myemail.com"

and make sure to check your spam folder as well. If you don't receive anything from that email, your server may need re-configuring. Try installing sendmail:

http://pc-freak.net/blog/install-sendmail-debian-gnu-linux/

But before you even do that; make sure your IP isn't listed on spamhaus:

https://www.spamhaus.org/lookup/

Again, not sure about Mandril, but make sure your server can fire out emails first, then move forward with debugging.

Edit Again, no clue about Mandril. For EE, the SMTP settings are stored in a serialized PHP array in the database, which is base64 encoded. Query it:

SELECT `site_system_preferences`
    FROM `my_schema`.`exp_sites`
    WHERE site_id = "1";

... assuming your site_id is 1. Take that value, and use an online base64 decoder to get your PHP serialized array. However, there really isn't any reason why just changing those settings in Your Site -> CP Home -> Administration -> Email Configuration would not update those values. Did you try my first debugging steps to make sure your server is firing off emails?

Do you want all email coming from this server to go through a relay host (SMTP)? In that case, you'll need to install and configure postfix. It would help if you would clarify your question a little, but hopefully this info is useful.

| improve this answer | |
  • Do you know where the SMTP data is saved? DB? Files? If I can view it there, I might have some extra insight. – ExpressionEngineNewbie Dec 8 '15 at 2:57
  • @ExpressionEngineNewbie I've updated my answer some. – jrothafer Dec 8 '15 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.