0

On a simple page with no embeds, the registration tag works well and the form is displayed on the webpage:

  {exp:visitor:registration_form error_handling="inline" return='conta'}

                Email*: <input id="email" name="email" type="text" value="" />
                {error:email}

                Password*: <input id="password" name="membro_senha" type="password" value="" />
                {error:password}

                Confirm password*: <input id="password_confirm" name="membro_senha" type="password" value="" />

                Member firstname: <input id="mbr_membro_nome" name="mbr_membro_nome" type="text" value="" />
                {error:mbr_membro_nome}

                Member lastname: <input id="mbr_membro_sobrenome" name="mbr_membro_sobrenome" type="text" value="" />
                {error:mbr_membro_sobrenome}

                Gender (radiobuttons): {options:membro_sexo} <input id="membro_sexo" name="membro_sexo" type="radio" value="{option_value}" />{option_value} {/options:membro_sexo}

                Birthday (datepicker): <input id="membro_aniversario" maxlength="23" name="membro_aniversario" size="25" type="date" value="" />

                <input class="form-submit" type="submit" value="Register" />

    {/exp:visitor:registration_form}

registration form

But there is a problem with the update form tag, nothings is displayed, a blank page is displayed with absolutely no code, it seems EE doesn't recognise this tag:

{exp:visitor:update_form return='account/update_profile/success'}
        Member firstname: <input id="member_firstname" name="member_firstname" type="text" value="" />
        Member lastname: <input id="member_lastname" name="member_lastname" type="text" value="" />
        Gender (radiobuttons): {options:member_gender} <input id="member_gender" name="member_gender" type="radio" value="{option_value}" />{option_value} {/options:member_gender}
        Birthday (datepicker): <input id="member_birthday" maxlength="23" name="member_birthday" size="25" type="text" value="" />
        <input class="form-submit" type="submit" value="Update profile" />
{/exp:visitor:update_form}

Did-someone has already encountered this problem? I tried under PHP 5.6, PHP 7.0, 7.1, the problem still the same. I tested on Wamp 3.0.9 on Windows 10, and on and on a physical Apache server. On local with wamp and in the Apache server, the exp:visitor:update_form doesn't work at all. I tried with EE 3.5.10 and EE 3.5.7.

What could be the problem ??? My Visitor 3.0.1 installation is ok.

If Someone encountered the same problem, I will relate it to DevDemon.

3
  • 1
    Are you logged in as a member on the browser you're testing update_form on? Aug 7 '17 at 14:44
  • Yes i'm logged as a member on the browser when I'm testing update_form on. Even on a fresh install on a Apache server, with only Visitor as addon. The installation is ok. Betweeen exp:visitor:update_form command, nothing is displayed, on the html.. Logged as Admin this problem appears, so I will try to discover if there is a relation with member authorisations, or template access.
    – Stéphane
    Aug 7 '17 at 18:19
  • Hi Romans, thanks to your comment I immediately thought that always i was logged as admin, and never as a member. So the problem is solved, when I logged as admin update form tag is not processed, logged as member is proccessed. Thanks a lot !!
    – Stéphane
    Aug 7 '17 at 18:48
2

Thanks to the Romans-8---31-39 comment's, I discovered when i am logged as admin, exp:visitor:update_form is not processed, logged as member it is processed, so the the problem is solved!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.