2

With EE2, Zoo Visitor was easy to install.

the lack of documentation makes it very difficult to install Visitor on EE3.

Here the copy of the screen installer.enter image description here

Without the documentation I can't understand this error message: enter image description here

An anonymous Guest member does not exist or is not linked with Visitor, go to the Visitor settings and select a member you want to use as anonymous Guest member.

I don't understand this error message too, because Visitor has created and anonymous Guest member.error message about the anonymous Guest Member

If I click on install this messager error appears: enter image description here

The settings options is not working. Does someone already has ever encountered these problems?

Updated Question with theses errror screenshots

Here more details about error message when i click on install, I tried to manually one by one each step, but But I can not do it.

The error screenshots under the

Expcetion Caught mesage

errors messages

  • Are you using php7? – Mufi - Amici Infotech May 27 '17 at 10:14
  • Hi Mufi, yes it's PHP 7.1. But I tried after with PHP 5.65, it was the same problem. I will try install it using PHP 5.65. Thanks – Stéphane May 27 '17 at 14:14
  • Using PHP 5.6 the problem still the same. – Stéphane May 27 '17 at 15:01
  • 1
    I've just installed Visitor on an external server, and it works fine. So, the problem is a local Wamp server configuration. But I confess I don't know what are the wrong parameters. (WampServer Version 3.0.8 64bit, Apache 2.4.23 - PHP 7.1.0, MySQL 5.7.14). – Stéphane May 27 '17 at 21:00
  • Visitor module is not compatible with php7.. it should work on wamp or xamp if you run php 5.3.8 or something similar version. Sometimes guest member is not linked automatically. We have to create one and assign him. – Mufi - Amici Infotech May 28 '17 at 16:41
2

I have the same issue. What I did is to manually create these fields on Visitor Fields group:

  • [Field Name | Shortname | Field Type | Options]
  • Member account | member_account | visitor | n/a
  • Firstname | member_firstname | text | n/a
  • Lastname | member_lastname | text | n/a
  • Gender | member_gender | radio | 'Male' & 'Female' on Radio options
  • Birthday | member_birthday | date | n/a

when I created these fields and refresh the install page (or click the start install button), all status is now Done.

Note: This solution is only to be able to continue on the setup and not a permanent solution for the actual problem with the addon. I'm not very good programmer I just tried doing this and it worked. Just sharing it.

| improve this answer | |
  • Hi Neetcoder, thanks for your solution. have you experienced this issue on a local server (Wamp)? When I installed Visitor 3.0.1 on an external server )(Apache PHP 7) I didn't encountered problems with the installation, I guess it must be a server configuration problem. So if I don't find the right configuration server under Wamp, I will use your solution. – Stéphane Jun 30 '17 at 13:03
  • 1
    It happened on both my local server (Ubuntu, PHP 7.1.5) and external server (PHP 7.1.6). I didn't spend much time to it, I'm on a tight schedule. – neetcoder Jul 2 '17 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.