0

I have a site that's running EE 3.3 and I'm trying to change it to include the SSL certificate that's just been installed on the server.

I normally can change the config or the URL settings to include the https and then update the .htaccess to force https on all the urls. However when I try this the site just gets caught in a loop.

I've tried removing everything out of the .htaccess and then trying but it then redirects back to the http.

I've also set up a plain html test page outside EE and I can access that if I go to it but if I then visit the website and then go back to the test page it redirects back to the homepage.

Going round in circles so would appreciate any help.

Thanks in advance.

0

Did you check your config.php files fo any url config? Maybe there's something overwriting the url and path settings in the cp?!

| improve this answer | |
  • Thanks I’ve removed everything out of the config file and still loops – James Cottis Mar 28 '19 at 6:54
0

To overcome this issue very first thing you need to do is to change URLs (with https) from Admin Panel (Settings >> URL and Path Settings). Make sure there should no hardcoded URL in config.php. Then you should add below code in your .htaccess file.

RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
| improve this answer | |
  • Hi Thanks. I removed everything from the config file and added it in but I get the same error. ******** The page isn't redirecting properly An error occurred during a connection to xxx This problem can sometimes be caused by disabling or refusing to accept cookies. ******** Something is forcing it back to http so it then gets caught in a loop. Also have noticed that if I change the site url to https and then load the homepage it loads but no inner pages work. Also the css can't be found on the homepage and I'm using {site_url} for the link. – James Cottis Mar 28 '19 at 9:04
  • What did you write in config.php can you add in your questions? – Harsh Barach Mar 28 '19 at 12:49
  • Config did have the $config['site_url'] = but I removed this and set it to go through the settings page. – James Cottis Mar 28 '19 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.