0

did everything as described in the docs on upgrading EE1 to EE2 and getting stuck around 2.1.4 and then this error comes up on the screen. How do I upgrade to 2.6.1 from 1.7.3 without getting this error?

A Database Error Occurred
Error Number: 1064

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '`wm_name` varchar(80), `wm_type` varchar(10) DEFAULT 'text', `wm_image_path` v' at line 3

ALTER TABLE `exp_member_groups` ADD `wm_id` int(4) UNSIGNED AUTO_INCREMENT, `wm_name` varchar(80), `wm_type` varchar(10) DEFAULT 'text', `wm_image_path` varchar(100), `wm_test_image_path` varchar(100), `wm_use_font` char(1) DEFAULT 'y', `wm_font` varchar(30), `wm_font_size` int(3) UNSIGNED, `wm_text` varchar(100), `wm_vrt_alignment` varchar(10) DEFAULT 'top', `wm_hor_alignment` varchar(10) DEFAULT 'left', `wm_padding` int(3) UNSIGNED, `wm_opacity` int(3) UNSIGNED, `wm_x_offset` int(4) UNSIGNED, `wm_y_offset` int(4) UNSIGNED, `wm_x_transp` int(4), `wm_y_transp` int(4), `wm_font_color` varchar(7), `wm_use_drop_shadow` char(1) DEFAULT 'y', `wm_shadow_distance` int(3) UNSIGNED, `wm_shadow_color` varchar(7), `id` int(10) UNSIGNED AUTO_INCREMENT, `upload_location_id` int(4) UNSIGNED DEFAULT '0', `title` varchar(255), `short_name` varchar(255) DEFAULT '', `resize_type` varchar(50) DEFAULT '', `width` int(10) DEFAULT '0', `height` int(10) DEFAULT '0', `watermark_id` int(4) UNSIGNED, `file_id` int(10) UNSIGNED AUTO_INCREMENT, `cat_id` int(10) UNSIGNED, `sort` int(10) UNSIGNED DEFAULT '0', `is_cover` char(1) DEFAULT 'n', `site_id` int(4) UNSIGNED DEFAULT '1', `rel_path` varchar(255), `status` char(1) DEFAULT 'o', `mime_type` varchar(255), `file_name` varchar(255), `file_size` int(10) DEFAULT '0', `field_1` text, `field_1_fmt` tinytext, `field_2` text, `field_2_fmt` tinytext, `field_3` text, `field_3_fmt` tinytext, `field_4` text, `field_4_fmt` tinytext, `field_5` text, `field_5_fmt` tinytext, `field_6` text, `field_6_fmt` tinytext, `metadata` mediumtext NULL, `uploaded_by_member_id` int(10) UNSIGNED DEFAULT '0', `upload_date` int(10), `modified_by_member_id` int(10) UNSIGNED DEFAULT '0', `modified_date` int(10), `file_hw_original` varchar(20), `can_admin_upload_prefs` CHAR(1) DEFAULT 'n' NOT NULL AFTER `can_admin_channels`

Filename: /home/user/admin/expressionengine/libraries/Smartforge.php

Line Number: 122

So I then remove all the new EE2 files and try and go back to EE1, I load my homepage and get this error:

Site Error: Unable to Load Site Preferences; Invalid Preference Data
1

Are the columns the script is trying to add to exp_member_groups already present, perhaps from an earlier aborted attempt at an upgrade?

Looks like that was the issue when someone posted a similar question on EllisLab forum.

You mentioned that you restored the files, but did you restore the database as well?

| improve this answer | |
  • yes sounds like a similar issue. Wasn't worth the headache so I sinstalled a new install of 2.6.1 and manually created everythins – Peter Eastwood Aug 17 '13 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.