0

This error came up after updating ee and opening 'admin.php'

You must define the following database parameters: database
ee/EllisLab/ExpressionEngine/Service/Database/DBConfig.php:157 

Stack Trace: #0 ee/EllisLab/ExpressionEngine/Service/Database/Database.php(151): EllisLab\ExpressionEngine\Service\Database\DBConfig->getGroupConfig() #1 ee/EllisLab/ExpressionEngine/Service/Database/Database.php(84): EllisLab\ExpressionEngine\Service\Database\Database->newConnection() #2 ee/EllisLab/ExpressionEngine/Service/Database/Database.php(51): EllisLab\ExpressionEngine\Service\Database\Database->getConnection() #3 ee/legacy/database/DB.php(48): EllisLab\ExpressionEngine\Service\Database\Database->newQuery() #4 ee/legacy/core/Loader.php(381): DB('') #5 ee/legacy/libraries/Core.php(107): EE_Loader->database() #6 ee/legacy/core/Controller.php(88): EE_Core->bootstrap() #7 ee/legacy/core/Controller.php(119): EE_Controller->__construct() #8 ee/EllisLab/ExpressionEngine/Core/Core.php(187): CP_Controller->__construct() #9 ee/EllisLab/ExpressionEngine/Core/Core.php(94): EllisLab\ExpressionEngine\Core\Core->runController(Array) #10 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request)) #11 admin.php(143): require_once('...')
1

Are you absolutely sure you have your DB settings correct in your config.php file? They should have this format in that file:

$config['database'] = array (
    'expressionengine' =>
        array (
            'hostname' => '',
            'username' => '',
            'password' => '',
            'database' => ''
        ),
);

Obviously, fill in the values with your credentials. database should have the name of your schema you installed EE to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.