2

Running EE v2.5.5 and FreeMember 2.1.1

I am using the following code to log out a user:

<a href="{exp:freemember:logout_url return="dashboard/register"}">logout</a>

clicking the link takes me to EE's system message page with the following message:

You are not authorized to perform the following action

am I implementing this wrong or is there a bug perhaps?

Here are links to my templates

logging out from here: http://pastie.org/6317009

any page I use for the return param creates the same error

Thanks!

  • Can you try upgrading to FreeMember 2.2? There was an unfinished version available on GitHub which some people managed to get a hold of which may be causing the error. – Adrian Macneil Feb 20 '13 at 9:51
  • When I download FreeMember from git hub The latest version I get is 2.1.1 where could I get 2.2 ? – mjr Feb 20 '13 at 19:03
  • Is this only happening with the logout tag? Can you login and register using FreeMember without issue? Also, this may sound crazy, but are you definitely logged in? – Adrian Macneil Feb 21 '13 at 14:32
  • definitely logged in, but glad you asked :) yes, it only happens on logout, login register are ok – mjr Feb 21 '13 at 18:30
  • am I missing something about the 2.2 release, didn't see it on github – mjr Feb 21 '13 at 18:30
1

This error has been fixed in FreeMember 2.2.1, released today:

https://github.com/expressodev/freemember

1

You are implementing the tag correctly according to the docs.

This error is usually related to a member having incorrect access or issues with forms being processed in Secure Mode.

Things to try:

  1. Change the return parameter to another URL, try return="/". If another URL works, something in that template is the problem so you'll need to reduce to find out what.

  2. Disable the "Process Form Data in Secure Mode" setting on the Security and Sessions page in the CP which is located here: Admin ‣ Security and Privacy ‣ Security and Sessions.


EDIT
With the new if of your template code, here are two things to try:

  1. Change {if logged_out}{redirect="/"}{/if} to {if logged_out}Logged out{/if}. Does it show or same error?
  2. Remove all code from the template except {if logged_out}{redirect="/"}{/if}
  3. Change {if logged_out}{redirect="/"}{/if} to {if logged_out}{redirect="/"}{if:else}ALL OTHER TEMPLATE CODE HERE{/if} OR {if logged_out}{redirect="/"}{/if} {if logged_in}ALL OTHER TEMPLATE CODE HERE{/if}
  4. Test a new template that just handles redirect with {if logged_out}{redirect="/"}{/if} {if logged_in}{redirect="dashboard"}{/if}
  5. Test {if logged_out}{redirect="{path=}"}{/if} OR {if logged_out}{redirect="http://www.domain.com"}{/if}
  6. Check the URL where you are seeing the message... is it the dashboard URL or the home page URL? It will tell you where the issue is.
  • After trying a different return param I'm still getting the same issue. Turning off secure mode sounds, well, insecure :) – mjr Feb 20 '13 at 19:09
  • Turning off secure mode and testing will just give you more information. Let me know the results after you test. You can turn the setting back on after you tests. – Anna_MediaGirl Feb 20 '13 at 22:31
  • Okee dokee. After testing with secure mode set to no, I'm still experiencing the same behavior. – mjr Feb 21 '13 at 4:47
  • Can you post the template code for this page and the return page to www.pastie.org and add the links to your question. Perhaps something else in the pages is causing the issue. – Anna_MediaGirl Feb 21 '13 at 17:24
  • Also, are you testing this with a SuperAdmin user or another group member login? – Anna_MediaGirl Feb 21 '13 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.