I really want to use the built in Image Manipulations to allow the images to be resized at the time of upload to help remove some of the extra server stress on load in the templates using CE Image.

The idea is to create a few sizes small/medium/large and then use CE Image to modify these if necessary.

I want to continue using Assets, but not sure if the sizes will work with it.

Can anyone advise me if this is possible with Assets 2?


Assets does work with the built-in image manipulations when using local sources. See Asset Image Manipulations



Assets respects the settings in the "File upload preferences". So if you have set a maximum size there it will be applied to an Assets upload.

I personally don't bother with creating any alternative sizes with the "Image Manipulations" option. I just use CE Image to create whatever I need whenever I need it in the template code. Why bother to create any if you are going to use CE Image anyway? After the image has been called once the smaller image is cached, so no extra load on the server.

  • 2
    Thanks Paul. I am looking to use the built in image manipulations because CE Image is struggling to create the images in the template as they are high res. the idea is that majority of the pages can just use the manipulations, then any that need filters or crops can use the manipulations with CE Image on top. CE Image should handle the changes much faster as the images will also be much smaller because of the resizing already completed at the time of upload.
    – ccdavies
    Jul 20 '13 at 19:27
  • 1
    Totally concur here - CE Image can easily choke on a 2+ MB image, giving your visitors the WSOD. Setting an initial resize on upload to a more manageable size is a sound idea. Jul 22 '13 at 13:06
  • I do set a maximum image size of 1000px in the File Upload Preferences, so I already start with a reasonable size. This is big enough for web viewing and stops the server getting clogged up with loads of massive files. If you need to have very high res images available to download or view then I can see there could be problems. Could the issue with WSOD be cured by allocating more memory? I use a php.ini file to increase the default memory_limit to 128M and increase the upload_max_filesize to 20M
    – Paul Frost
    Jul 22 '13 at 21:54
  • Does Assets also resprect the 'File upload prefs' when uploading to S3? Oct 20 '15 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.