0

Updating an older site, and I'm getting an error using the DevDemon Updater (v3.2.15), while trying to bring a site from 2.5.5 to 2.8.1

It stops during the update process on an error. And that message says: Unexpected server response, probably a php error. Show Error - which I click through, it says this:

A PHP Error was encountered
Severity: Warning
Message: copy(/var/www/vhosts/mysite.com/sitehomedir/blog/system/expressionengine/cache/updater/1407520245_589541/system/EllisLab): failed to open stream: No such file or directory
Filename: libraries/updater_transfer.php
Line Number: 827
{"success":"yes","body":""}

Not sure why it's looking for an Ellislab folder in /system/ - Is this a bug in the updater? Or something with my code?

Caveat: my site is in a subfolder (i.e. mysite.com/blog/ ) All the other functions work fine, but I just can't get EE to update.

0

I went poking in the code for the plugin and found the reference to EllisLab - I removed the updater and installed an earlier version (v3.2.11). And that version was able to update my site to 2.8.1 without any issues appearing.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.