Hot answers tagged

3

try next config: server { listen 443 default_server ssl; ssl_certificate /etc/nginx/ssl/xxx_xxx_xxx.pem; ssl_certificate_key /etc/nginx/ssl/xxx_xxx_xxx.key; server_name xxx.xxx.xxx; root /sites/xxx_xxx_xxx/public_html; access_log /var/log/nginx/xxx_xxx_xxx-access.log; error_log /var/log/nginx/xxx_xxx_xxx-error.log info; location /themes/...


3

I've not seen that before. Odd one! Take a look here at sample code for setting status from that hook. Maybe it will provide some direction. https://github.com/CartThrob/extension-change_product_status In theory, sagepay should hit the callback url on payment complete (extload.php) and POST it the payment status flag (Y,C etc) which CT then interprets into ...


2

Dorothy dorothy has answered my question in another post: Take a look in your system folder \expressionengine\third_party\cartthrob\payment_gateways\Cartthrob_sage_s.php file Somewhere at around line 172 you will see that the $post_array includes the NotificationURL. Look for this line: 'NotificationURL' => $this->response_script(...


2

Take a look in your system folder \expressionengine\third_party\cartthrob\payment_gateways\Cartthrob_sage_s.php file Somewhere at around line 172 you will see that the $post_array includes the NotificationURL. Look for this line: 'NotificationURL' => $this->response_script(ucfirst(get_class($this))), if you add a die statement like this: ...


2

Sorry, there was an unexpected error communicating with the payment gateway. This generally means that there was a communication problem talking to the gateway (i.e. your server is blocking the request, or the authentication details are incorrect). We're working on better logging for these errors, but in the meantime the full error isn't displayed because ...


1

I would suggest making sure all your paths are correct in the server move, especially as listed here: themes/third_party/cartthrob/lib/extload.php. That's usually the issue in this kind of situation.


1

(I'm with Vector; we make CartThrob) This error is coming directly from SagePay and honestly, is usually exactly what it sounds like: your server is making a request from an IP that's not whitelisted in SagePay's system, so they're rejecting it. Common causes of this include: You're using a VPS or cloud server and the IP has changed You're using a server ...


1

Having spoken to the very helpful Chris @ Cartthrob during a dedicated support session, thought I'd come back to answer this - the soon to be latest edition of Cartthrob will handle Sagepay 3.00 vps - I can confirm all worked great from my point of view, as the update was conducted during the support session, and I was immediately able to both continue to ...


1

How you do this will depend on the fields you have for your product code. If you're using the title field, then this will automatically be carried across to your orders. If you're using a different field for example something like {product_sku}, then you'll need to carry this over into your orders channel. You can collect any custom data for products as ...


1

Due to the new EE security preventing forms being submitted without an XID, third party gateways can't submit POST notifications. The csrf protection needs to be disabled. To prevent disabling the security feature globally, we use this in our config.php file for Payment Gateways: /* |-------------------------------------------------------------------------- ...


1

This was an issue with accepting tokens with a test gateway. This has now been resolved.


1

Ensure your firewalls allow outbound Port 443 (HTTPS only) & inbound ports 443 (& optionally 80 HTTP) access in order to communicate with our servers (on Test/Live). Check not a DNS issue if not receiving our (Sage Pays) Notification post. What are the main differences between the two NotificationURLs? When acknowledging Sage Pays notification ...


1

For the Merchant Service application - a working Test or Live wesbite is required so that the merchant bank, Elavon, can simulate the check out process up to the payment page. This does not need to be integrated with Sage Pay at this point.


1

I spoke at length with Chris Newton (Cartthrob developer) and he eventually tracked the problem down to a combination of me using Focus Lab's multi-environment config, changes in the way that EE 2.7.2 handles $assign_to_config[] and how this affected CT2.4. We're still working on a fix, but it looks like this was a very specific environment/config issue.


1

have you updated the extload.php inside /themes/third_party/cartthrob/lib ?


Only top voted, non community-wiki answers of a minimum length are eligible