12

In EE 2.7, each class extending EE_Fieldtype is required to implement a display_field() function. So either you implement that function with no actual implementation if you just want the error to go away public function display_field($data) { // NOTE: Placeholder } or wait for the fieldtype developers to implement the function so as to be compatible to ...


12

Grab the latest P&T Field Pack. They fixed it recently.


9

Go to Add-ons > Modules > Wygwam > Editor Configurations and select the configuration you want to edit. Look for the Restrict allowed HTML? setting and make sure it is set to No.


8

You can do this without editing the Wygwam source. First you need to create a custom config file for CKEditor. Create a JavaScript file called something like 'ckeditor_config.js' and then set Wygwam to use it. You can do this by adding an advanced setting to your Wygwam editor configuration. Add the 'customConfig' setting and enter the path to the JavaScript ...


8

The problem is that many developers don't know how to write compliant SQL statements - they're software developers who find themselves also filling the role of database developers. This problem crops up in many addons and was recently fixed in EE core code. For Assets v2.6 Change line 615 of ft.assets.php FROM: $sql = "SELECT DISTINCT a.source_type, a....


7

...And as soon as I write it down in a question, I figured out my mistake. Correct solution for future visitors was: {if "{product_videos:total_children}" > 0} //do something {/if}


7

Here's how to upgrade an existing EE install with P&T fieldtypes. After upgrading EE you'll get this error when visiting the modules section: Fatal error: Class PT_Fieldtype contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (EE_Fieldtype::display_field) in /third_party/pt_field_pack/pt_fieldtype.php ...


6

Pixel and Tonic obliged me with this request recently. Just purchase a license for Matrix, then email them to request the last available EE1-compatible version (I believe it's 2.5.3).


5

Having recently upgraded an EE v1.6.8 site to v2.6.1, I had to re-save each of the Wygwam fields to fix the "defer" PHP notice. http://website.com/manage.php?D=cp&C=admin_content&M=field_group_management


5

The {options:field_name} tag pair is actually a Safecracker tag, which only works with Field Pack 1.x out of the box. You can add Field Pack 2.x support by opening up system/expressionengine/config/config.php and adding these lines: $config['safecracker_option_fields'][] = 'fieldpack_checkboxes'; $config['safecracker_option_fields'][] = '...


5

This could arguably be a duplicate of this question, but it's a bit different because you're asking how to silence the error so you can finish the update per the P&T docs. I just ran into this today myself and had the same question! The solution is courtesy of this answer. Open up pt_fieldtype.php and below the constructor (around line 29) add: public ...


5

That’s an error in the documentation, and we’ll get that fixed. :child_ids only supports filtering entries with the following parameters: var_id var element_id field_id field col_id col row_id child_id parent_id If you need anything else, and you should just use a tag pair: {event_related_media limit="2" status="Archived" channel="video" ...


5

Unfortunately, there wasn't a good answer in getting this to work with Matrix. Everything I tried still resulted in a page load time of 14.6 - 17.2 seconds. I worked with EllisLab all day Friday from like 2-9. We spent the day debugging templates, analyzing output, checking for red flags, etc.. I completely rebuilt the template using the native Grid field ...


5

So far I've discovered and fixed one case and will add more here if discovered. File: mod.playa.php Line: 550 FROM $sql = 'SELECT DISTINCT(rel.child_entry_id) AS entry_id TO $sql = 'SELECT DISTINCT rel.child_entry_id AS entry_id, rel.parent_entry_id, rel.parent_field_id, rel.parent_row_id, rel.parent_col_id, rel.parent_var_id, rel.rel_order


4

Is this not a case for using {switch="||do-thing"}? {switch='<div class="row">||'} {cf_about_us_biographies} <div class="four columns"> <img src="{cf_about_us_bio_photo}"> <ul class="accordion"> <li> <div class="title"> <...


4

Doh! The answer is to use the documented var_prefix parameter so I can then reference the entry's {title} field as normal :$ That Brandon fella has thought of (nearly) everything :)


4

To make sure extra processing is done before the var is put in the template, use the tag syntax rather than the variable syntax: {exp:low_variables:single var="my_wygwam_var"}


4

Take a look at the columns in exp_matrix_data table in the database. Does it have a field var_id? If no, then the version you should set is 2.2. If yes, does it have a field is_draft? If no, then the version you should set is 2.3 If yes, then the version you should set is 2.5.6 Now, set the version number we determined in the previous three steps for the ...


4

After updating Playa and it failing to run it's update forDB schema, here's what you can try: Take a look at the columns in exp_playa_relationships table in the database. Does it have a field parent_var_id? If no, then the version you should set is 4.1. If yes, does it have a field parent_is_draft? If no, then the version you should set is 4.3 If yes, ...


4

P&T switch has moved into a new bundle of old dive bar addons called Field Pack as of August 2013. You should update to that and everything will be working fine. Updating is simple, but do read the docs. http://docs.pixelandtonic.com/fieldpack/installation.html#updating-from-the-old-dive-bar-fieldtypes


4

You can use Matrix's search parameter to return only the rows of interest: {report_articles search:report_type="=Land"} Show the Land data {/report_articles}


3

I just came across this issue too and it turns out while the EE filemanager doesn't mind a missing trailing slash on the server path, Assets does. Make sure your upload directory server path has a trailing slash. Resolved the issue for me.


3

I have solved this issue. The Assets error message did not seem very helpful, it was inconsistent with the issue. The Assets response implied the Amazon credentials were wrong, but they were not. So therefore I needed to debug tha actual Amazon response. So in the function listBuckets() in system/third_party/assets/sourses/s3/lib/S3.php I could see there ...


3

To get the tag pair to work with EE 2.5.5 and PT Field Pack 1.0.3 you need to modify the ft.pt_checkboxes.php file and add has_array_data = true; class Pt_checkboxes_ft extends PT_Multi_Fieldtype { var $info = array( 'name' => 'P&amp;T Checkboxes', 'version' => PT_FIELD_PACK_VER ); var $class = 'pt_checkboxes'; var $has_array_data =...


3

You can't do this with a Matrix tag, but you could use Stash to set a list of the Matrix rows, then get the unique values only. https://github.com/croxton/Stash/wiki/%7Bexp%3Astash%3Aget_list%7D#unique---yes--no- matrix set_list {exp:channel:entries channel="blog" entry_id="123"} {exp:stash:set_list name="blog_related_entries" parse_tags="yes" save="...


3

P&T Field Pack has been renamed into/superseded by Field Pack.


3

I've hacked Playa before to do this same thing. Just modify /playa/views/entry.php Using version 4.3.3, I added the entry_id for each entry like this in line 2 of entry.php. Original: <a> <span class="playa-entry-status <?=str_replace(' ', '_',$entry->status)?>">&bull;</span> <?=$entry->title?></a>...


3

Can I tell WYGWAM not to wrap text that starts and ends with {} in a paragraph tag? If not, other suggestions?? For WYGWAM, I don't think you can do that specifically, but you might be able to modify how it responds to paragraph tags by adjusting the Advanced Settings for your configuration. If that doesn't work, you could try Streeng to kill the empty &...


3

Make sure that the particular Wygwam editor configuration assigned to this custom field has a chosen upload directory. To double check this go to... Modules > Wygwam > Editor Configurations ...and in the editor configuration settings you will see a select menu labelled "Upload Directory" where you assign this.


3

I've done it before. Take a look at the display_field method of ft.wygwam.php. You'll see that it's fairly simple to instantiate a WYGWAM field. A few calls to the Wygwam_Helper class to load the JS/CSS. There are also some helpers for properly formatting the data. You'll need a textarea with an id, and also the ID number of a WYGWAM config. I don't want to ...


Only top voted, non community-wiki answers of a minimum length are eligible